Bug 163108 - [maintainer update] update net/rabbitmq-c-devel distinfo
Summary: [maintainer update] update net/rabbitmq-c-devel distinfo
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Roman Bogorodskiy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-07 09:40 UTC by rabbitmq
Modified: 2011-12-08 15:34 UTC (History)
0 users

See Also:


Attachments
file.diff (1.19 KB, patch)
2011-12-07 09:40 UTC, rabbitmq
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rabbitmq 2011-12-07 09:40:07 UTC
The hg.rabbitmq.com site is now serving out different sized tarballs of the same data as before. This patch updates the distinfo to fix this issue.

Fix: Patch attached with submission follows:
Comment 1 Roman Bogorodskiy freebsd_committer 2011-12-08 11:52:26 UTC
It would help a lot if you publish diff between the old and the new tarball
to make sure nothing malicious has been added.

Roman Bogorodskiy
Comment 2 rabbitmq 2011-12-08 13:54:57 UTC
Unfortunately I don't have copies of the versions in the distinfo as =
they've not appeared on ftp.freebsd.org, but the previous revisions I =
can compare to those on ftp.freebsd.org. These have changed such that

diff -ruN freebsd/rabbitmq-codegen-fc46914f99b7/.hg_archival.txt =
rabbitmq/rabbitmq-codegen-fc46914f99b7/.hg_archival.txt
--- freebsd/rabbitmq-codegen-fc46914f99b7/.hg_archival.txt	=
2010-03-18 16:34:15.000000000 +0000
+++ rabbitmq/rabbitmq-codegen-fc46914f99b7/.hg_archival.txt	=
2010-03-18 16:34:15.000000000 +0000
@@ -1,2 +1,5 @@
 repo: 128e577c9e05d99bb860650c467600e2277995a0
 node: fc46914f99b759de8642f43059159ab08fb0d983
+branch: amqp_0_9_1
+latesttag: rabbitmq_v1_7_2
+latesttagdistance: 4

diff -ruN freebsd/rabbitmq-c-17b9fb0d63d3/.hg_archival.txt =
rabbitmq/rabbitmq-c-17b9fb0d63d3/.hg_archival.txt
--- freebsd/rabbitmq-c-17b9fb0d63d3/.hg_archival.txt	2010-03-31 =
02:28:56.000000000 +0100
+++ rabbitmq/rabbitmq-c-17b9fb0d63d3/.hg_archival.txt	2010-03-31 =
02:28:56.000000000 +0100
@@ -1,2 +1,5 @@
 repo: eb34adcb47da72bebae1f936d87fe303d3890743
 node: 17b9fb0d63d39018c8afa67bfc9711266f053ef0
+branch: amqp_0_9_1
+latesttag: librabbitmq-0.1-amqp_0_9_1
+latesttagdistance: 4

I've also contacted rabbitmq and they have upgraded the hgweb =
application which serves these files. They've pointed out that hg, like =
git, uses cryptographic hashes to identify revisions so that previous =
revisions cannot be modified. The only difference seems to be the =
addition of extra information included when the archives are created by =
hgweb.

I've also confirmed that the same types of differences apply to the =
net/rabbitmq-c distfiles which are updated in ports/163107.

--
Geoff=
Comment 3 Roman Bogorodskiy freebsd_committer 2011-12-08 15:13:19 UTC
Responsible Changed
From-To: freebsd-ports-bugs->novel

I will take it.
Comment 4 dfilter service freebsd_committer 2011-12-08 15:25:09 UTC
novel       2011-12-08 15:24:56 UTC

  FreeBSD ports repository

  Modified files:
    net/rabbitmq-c-devel Makefile distinfo 
  Log:
  Un-break by fixing distinfo. Distfile change was confirmed by
  upstream and is caused by upgrading of hgweb application serving these
  files.
  
  PR:             163108
  Submitted by:   Geoff Garside (maintainer)
  Feature safe:   yes
  
  Revision  Changes    Path
  1.9       +0 -2      ports/net/rabbitmq-c-devel/Makefile
  1.4       +4 -4      ports/net/rabbitmq-c-devel/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Roman Bogorodskiy freebsd_committer 2011-12-08 15:34:33 UTC
State Changed
From-To: open->closed

Committed, thanks!