Bug 163679 - [NEW PORT] sysutils/sysrc: Utility to get or set rc.conf(5) values
Summary: [NEW PORT] sysutils/sysrc: Utility to get or set rc.conf(5) values
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-28 20:20 UTC by Devin Teske
Modified: 2011-12-31 13:30 UTC (History)
0 users

See Also:


Attachments
file.shar (1.96 KB, text/plain)
2011-12-28 20:20 UTC, Devin Teske
no flags Details
sysrc.shar (2.01 KB, application/octet-stream)
2011-12-30 02:50 UTC, devin.teske
no flags Details
sysrc.shar (1.94 KB, application/octet-stream)
2011-12-31 02:50 UTC, devin.teske
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Teske 2011-12-28 20:20:09 UTC
New Port sysutils/sysrc.

Sysrc is a robust utility for managing rc.conf(5) from the command-line without
a text-editor. Feature-highlights include (but are not limited to):
  - Environment variable taint prevention
  - Shell taint checking (aka boot-regression prevention)
  - File-access race-condition prevention
  - File-structure sensitivity/preservation
  - Intelligent syntax handling
  - Execution performance optimizations
  - Detailed safety measures
  - Support for jails (both legacy and current)



WWW: http://druidbsd.sourceforge.net/
Comment 1 devin.teske 2011-12-30 02:50:26 UTC
Working with Stefan Esser, we've formed a new Makefile and a man-page. Attached
is the new files.
-- 
Devin

_____________
The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. Thank you.
Comment 2 devin.teske 2011-12-31 02:50:08 UTC
Marco Steinbach <coco@executive-computing.de> found a bug in 9.0-CURRENT.

The bug has been fixed in version 3.2.1 of sysrc.

A new shar is attached, updating the port Makefile as necessary.

Marco also found a portion of the man-page to be confusing and adds a crontab(5) example to the man-page.

Stefan Esser also pointed out some issues in the man-page that were addressed in this new revision.

Thanks again for reviewing!
-- 
Devin

_____________
The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. Thank you.
Comment 3 Stefan Eßer freebsd_committer 2011-12-31 13:06:12 UTC
State Changed
From-To: open->closed

Latest version of port (in PR) was commited without further change.
Comment 4 dfilter service freebsd_committer 2011-12-31 13:06:12 UTC
se          2011-12-31 13:06:02 UTC

  FreeBSD ports repository (src committer)

  Modified files:
    sysutils             Makefile 
  Added files:
    sysutils/sysrc+      Makefile distinfo pkg-descr 
  Log:
  The sysrc utility performs easy and safe editing of rc.conf style enries
  in configuration files.
  
  PR:             163679
  Submitted by:   Devin Teske (dteske@ at vicor dot com)
  Feature safe:   yes
  
  Revision  Changes    Path
  1.1362    +1 -0      ports/sysutils/Makefile
  1.1       +25 -0     ports/sysutils/sysrc+/Makefile (new)
  1.1       +2 -0      ports/sysutils/sysrc+/distinfo (new)
  1.1       +12 -0     ports/sysutils/sysrc+/pkg-descr (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 dfilter service freebsd_committer 2011-12-31 13:22:55 UTC
se          2011-12-31 13:22:47 UTC

  FreeBSD ports repository (src committer)

  Added files:
    sysutils/sysrc       Makefile distinfo pkg-descr 
  Removed files:
    sysutils/sysrc+      Makefile distinfo pkg-descr 
  Log:
  The sysrc utility performs easy and safe editing of rc.conf style enries
  in configuration files.
  
  This port had been added from a temporary directory by accident is moved
  to its correct place with this commit. A commit to "modules" will follow
  immdetiately thereafter. Sorry!
  
  PR:             163679
  Submitted by:   Devin Teske (dteske@ at vicor dot com)
  Feature safe:   yes
  
  Revision  Changes    Path
  1.2       +0 -25     ports/sysutils/sysrc+/Makefile (dead)
  1.2       +0 -2      ports/sysutils/sysrc+/distinfo (dead)
  1.2       +0 -12     ports/sysutils/sysrc+/pkg-descr (dead)
  1.1       +25 -0     ports/sysutils/sysrc/Makefile (new)
  1.1       +2 -0      ports/sysutils/sysrc/distinfo (new)
  1.1       +12 -0     ports/sysutils/sysrc/pkg-descr (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"