Bug 166652 - [patch] devel/p5-POE-Component-Child: unbreak test indefinite hang
Summary: [patch] devel/p5-POE-Component-Child: unbreak test indefinite hang
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-04 19:40 UTC by Rachel Flynn
Modified: 2012-04-12 04:10 UTC (History)
1 user (show)

See Also:


Attachments
devel__p5-POE-Component-Child.patch (771 bytes, patch)
2012-04-04 19:40 UTC, Rachel Flynn
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rachel Flynn 2012-04-04 19:40:01 UTC
When test target is run, tests will hang indefinitely, caused by a missing
write hook.

Fix: Obtained from: https://rt.cpan.org/Public/Bug/Display.html?id=70701


How-To-Repeat: cd /usr/ports/devel/p5-POE-Component-Child
make build
cd `make -V WRKSRC` && make test
Comment 1 Edwin Groothuis freebsd_committer 2012-04-04 19:40:19 UTC
Responsible Changed
From-To: freebsd-ports-bugs->perl

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Steve Wills freebsd_committer 2012-04-06 17:04:08 UTC
Responsible Changed
From-To: perl->swills

I'll take it.
Comment 3 Steve Wills freebsd_committer 2012-04-12 04:00:36 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 4 dfilter service freebsd_committer 2012-04-12 04:00:46 UTC
swills      2012-04-12 03:00:24 UTC

  FreeBSD ports repository

  Modified files:
    devel/p5-POE-Component-Child Makefile 
  Added files:
    devel/p5-POE-Component-Child/files patch-test.pl 
  Log:
  - Avoid use of SITE_PERL in DEPENDS
  - Fix tests [1]
  
  PR:             ports/166652 [1]
  Submitted by:   Mel Flynn <rflynn@acsalaska.net> [1]
  
  Revision  Changes    Path
  1.8       +2 -2      ports/devel/p5-POE-Component-Child/Makefile
  1.1       +11 -0     ports/devel/p5-POE-Component-Child/files/patch-test.pl (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"