Bug 167380 - updated net/netatalk 2.2.2 breaks file transfers due to incorrect use of sendfile
updated net/netatalk 2.2.2 breaks file transfers due to incorrect use of send...
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Joe Marcus Clarke
Depends on:
  Show dependency treegraph
Reported: 2012-04-27 23:10 UTC by razzfazz
Modified: 2012-04-29 01:50 UTC (History)
0 users

See Also:

file.txt (1.37 KB, text/plain)
2012-04-27 23:10 UTC, razzfazz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description razzfazz 2012-04-27 23:10:10 UTC
After the recent update to version 2.2.2, all file transfers that use sendfile return corrupt data and/or terminate the connection.

This appears to be a known issue in 2.2.2 that is caused by improper use of FreeBSD's sendfile; it was fixed upstream on Feb 9:


This will apparently be rolled into 2.2.3 upstream; however, since 2.2.2 in its current state for all intents and purposes does not work on FreeBSD, please consider integrating the linked patch into the FreeBSD port.

Fix: Backport patch from upstream:


Patch attached with submission follows:
How-To-Repeat: Read any file larger than a few kilobytes from a Netatalk share.
Comment 1 Edwin Groothuis freebsd_committer 2012-04-28 21:21:37 UTC
Responsible Changed
From-To: freebsd-ports-bugs->marcus

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Joe Marcus Clarke freebsd_committer 2012-04-29 01:48:44 UTC
State Changed
From-To: open->closed

Committed, thanks!
Comment 3 dfilter freebsd_committer 2012-04-29 01:48:49 UTC
marcus      2012-04-29 00:48:35 UTC

  FreeBSD ports repository

  Added files:
    net/netatalk/files   patch-libatalk_adouble_ad_sendfile.c 
  Fix usage of sendfile on FreeBSD.
  PR:             167380
  Submitted by:   Daniel Becker <razzfazz@gmail.com>
  Obtained from:  netatalk git
  Revision  Changes    Path
  1.1       +20 -0     ports/net/netatalk/files/patch-libatalk_adouble_ad_sendfile.c (new)
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"