Bug 167641 - editors/libreoffice:
Summary: editors/libreoffice:
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-06 13:20 UTC by O. Hartmann
Modified: 2014-02-27 14:55 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2012-05-06 13:20:07 UTC
Updating or building port editors/libreoffice (LibreOffice 3.5.2.2) on both FreeBSD 9-STABLE/amd64 and FreeBSD 10-CURRENT/amd64 fails, no matter whether compilers CLANG (3.0 on FreeBSD 9, 3.1 on FreeBSD 10), legacy GCC 4.2.1 (on all platforms) or GCC 4.6.4-20120420 (on all platforms) are used, with the below showed error message. On all platforms, on all attempts it is always the same sub module that cause the fail, no matter why.

Since all boxes are "grown", that means they have been used for a while after installation, I also rebuild all requisite ports via "portmaster -f". It has been witnessed that after installation of a base system of FreeBSD, no matter what release, LibreOffice (3.4) build well from sources, even with CLANG (as on a Laptop, 4GB RAM, Core i3 CPU, FreeBSD 9-STABLE/amd64). Updating an existing installation has failed for years in nearly every case, starting with OpenOffice.

Trying to rebuild as suggested endes up in the same error again.

[...]
[ build CHK ] cppcanvas
[ build CHK ] loaded modules: cppcanvas

cppcanvas deliver
Module 'cppcanvas' delivered successfully. 0 files copied, 0 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/ucb/source/ucp/cmis

 it seems that the error is inside 'ucb', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd ucb
rm -Rf /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/ucb/unxfbsd.pro # optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2'
gmake: *** [source-env-and-recurse] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [build] Error code 1

Stop in /usr/ports/editors/libreoffice.

===>>> make failed for editors/libreoffice
===>>> Aborting update

===>>> Update for editors/libreoffice failed
===>>> Aborting update

===>>> Update for german/libreoffice failed
===>>> Aborting update

How-To-Repeat: Try building LibreOffice or even better, try updating existing LibreOffice on a productive box and not on a show-case of a fresh installed system.
Comment 1 Edwin Groothuis freebsd_committer 2012-05-06 13:20:23 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Martin Wilke freebsd_committer 2014-02-27 14:54:59 UTC
State Changed
From-To: open->closed

i think that is solved since some ages.