Bug 167989 - databases/evolution-data-server build fails on FreeBSD 10 with new Heimdal
databases/evolution-data-server build fails on FreeBSD 10 with new Heimdal
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: gnome
Depends on:
  Show dependency treegraph
Reported: 2012-05-17 02:50 UTC by Don Lewis
Modified: 2012-05-20 17:30 UTC (History)
1 user (show)

See Also:

file.diff (868 bytes, patch)
2012-05-17 02:50 UTC, Don Lewis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Don Lewis freebsd_committer 2012-05-17 02:50:02 UTC
The databases/evolution-data-server port fails to build on FreeBSD 10 since
Heimdel was upgraded to 1.5.1.

  CC     libcamel_provider_1_2_la-camel-sasl-gssapi.lo
In file included from camel-sasl-gssapi.c:51:
/usr/include/gssapi.h:3:2: warning: #warning "this file includes <gssapi.h> which is deprecated, use <gssapi/gssapi.h> instead"
camel-sasl-gssapi.c: In function 'gssapi_set_exception':
camel-sasl-gssapi.c:157: error: implicit declaration of function 'error_message'
camel-sasl-gssapi.c:157: warning: nested extern declaration of 'error_message'
camel-sasl-gssapi.c:157: warning: assignment makes pointer from integer without a cast
gmake[4]: *** [libcamel_provider_1_2_la-camel-sasl-gssapi.lo] Error 1
gmake[4]: Leaving directory `/usr/ports/databases/evolution-data-server/work/evolution-data-server-2.32.1/camel'

The problem is that <com_err.h>, which declares error_message(), is not being
included.  The reason for that problem is that the port's configure test
for this header is failing because <com_err.h> includes <com_right.h>, which
uses size_t in the function prototype for com_right_r(), but size_t has not
been declared because the compile test for this header doesn't include

The com_err(3) man page imported with the new Heimdel distribution says
that the proper list of includes is:

     #include <stdio.h>
     #include <stdarg.h>
     #include <krb5/com_err.h>

though com_err.h is still being installed directly under /usr/include in
FreeBSD 10.  It appears that this relies on <stdio.h> defining size_t.

Fix: The configure script should probably be enhanced to handle the new Heimdel
version, but that is probably best handled upstream.  The following patch
uses config.cache to bypass the test for <com_err.h> and just force it
to be included.
Attempt to build the port on a recent version of FreeBSD 10.
Comment 1 Edwin Groothuis freebsd_committer 2012-05-17 02:50:26 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 mezz freebsd_committer 2012-05-20 17:27:40 UTC
State Changed
From-To: open->closed

Committed, thanks!
Comment 3 dfilter freebsd_committer 2012-05-20 17:27:46 UTC
mezz        2012-05-20 16:27:31 UTC

  FreeBSD ports repository

  Modified files:
    databases/evolution-data-server/files patch-configure 
  Fix the build with Heimdal 1.5.x.
  PR:             ports/167989
  Reported by:    truckman
  Revision  Changes    Path
  1.13      +23 -5     ports/databases/evolution-data-server/files/patch-configure
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"