Bug 168319 - graphics/qiviewer: Not displaying image jpeg
graphics/qiviewer: Not displaying image jpeg
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Stefan Walter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 23:10 UTC by rflynn
Modified: 2013-05-13 21:40 UTC (History)
1 user (show)

See Also:


Attachments
qpdfview.diff (759 bytes, patch)
2013-04-29 15:20 UTC, g.veniamin
no flags Details | Diff
file.dat (561 bytes, text/plain; charset=koi8-r)
2013-04-29 15:20 UTC, g.veniamin
no flags Details
fixed-qiviewer.patch (1018 bytes, patch)
2013-05-13 18:27 UTC, g.veniamin
no flags Details | Diff
file.dat (332 bytes, text/plain; charset=us-ascii)
2013-05-13 18:27 UTC, g.veniamin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description rflynn 2012-05-24 23:10:02 UTC
When graphics/qiviewer is installed without having a full KDE desktop,
in my case a trimmed down x11-wm/xfce4 (no PRINT, no MIXER, no GDM) then
qiviewer will not display JPEG images.
It will successfully show PNG images, which leads me to believe that the
root cause is that the program relies on QtGUI providing the image support.

Since the FreeBSD QtGUI only links with png, no other image formats are
available to it. Jpeg is available at compile and runtime.

I haven't tested if the application works in full KDE environment (ENOTIME).

Fix: 

Possible fix that should be examined if linking QtGui with jpeg makes this
work.
How-To-Repeat: 
pre-req: delete all qt4-* ports or have a clean install and then install
         for example xfce or fvwm.
make -C /usr/ports/graphics/qiviewer install

Try to open a folder containing jpg images. Size will be displayed but the
actual image screen is blank.
Using convert from ImageMagick to change the image to png, will show the
image in qiviewer correctly.
Comment 1 Edwin Groothuis freebsd_committer 2012-05-24 23:10:10 UTC
Maintainer of graphics/qiviewer,

Please note that PR ports/168319 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/168319

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2012-05-24 23:10:12 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Raphael Kubo da Costa freebsd_committer 2012-06-01 03:10:40 UTC
Mel Flynn <rflynn@acsalaska.net> writes:

> Possible fix that should be examined if linking QtGui with jpeg makes this
> work.

Hmm. We already pass -system-libpng, -system-libjpeg and friends to Qt's
configure program. Do you have graphics/qt4-imageformats installed?
Comment 4 rflynn 2012-06-01 14:19:28 UTC
On 1-6-2012 4:10, Raphael Kubo da Costa wrote:
> Hmm. We already pass -system-libpng, -system-libjpeg and friends to Qt's
> configure program. Do you have graphics/qt4-imageformats installed?

Negative.
Also not marked in that port's dependencies.

Qt4 related ports on the build host:
qt4-assistant-4.7.4_1
qt4-clucene-4.7.4
qt4-corelib-4.7.4
qt4-dbus-4.7.4
qt4-declarative-4.7.4
qt4-designer-4.7.4_1
qt4-doc-4.7.4
qt4-gui-4.7.4_1
qt4-help-4.7.4
qt4-linguist-4.7.4_1
qt4-network-4.7.4
qt4-opengl-4.7.4
qt4-qmake-4.7.4
qt4-qt3support-4.7.4
qt4-qtestlib-4.7.4
qt4-rcc-4.7.4
qt4-script-4.7.4
qt4-sql-4.7.4
qt4-sqlite-plugin-4.7.4
qt4-svg-4.7.4
qt4-uic-4.7.4
qt4-webkit-4.7.4
qt4-xml-4.7.4
qt4-xmlpatterns-4.7.4

Package dependencies recorded:
@pkgdep xineramaproto-1.2.1
@pkgdep xextproto-7.2.0
@pkgdep renderproto-0.11.1
@pkgdep randrproto-1.3.2
@pkgdep kbproto-1.0.5
@pkgdep inputproto-2.0.2
@pkgdep fixesproto-5.0
@pkgdep expat-2.0.1_2
@pkgdep gnome_subr-1.0
@pkgdep hicolor-icon-theme-0.12
@pkgdep python27-2.7.3
@pkgdep perl-threaded-5.12.4_4
@pkgdep png-1.4.11
@pkgdep xdg-utils-1.0.2_7
@pkgdep pkg-config-0.25_1
@pkgdep freetype2-2.4.9_1
@pkgdep fontconfig-2.8.0_2,1
@pkgdep xproto-7.0.22
@pkgdep libICE-1.0.7,1
@pkgdep libSM-1.2.0,1
@pkgdep libXdmcp-1.1.0
@pkgdep libXau-1.0.6
@pkgdep pcre-8.30_2
@pkgdep libpthread-stubs-0.3_3
@pkgdep libxcb-1.7
@pkgdep libX11-1.4.4,1
@pkgdep libXrender-0.9.6
@pkgdep libXfixes-5.0
@pkgdep libXcursor-1.1.12
@pkgdep libXt-1.1.1,1
@pkgdep libXext-1.3.0_1,1
@pkgdep libXinerama-1.1.1,1
@pkgdep libXi-1.4.5,1
@pkgdep libXrandr-1.3.2
@pkgdep icu-4.8.1.1_1
@pkgdep libiconv-1.13.1_1
@pkgdep libxml2-2.7.8_2
@pkgdep dbus-1.4.14_2
@pkgdep gettext-0.18.1.1
@pkgdep glib-2.28.8_4
@pkgdep qt4-corelib-4.7.4
@pkgdep qt4-gui-4.7.4_1
@pkgdep qt4-xml-4.7.4
@pkgdep qt4-dbus-4.7.4
-- 
Mel
Comment 5 Raphael Kubo da Costa freebsd_committer 2012-06-01 21:48:54 UTC
Mel Flynn <rflynn@acsalaska.net> writes:

> Negative.
> Also not marked in that port's dependencies.

Please try installing it and checking if things work fine. If they do,
the port's dependencies need to be adjusted.
Comment 6 g.veniamin 2012-06-04 08:58:50 UTC
Hi,
I'm a soon check it.
Comment 7 rflynn 2012-06-07 15:19:19 UTC
On 1-6-2012 20:17, Raphael Kubo da Costa wrote:
> Mel Flynn <rflynn@acsalaska.net> writes:
> 
>> On 1-6-2012 4:10, Raphael Kubo da Costa wrote:
>>> Mel Flynn <rflynn@acsalaska.net> writes:
>>>
>>>> When graphics/qiviewer is installed without having a full KDE desktop,
>>>> in my case a trimmed down x11-wm/xfce4 (no PRINT, no MIXER, no GDM) then
>>>> qiviewer will not display JPEG images.
>>>> It will successfully show PNG images, which leads me to believe that the
>>>> root cause is that the program relies on QtGUI providing the image support.
>>>>
>>>> Since the FreeBSD QtGUI only links with png, no other image formats are
>>>> available to it. Jpeg is available at compile and runtime.
>>> <snip>
>>>> Possible fix that should be examined if linking QtGui with jpeg makes this
>>>> work.
>>>
>>> Hmm. We already pass -system-libpng, -system-libjpeg and friends to Qt's
>>> configure program. Do you have graphics/qt4-imageformats installed?
>>
>> Negative.
>> Also not marked in that port's dependencies.
> 
> Please try installing it and checking if things work fine. If they do,
> the port's dependencies need to be adjusted.

No luck. I've added imageformats to the qt components in the port's
Makefile and rebuilt qiviewer. Still unable to view jpeg images.
I did not rebuild qt4-gui.

-- 
Mel
Comment 8 Stefan Walter freebsd_committer 2013-04-29 11:13:46 UTC
Hello Veniamin, hello Mel,

there hasn't been an update on this PR on graphics/qiviewer (see [1]) for
quite a while. What is the current state of things here? Does the problem
still exist, or should the PR be closed?

Best regards,
Stefan

[1]: http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/168319
Comment 9 Stefan Walter freebsd_committer 2013-04-29 11:13:56 UTC
Responsible Changed
From-To: freebsd-ports-bugs->stefan

Track this while waiting for feedback.
Comment 10 g.veniamin 2013-04-29 12:25:05 UTC
Hello,

I'm trying fix it now.=20

On 29.04.2013, at 2:13 =D0=CF=D3=CC=C5 =D0=CF=CC=D5=C4=CE=D1, Stefan Walter <=
stefan@freebsd.org> wrote:

> Hello Veniamin, hello Mel,
>=20
> there hasn't been an update on this PR on graphics/qiviewer (see [1]) for
> quite a while. What is the current state of things here? Does the problem
> still exist, or should the PR be closed?
>=20
> Best regards,
> Stefan
>=20
> [1]: http://www.freebsd.org/cgi/query-pr.cgi?pr=3Dports/168319
Comment 11 g.veniamin 2013-04-29 15:20:22 UTC
Fixed. See attached patch.
Comment 12 Stefan Walter freebsd_committer 2013-04-29 15:52:42 UTC
Mel,

can you verify that the patch sent by Veniamin fixes your problem?

Best regards,
Stefan
Comment 13 Stefan Walter freebsd_committer 2013-04-30 12:45:05 UTC
For the record - my feedback request did not reach the submitter:

> This is the mail system at host sockeye.acsalaska.net.
> 
> I'm sorry to have to inform you that your message could not
> be delivered to one or more recipients. It's attached below.
> 
> For further assistance, please send mail to postmaster.
> 
> If you do so, please include this problem report. You can
> delete your own text from the attached returned message.
> 
> 
> <rflynn@acsalaska.net>: Mailbox full
Comment 14 Stefan Walter freebsd_committer 2013-04-30 13:23:37 UTC
Hi Veniamin,

I noticed just now: Your patch is for print/qpdfview, while this PR is
about graphics/qiviewer...

Best regards,
Stefan
Comment 15 g.veniamin 2013-04-30 13:52:11 UTC
Hello,

Ooops, I'll try fix it. I'm sorry about mistake in port name but I fixed qpd=
fview with same problem.=20

On 30.04.2013, at 4:23 =D0=CF=D3=CC=C5 =D0=CF=CC=D5=C4=CE=D1, Stefan Walter <=
stefan@freebsd.org> wrote:

> Hi Veniamin,
>=20
> I noticed just now: Your patch is for print/qpdfview, while this PR is
> about graphics/qiviewer...
>=20
> Best regards,
> Stefan
Comment 16 Stefan Walter freebsd_committer 2013-05-12 17:16:42 UTC
Hi Veniamin,

Veniamin Gvozdikov, 30.04.13, 14:52h CEST:

> Hello,
> 
> Ooops, I'll try fix it. I'm sorry about mistake in port name but I fixed qpdfview with same problem. 

any news on this issue?

Best regards,
Stefan
Comment 17 g.veniamin 2013-05-13 18:27:13 UTC
Hi Stefan,

I reproduced bug and fixed it. See attached patch.
Comment 18 Stefan Walter freebsd_committer 2013-05-13 21:32:16 UTC
State Changed
From-To: feedback->closed

Fix committed, thanks!
Comment 19 dfilter freebsd_committer 2013-05-13 21:32:22 UTC
Author: stefan
Date: Mon May 13 20:32:02 2013
New Revision: 318130
URL: http://svnweb.freebsd.org/changeset/ports/318130

Log:
  Add missing 'imageformats' to USE_QT4.
  
  PR:		168319
  Submitted by:	Mel Flynn <rflynn@acsalaska.net>
  Reviewed by:	Veniamin Gvozdikov <g.veniamin@googlemail.com> (maintainer)

Modified:
  head/graphics/qiviewer/Makefile
  head/graphics/qiviewer/pkg-descr

Modified: head/graphics/qiviewer/Makefile
==============================================================================
--- head/graphics/qiviewer/Makefile	Mon May 13 20:31:53 2013	(r318129)
+++ head/graphics/qiviewer/Makefile	Mon May 13 20:32:02 2013	(r318130)
@@ -3,7 +3,7 @@
 
 PORTNAME=	qiviewer
 PORTVERSION=	0.5.0
-PORTREVISION=	1
+PORTREVISION=	2
 CATEGORIES=	graphics
 MASTER_SITES=	GOOGLE_CODE
 
@@ -13,8 +13,8 @@ COMMENT=	Fast and lightweight image view
 LICENSE=	GPLv2
 
 USE_BZIP2=	yes
-USE_QT4=	gui xml dbus linguist_build qmake_build moc_build \
-		rcc_build uic_build
+USE_QT4=	gui xml dbus imageformats linguist_build qmake_build \
+		moc_build rcc_build uic_build
 QMAKEFLAGS+=	PREFIX="${PREFIX}"
 
 PLIST_FILES=	bin/qiviewer \

Modified: head/graphics/qiviewer/pkg-descr
==============================================================================
--- head/graphics/qiviewer/pkg-descr	Mon May 13 20:31:53 2013	(r318129)
+++ head/graphics/qiviewer/pkg-descr	Mon May 13 20:32:02 2013	(r318130)
@@ -1,4 +1,4 @@
 This program has been written with help of Qt library, to be a
 lightweight image viewer, similar to eog or viewnior for Gnome.
 
-WWW:	http://code.google.com/p/qiviewer/
+WWW: http://code.google.com/p/qiviewer/
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"