Bug 168323 - graphics/ImageMagick-nox11 install failure
graphics/ImageMagick-nox11 install failure
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Martin Matuska
Depends on:
  Show dependency treegraph
Reported: 2012-05-25 01:40 UTC by Adam Weinberger
Modified: 2012-05-28 23:08 UTC (History)
0 users

See Also:

IMfail.txt (57.92 KB, text/plain)
2012-05-25 01:40 UTC, Adam Weinberger
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Weinberger freebsd_committer 2012-05-25 01:40:00 UTC
I get this error on every one of my machines. I am using some specific
config settings so I am including showconfig, as well as the entire build
and install output (except for the documentation stuff).

The coders directory isn't being installed at all. I have no idea whether
that is intentional or a byproduct of my settings. Either way, install fails.
Comment 1 Edwin Groothuis freebsd_committer 2012-05-25 01:40:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->mm

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 turutani 2012-05-25 02:18:48 UTC

Me too.
It might caused by the change around 5030-th line of Makefile.in;
I do not know why "list2" is null string (it indeed is null, as I checked).
Comment 3 dfilter freebsd_committer 2012-05-25 23:13:21 UTC
mm          2012-05-25 22:13:11 UTC

  FreeBSD ports repository

  Modified files:
    graphics/ImageMagick Makefile pkg-plist 
  Do not touch .keep files if not using WITH_IMAGEMAGICK_MODULES
  PR:             ports/168323
  Reported by:    Adam Weinberger <adamw@freebsd.org>
  Revision  Changes    Path
  1.345     +4 -2      ports/graphics/ImageMagick/Makefile
  1.147     +2 -2      ports/graphics/ImageMagick/pkg-plist
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Adam Weinberger freebsd_committer 2012-05-28 23:07:27 UTC
State Changed
From-To: open->closed

mm identified the problem as stemming from the WITHOUT_MODULES option. 
He committed a fix and it works for me. Thanks, mm! I'm closing this PR 
as successfully fixed.