Bug 168343 - editors/libreoffice 3.5.2 missing dependency (graphics/sampleicc)
Summary: editors/libreoffice 3.5.2 missing dependency (graphics/sampleicc)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-26 00:30 UTC by grarpamp
Modified: 2013-02-15 17:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grarpamp 2012-05-26 00:30:01 UTC
The binary package for sampleicc 1.6.6 (as required by pkgdep in binary package libreoffice 3.5.2 +CONTENTS) is not found on the FTP server, so the install of libreoffice 3.5.2 is incomplete :(

Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8-stable/All/libreoffice-3.5.2_2.tbz... Done.
..
Error: Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8-stable/All/sampleicc-1.6.6.tbz: File unavailable (e.g., file not found, no access)
..
pkg_add: can't open dependency file '/usr/local/pkg/sampleicc-1.6.6/+REQUIRED_BY'!
dependency registration is incomplete


Older libreoffice 3.4.5 worked fine, so this would be a regression I guess (though it had no dependency on sampleicc).

Fix: 

Update the freebsd.org portbuild and distribution system to publish the binary package for sampleicc on the FTP servers. Thanks :)
How-To-Repeat: pkg_add ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8-stable/All/libreoffice-3.5.2_2.tbz
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-05-26 05:13:36 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

This seems to be correct.  For some reason sampleicc-1.6.6 is in restricted.sh 
on i386/8/builds/*, although at a glance I don't see why.  The package does 
indeed build. 

To submitter: you should be able to just 'make install' in graphics/samplieicc 
in the meantime.
Comment 2 grarpamp 2012-05-29 17:42:12 UTC
> For some reason sampleicc-1.6.6 is in restricted.sh on i386/8/builds/*,
> although at a glance I don't see why. The package does indeed build.

The license for sampleicc appears to be standard BSD. So that can't
be why. If this "restricted.sh / i386/8/builds/*" tree is under private change
control, maybe there is a commit note?

> you should be able to just 'make install' in graphics/samplieicc
> in the meantime.

Unfortunately I've not deployed the ports infrastructure yet. Only packages,
for things that aren't compiled locally under local infrastructure.
Comment 3 grarpamp 2012-07-05 07:43:42 UTC
Marking current, as observed with newer revision of pkg: libreoffice-3.5.2_4.tbz
Comment 4 grarpamp 2012-09-19 20:37:39 UTC
Marking current, as observed with newer revision of pkg: libreoffice-3.5.6_1
Comment 5 Jung-uk Kim freebsd_committer 2013-02-15 16:58:47 UTC
State Changed
From-To: open->closed

LibreOffice was updated to 3.6.5 and SampleICC was obsoleted by lcms2.