Bug 169724 - [PATCH] x11/xscreensaver unbreak PAM authentication
Summary: [PATCH] x11/xscreensaver unbreak PAM authentication
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Doug Barton
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-09 02:00 UTC by John Marshall
Modified: 2012-07-09 03:40 UTC (History)
0 users

See Also:


Attachments
xscreensaver-5.18.diff (624 bytes, patch)
2012-07-09 02:00 UTC, John Marshall
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Marshall 2012-07-09 02:00:22 UTC
Since the 5.17 upgrade, PAM authentication has been broken.  The port
installs (blindly) its own /usr/local/etc/pamd/xscreensaver file which,
since 5.17, refers to a non-existent 'system-auth' module:

  # Fedora Core 5:
  auth       include	system-auth

The problem is that the FreeBSD port-supplied file is now being
overwritten by the one from the xscreensaver build.  The attached patch
provides a larger hammer to ensure that the FreeBSD
files/xscreensaver.pam is once again installed.
Comment 1 Edwin Groothuis freebsd_committer 2012-07-09 02:00:33 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dougb

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2012-07-09 03:28:56 UTC
dougb       2012-07-09 02:28:47 UTC

  FreeBSD ports repository

  Modified files:
    x11/xscreensaver     Makefile 
  Log:
  Fix installation of PAM conf file
  
  PR:             ports/169724
  Submitted by:   John Marshall <john.marshall@riverwillow.com.au>
  
  Revision  Changes    Path
  1.127     +2 -1      ports/x11/xscreensaver/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Doug Barton freebsd_committer 2012-07-09 03:29:26 UTC
State Changed
From-To: open->closed


Committed, thanks!