Bug 170695 - sysutils/fusefs-ntfs - instant reboot when mv from UFS
Summary: sysutils/fusefs-ntfs - instant reboot when mv from UFS
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.1-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-17 09:50 UTC by kamikaze
Modified: 2015-01-17 02:43 UTC (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kamikaze 2012-08-17 09:50:06 UTC
Ever since I switched from RELENG_8 to RELENG_9 a mv command from UFS to NTFS causes an instant reboot.

No panic, no dumps. I just hit enter and get the BIOS loader screen. I mount my NTFS file systems through AMD.

How-To-Repeat: # cd /media/ntfs/5vault/videos/music/
# mount | grep ntfs
/dev/fuse0 on /var/run/automounter.mnt/ntfs/5vault (fusefs, local, noatime, synchronous)
# mv ~/'Hammerfall - Last Man Standing.flv' ./
Comment 1 kamikaze 2012-08-23 02:09:32 UTC
I just encountered the same issue with sshfs. So I figure it's not
ntfs specific but a general fuse issue.

-- 
A: Because it fouls the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?
Comment 2 kamikaze 2012-10-13 16:42:31 UTC
With all the changes recently ... the issue still stands.

-- 
A: Because it fouls the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?
Comment 3 Eric Kraußer 2013-01-04 02:25:27 UTC
Happy New Year!

The panic (I see a page fault when not in X11) also occurs on
9.1-RELEASE when execute "mv" from ZFS or TMPFS to the mounted NTFS. I
mount with "ntfs-3g /dev/somedevice /mnt/somedir".
Comment 4 t.eichstaedt 2013-02-27 11:58:42 UTC
I had crashes (kernel panic) when accessing an external USB HD w/ NTFS, too.
Now the NTFS fs seems corrupted, there are files now in the root with names 
beginning with a $, like $Volume etc.  But as far I investigated until now, I 
did not loose data.

But there is a guy on the PC-BSD forum who crashed his HD completely :/ with 
FUSE+NTFS.

I have three kernel coredumps.  Shall I send them to help you to find the bug?
--
=|o)
Comment 5 01aurelien 2014-04-28 11:43:59 UTC
Hello,

I experienced the same issue to rsync file from ZFS to my external HD in 
NTFS
It crashed my NAS without more information in logs.

Please follow the pastebin with all logs (rsync/fuse-ntfs version ...)
http://pastebin.com/4tcR8XTR

Cheers,Aurelien
Comment 6 John Marino freebsd_committer 2014-07-26 14:39:06 UTC
FYI, like most fuse ports (incredibly), this port has no maintainer.  I'm not sure how any problem is going to get fixed.
Comment 7 Thomas Zander freebsd_committer 2014-08-17 09:46:27 UTC
I'd argue that tracking down and resolving instant system crashes is in the expertise of the kernel committers rather than port maintainers.

@attilio: I assigned this to you because of your experience with fuse. Would you be able to help?
Comment 8 Mark Linimon freebsd_committer freebsd_triage 2015-01-04 20:28:12 UTC
attilio has turned in his commit bit.
Comment 9 Vicen Dominguez 2015-01-17 02:43:44 UTC
Happy new year! I know the bug/ticket was closed. It is for information purposes only.

Confirmed with fuse-encfs over ZFS in 9.3-RELEASE-p3 when you try to copy/create/write something in the mounted point. Reboot guaranteed.

It looks very ugly. You can close it again if you want. Thx.