Bug 171139 - [PATCH] textproc/iksemel: add dependency on pkg-config
[PATCH] textproc/iksemel: add dependency on pkg-config
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD ports mailing list
Depends on:
  Show dependency treegraph
Reported: 2012-08-28 14:00 UTC by Frank Wall
Modified: 2012-09-02 22:30 UTC (History)
0 users

See Also:

file.diff (513 bytes, patch)
2012-08-28 14:00 UTC, Frank Wall
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Wall 2012-08-28 14:00:10 UTC
The port textproc/iksemel requires pkg-config to be build. The build dependency for it is missing, thus the port won't compile if devel/pkgconf is not already installed.

Fix: apply the patch:

------------------- start inline patch -------------------
--- textproc/iksemel/Makefile.orig	2011-09-24 00:25:43.000000000 +0200
+++ textproc/iksemel/Makefile	2012-08-28 14:47:02.000000000 +0200
@@ -7,7 +7,7 @@
 PORTNAME=	iksemel
 CATEGORIES=	textproc
@@ -16,6 +16,7 @@
 LIB_DEPENDS=	gnutls.47:${PORTSDIR}/security/gnutls
 USE_AUTOTOOLS=	aclocal autoheader automake autoconf libtool
 ACLOCAL_ARGS=	-I ${LOCALBASE}/share/aclocal
------------------- end inline patch -------------------

Patch attached with submission follows:
How-To-Repeat: - make sure devel/pkgconf is NOT installed
- try to install textproc/iksemel
- build will fail with a syntax error during the configure phase:

===>  Extracting for iksemel-1.4_3
=> SHA256 Checksum OK for iksemel-1.4.tar.gz.
===>  Patching for iksemel-1.4_3
===>  Applying FreeBSD patches for iksemel-1.4_3
===>   iksemel-1.4_3 depends on file: /usr/local/bin/automake-1.12 - found
===>   iksemel-1.4_3 depends on file: /usr/local/bin/autoconf-2.69 - found
===>   iksemel-1.4_3 depends on package: libtool>=2.4 - found
===>   iksemel-1.4_3 depends on shared library: gnutls.47 - found
===>  Configuring for iksemel-1.4_3
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking for getaddrinfo... yes
./configure: 11910: Syntax error: word unexpected (expecting ")")
===>  Script "configure" failed unexpectedly.
Comment 1 Edwin Groothuis freebsd_committer 2012-08-28 14:00:36 UTC
Maintainer of textproc/iksemel,

Please note that PR ports/171139 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:

Edwin Groothuis via the GNATS Auto Assign Tool
Comment 2 Edwin Groothuis freebsd_committer 2012-08-28 14:00:40 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Bryan Drewery freebsd_committer 2012-08-28 20:34:25 UTC
State Changed
From-To: feedback->closed

Thank you for your report. It's been reported in ports/170771 and should 
be fixed in the next week.
Comment 4 dfilter freebsd_committer 2012-09-02 22:23:18 UTC
Author: bdrewery
Date: Sun Sep  2 21:23:07 2012
New Revision: 303577
URL: http://svn.freebsd.org/changeset/ports/303577

  - Fix build by adding dependency on pkgconfig
  - Remove ABI version from LIB_DEPENDS
  PR:		ports/170771 [1]
  Submitted by:	bdrewery [1]
  PR:		ports/171139 [2]
  Submitted by:	Frank Wall <fw@moov.de> [2]
  Approved by:	maintainer timeout (2w)
  Approved by:	bapt (mentor)


Modified: head/textproc/iksemel/Makefile
--- head/textproc/iksemel/Makefile	Sun Sep  2 21:01:06 2012	(r303576)
+++ head/textproc/iksemel/Makefile	Sun Sep  2 21:23:07 2012	(r303577)
 MAINTAINER=	rhaamo@gruik.at
 COMMENT=	XML parser library mainly designed for Jabber applications
-LIB_DEPENDS=	gnutls.47:${PORTSDIR}/security/gnutls
+LIB_DEPENDS=	gnutls:${PORTSDIR}/security/gnutls
 USE_AUTOTOOLS=	aclocal autoheader automake autoconf libtool
 ACLOCAL_ARGS=	-I ${LOCALBASE}/share/aclocal
@@ -22,6 +22,7 @@ GNU_CONFIGURE=	yes
 INFO=	iksemel
svn-ports-all@freebsd.org mailing list
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"