Bug 171534 - www/firefox doesn't use system hunspell dictionary
www/firefox doesn't use system hunspell dictionary
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: gecko
Depends on:
  Show dependency treegraph
Reported: 2012-09-11 07:00 UTC by mbsd
Modified: 2012-10-10 22:18 UTC (History)
0 users

See Also:

file.txt (71.29 KB, text/plain)
2012-09-11 07:00 UTC, mbsd
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mbsd 2012-09-11 07:00:13 UTC
Firefox (www/firefox)(version=15.0) doesn't use dictionaries from /usr/local/share/hunspell, only from /usr/local/lib/firefox/dictionaries, and, of course, xpi.

By default firefox builds with --enable-system-hunspell.
pkg_info -R hunspell-1.3.2_1
Required by:

But it hasn't worked for ages.

Fix: Patch attached with submission follows:
How-To-Repeat: install firefox, russian/hunspell.
run firefox and try spell checking. You won't see Russian in Languages list.
Comment 1 Edwin Groothuis freebsd_committer 2012-09-11 07:01:50 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gecko

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Florian Smeets freebsd_committer 2012-10-10 22:18:26 UTC
State Changed
From-To: open->closed

Should be fixed in r305684