Bug 171935 - New port: x11-fonts/sourcecodepro-ttf
Summary: New port: x11-fonts/sourcecodepro-ttf
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-25 03:40 UTC by Masaki TAGAWA
Modified: 2012-09-26 01:20 UTC (History)
1 user (show)

See Also:


Attachments
sourcecodepro-ttf.shar (3.86 KB, text/plain)
2012-09-25 03:40 UTC, Masaki TAGAWA
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masaki TAGAWA 2012-09-25 03:40:01 UTC
Adobe has made available an Open source font that is specifically designed for Coders.
I have created an initial port of the TTF versions based on x11-fonts/sourcesanspro-ttf.

http://blogs.adobe.com/typblography/2012/09/source-code-pro.html

How-To-Repeat: * shar file Attached
- checked on Redports.org [1]

[1] https://redports.org/buildarchive/20120925014332-88806
Comment 1 Edwin Groothuis freebsd_committer 2012-09-25 03:40:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->swills

swills@ wants his PRs (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2012-09-26 01:18:22 UTC
Author: swills
Date: Wed Sep 26 00:18:06 2012
New Revision: 304866
URL: http://svn.freebsd.org/changeset/ports/304866

Log:
  Source Code Pro was designed by Paul D. Hunt as a companion to Source Sans.
  This complementary family was adapted from the Source design due to a
  request to create a monospaced version for coding applications.
  
  Source Code Pro currently supports a wide range of languages using Latin
  script, and includes all the characters in the Adobe Latin 4 glyph set. As
  an open source project, it is expected that incremental updates will be
  made over time to extend glyph set coverage and functionality.
  
  WWW: http://sourceforge.net/projects/sourcecodepro.adobe/
  
  PR:		ports/171935
  Submitted by:	Masaki TAGAWA <masaki@club.kyutech.ac.jp>

Added:
  head/x11-fonts/sourcecodepro-ttf/
  head/x11-fonts/sourcecodepro-ttf/Makefile   (contents, props changed)
  head/x11-fonts/sourcecodepro-ttf/distinfo   (contents, props changed)
  head/x11-fonts/sourcecodepro-ttf/files/
  head/x11-fonts/sourcecodepro-ttf/files/pkg-message.in   (contents, props changed)
  head/x11-fonts/sourcecodepro-ttf/pkg-descr   (contents, props changed)
  head/x11-fonts/sourcecodepro-ttf/pkg-plist   (contents, props changed)
Modified:
  head/x11-fonts/Makefile

Modified: head/x11-fonts/Makefile
==============================================================================
--- head/x11-fonts/Makefile	Wed Sep 26 00:12:16 2012	(r304865)
+++ head/x11-fonts/Makefile	Wed Sep 26 00:18:06 2012	(r304866)
@@ -137,6 +137,7 @@
     SUBDIR += sgifonts
     SUBDIR += sharefonts
     SUBDIR += showfont
+    SUBDIR += sourcecodepro-ttf
     SUBDIR += sourcesanspro-ttf
     SUBDIR += stix-fonts
     SUBDIR += suxus

Added: head/x11-fonts/sourcecodepro-ttf/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcecodepro-ttf/Makefile	Wed Sep 26 00:18:06 2012	(r304866)
@@ -0,0 +1,51 @@
+# Created by:	Masaki TAGAWA <masaki@club.kyutech.ac.jp>
+# $FreeBSD$
+
+PORTNAME=	sourcecodepro-ttf
+PORTVERSION=	1.009
+CATEGORIES=	x11-fonts
+MASTER_SITES=	SF/sourcecodepro.adobe
+DISTNAME=	SourceCodePro_FontsOnly-${PORTVERSION}
+
+MAINTAINER=	masaki@club.kyutech.ac.jp
+COMMENT=	A set of fonts by Adobe designed for coders
+
+LICENSE=	OFL
+LICENSE_NAME=	SIL OPEN FONT LICENSE Version 1.1
+LICENSE_FILE=	${WRKSRC}/LICENSE.txt
+LICENSE_PERMS=	auto-accept
+
+BUILD_DEPENDS=	mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale	\
+		mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+
+USE_ZIP=	yes
+USE_XORG=	x11
+
+PLIST_SUB=	FONTDIR="${FONTDIR:S|${PREFIX}/||}"
+
+SUB_FILES=	pkg-message
+PKGMESSAGE=	${WRKDIR}/pkg-message
+SUB_LIST=	FONTDIR=${FONTDIR}
+
+FONTNAME=	SourceCodePro
+FONTDIR=	${PREFIX}/lib/X11/fonts/${FONTNAME}
+INSTDAT=		fonts.dir fonts.scale
+
+MKFONTSCL_CMD=	${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD=	${LOCALBASE}/bin/mkfontdir
+
+do-build:
+	cd ${WRKSRC}/ && ${MKFONTSCL_CMD}
+	cd ${WRKSRC}/ && ${MKFONTDIR_CMD}
+
+do-install:
+	${MKDIR} ${FONTDIR}
+	cd ${WRKSRC}/ &&	\
+	${INSTALL_DATA} ${INSTDAT} *.ttf ${FONTDIR}
+
+post-install:
+	@${ECHO_MSG}
+	@${CAT} ${PKGMESSAGE}
+	@${ECHO_MSG}
+
+.include <bsd.port.mk>

Added: head/x11-fonts/sourcecodepro-ttf/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcecodepro-ttf/distinfo	Wed Sep 26 00:18:06 2012	(r304866)
@@ -0,0 +1,2 @@
+SHA256 (SourceCodePro_FontsOnly-1.009.zip) = 8681e3a1b0c32e7c32b03d883a429cd460f4bded8953d67d6e32f499ba3c135c
+SIZE (SourceCodePro_FontsOnly-1.009.zip) = 613755

Added: head/x11-fonts/sourcecodepro-ttf/files/pkg-message.in
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcecodepro-ttf/files/pkg-message.in	Wed Sep 26 00:18:06 2012	(r304866)
@@ -0,0 +1,5 @@
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your x.org configuration file:
+
+	FontPath "%%FONTDIR%%/"

Added: head/x11-fonts/sourcecodepro-ttf/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcecodepro-ttf/pkg-descr	Wed Sep 26 00:18:06 2012	(r304866)
@@ -0,0 +1,10 @@
+Source Code Pro was designed by Paul D. Hunt as a companion to Source Sans. 
+This complementary family was adapted from the Source design due to a 
+request to create a monospaced version for coding applications.
+
+Source Code Pro currently supports a wide range of languages using Latin 
+script, and includes all the characters in the Adobe Latin 4 glyph set. As 
+an open source project, it is expected that incremental updates will be 
+made over time to extend glyph set coverage and functionality.
+
+WWW: http://sourceforge.net/projects/sourcecodepro.adobe/

Added: head/x11-fonts/sourcecodepro-ttf/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcecodepro-ttf/pkg-plist	Wed Sep 26 00:18:06 2012	(r304866)
@@ -0,0 +1,10 @@
+%%FONTDIR%%/SourceCodePro-Black.ttf
+%%FONTDIR%%/SourceCodePro-Bold.ttf
+%%FONTDIR%%/SourceCodePro-ExtraLight.ttf
+%%FONTDIR%%/SourceCodePro-Light.ttf
+%%FONTDIR%%/SourceCodePro-Regular.ttf
+%%FONTDIR%%/SourceCodePro-Semibold.ttf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTDIR%%
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Steve Wills freebsd_committer 2012-09-26 01:19:09 UTC
State Changed
From-To: open->closed

New port added. Thanks!