Bug 172851 - [PATCH] sysutils/py-supervisor: update to 3.0b1 + OPTIONS + more
Summary: [PATCH] sysutils/py-supervisor: update to 3.0b1 + OPTIONS + more
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-18 13:10 UTC by koobs
Modified: 2012-10-29 21:21 UTC (History)
1 user (show)

See Also:


Attachments
py27-supervisor-3.0b1.patch (2.06 KB, patch)
2012-10-18 13:10 UTC, koobs
no flags Details | Diff
py-supervisor.patch (1.34 KB, patch)
2012-10-19 12:19 UTC, koobs
no flags Details | Diff
py-supervisor.txt (1.87 KB, text/plain)
2012-10-22 09:27 UTC, hizel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description koobs 2012-10-18 13:10:00 UTC
- Update to 3.0b1
- Make CHEESESHOP the primary MASTERSITE (dist.supervisord.org is empty)
- Trim Makefile header
- Update minimum required py-meld3 version
- Add OPTIONS for unit tests
- Set USE_PYTHON version appropriately
- Add regression-test target
- Use TEST_DEPENDS for tinderbox builds

Changes:

https://github.com/Supervisor/supervisor/blob/3.0b1/CHANGES.txt

====[QA]====
portlint: WARN: possible use of absolute pathname
porttest: OK
unittest: Ran 16 tests in 0.004s - OK
redports: https://redports.org/buildarchive/20121018113126-46920/

Note: All redports builds include regression-test run
============

Port maintainer (hizel@vyborg.ru) is cc'd.

Generated with FreeBSD Port Tools 0.99_6 (mode: update, diff: ports)
Comment 1 Edwin Groothuis freebsd_committer 2012-10-18 13:10:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-python

freebsd-python@ wants this port PRs (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2012-10-18 13:10:10 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Edwin Groothuis freebsd_committer 2012-10-18 13:10:10 UTC
Maintainer of sysutils/py-supervisor,

Please note that PR ports/172851 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/172851

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 4 R.Mahmatkhanov 2012-10-18 13:12:24 UTC
Hi koobs!

Kubilay Kocak wrote on 18.10.2012 16:05:
>
>> Number:         172851
>> Category:       ports
>> Synopsis:       [PATCH] sysutils/py-supervisor: update to 3.0b1 + OPTIONS + more

Please note that most of this changes is already committed today, sorry 
:). Please make the patch against current version in the tree.

-- 
Regards,
Ruslan

Tinderboxing kills... the drives.
Comment 5 hizel 2012-10-18 13:20:39 UTC
see ports/172844 :)

-- 
e-mail: hizel@vyborg.ru
jid: hizel@vyborg.ru
Comment 6 koobs 2012-10-18 13:36:20 UTC
Thanks rm, I noticed it 2 minutes after I submitted.

This patch also incorrectly uses RUN_DEPENDS for the TESTS option, so 
requires an updated patch anyway (thanks jhale!)

Stand by for follow-up against recent commit.
Comment 7 koobs 2012-10-19 12:19:05 UTC
Updated patch against the latest py-supervisor commit attached:

- Update minimum required py-meld3 version
- Use TEST_DEPENDS for tinderbox builds
- Add OPTIONS for unit tests
- Add regression-test target

====[QA]====
portlint: WARN: possible use of absolute pathname
porttest: OK
unittest: Ran 718 tests in 2.883s - FAILED (failures=1)

     Note: Failure is due to host in DST (reported upstream)
     https://github.com/Supervisor/supervisor/issues/155

redports: https://redports.org/buildarchive/20121019081455-33633/

     Note: All redports builds include regression-test run - OK
============
Comment 8 hizel 2012-10-22 09:27:57 UTC
Final patch with fix test error. To  
https://github.com/Supervisor/supervisor/issues/155 send pull request.

-- 
e-mail: hizel@vyborg.ru
jid: hizel@vyborg.ru
Comment 9 Ruslan Makhmatkhanov freebsd_committer 2012-10-24 12:57:05 UTC
Responsible Changed
From-To: freebsd-python->rm

I will take it.
Comment 10 Ruslan Makhmatkhanov freebsd_committer 2012-10-29 21:21:10 UTC
State Changed
From-To: feedback->closed

Committed, thank you! Sorry for delay (