Bug 172873 - [build] WITH_CTF=1 in /etc/src.conf makes make buildworld bomb out with "/usr/src/share/mk/bsd.own.mk", line 477: WITH_CTF and WITHOUT_CTF can't both be set.
Summary: [build] WITH_CTF=1 in /etc/src.conf makes make buildworld bomb out with "/usr...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 9.1-PRERELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-19 10:10 UTC by Trond.Endrestol
Modified: 2018-05-20 16:21 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trond.Endrestol 2012-10-19 10:10:01 UTC
/etc/make.conf contains:

KERNCONF=ENTERPRISE

STRIP=
CFLAGS+=-fno-omit-frame-pointer

/etc/src.conf contains:

WITH_CLANG_EXTRAS=yes
WITH_CTF=1
WITH_ICONV=yes

cd /usr/src && svn up tells me:

At revision 241721.

make buildworld buildkernel bombs out during:

 >>> stage 1.1: legacy release compatibility shims
 
 with:
 
 "/usr/src/share/mk/bsd.own.mk", line 477: WITH_CTF and WITHOUT_CTF can't both be set.
 *** [_legacy] Error code 1
 1 error
 *** [buildworld] Error code 2
 1 error

Fix: 

Patch from http://lists.freebsd.org/pipermail/freebsd-arch/2012-October/013195.html solves the problem.
How-To-Repeat: cd /usr/obj
rm -Rf *
cd /usr/src
svn up # assuming stable/9
make -DNO_CLEAN buildworld buildkernel
Comment 1 Brooks Davis freebsd_committer 2012-10-21 10:43:26 UTC
State Changed
From-To: open->closed

I've MFC'd 228120 which allows WITH_CTF to be set in make.conf again.
Comment 2 John Hein 2012-12-20 01:58:02 UTC
I still get this error on 8.x after r241969 when doing 'make
buildkernel WITH_CTF=1'.  It works if you have WITH_CTF=1
in /etc/src.conf, but not on the command line.

.undef doesn't work with command line make args.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2012-12-20 02:14:14 UTC
State Changed
From-To: closed->open

per submitter request
Comment 4 Enji Cooper freebsd_committer 2014-08-17 04:16:55 UTC
This has been fixed on HEAD to allow both WITH_* and WITHOUT_* flags, but hasn't been MFCed to anything earlier than 11-CURRENT because there are a large number of build changes present in 11 that don't exist in prior versions.

Could you please try 11-CURRENT to see if this still repros for you?
Comment 5 Trond.Endrestol 2018-05-20 14:39:25 UTC
(In reply to Ngie Cooper from comment #4)
This is no longer an issue at my end. Are we ready to close this PR?
Comment 6 Mark Johnston freebsd_committer 2018-05-20 16:21:45 UTC
Re-closing; the issue reported in comment 2 doesn't reproduce on HEAD, and the submitter's issue has been resolved.