Bug 172903 - dns/opendnssec convert to OPTIONSNG
Summary: dns/opendnssec convert to OPTIONSNG
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Erwin Lansing
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-20 13:50 UTC by Erwin Lansing
Modified: 2012-10-23 13:35 UTC (History)
0 users

See Also:


Attachments
optionsng-ods.diff (1.74 KB, patch)
2012-10-20 13:50 UTC, Erwin Lansing
no flags Details | Diff
patch-ods (1.82 KB, application/octet-stream)
2012-10-21 18:54 UTC, Jaap Akkerhuis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erwin Lansing freebsd_committer 2012-10-20 13:50:01 UTC
	Convert to new OPTIONSNG framework
Comment 1 Edwin Groothuis freebsd_committer 2012-10-20 13:50:07 UTC
Maintainer of dns/opendnssec,

Please note that PR ports/172903 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/172903

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2012-10-20 13:50:08 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Erwin Lansing freebsd_committer 2012-10-20 15:04:13 UTC
Update patch:

Index: Makefile
===================================================================
--- Makefile	(revision 306177)
+++ Makefile	(working copy)
@@ -32,13 +32,14 @@
 MAN7=		opendnssec.7
 MAN8=		ods-control.8 ods-enforcerd.8 ods-signer.8 ods-signerd.8
 
-OPTIONS=	SOFTHSM "Build/update SOFTHSM as well." Off \
-		AUDITOR "Build with Auditor." On \
-		MYSQL "Use with (experimental) MYSQL support" Off
+OPTIONS_DEFINE=		SOFTHSM AUDITOR MYSQL
+OPTIONS_DEFAULT=	AUDITOR
+SOFTHSM_DESC=		Build/update SOFTHSM as well.
+AUDITOR_DESC=		Build with Auditor.
 
 .include <bsd.port.options.mk>
 
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
 CONFIGURE_ARGS+=	--with-mysql=${LOCALBASE}
 CONFIGURE_ARGS+=	--with-database-backend=mysql
 USE_MYSQL=	compat
@@ -52,7 +53,7 @@
 PLIST_SUB+=	MYSQL="@comment "
 .endif
 
-.if defined(WITH_AUDITOR)
+.if ${PORT_OPTIONS:MAUDITOR}
 BUILD_DEPENDS+=	rubygem-dnsruby>=1.53:${PORTSDIR}/dns/rubygem-dnsruby
 USE_RUBY=	yes
 PLIST_SUB+=	AUDITOR=""
@@ -62,7 +63,7 @@
 PLIST_SUB+=	AUDITOR="@comment "
 .endif
 
-.if defined(WITH_SOFTHSM)
+.if ${PORT_OPTIONS:MSOFTHSM}
 CONFIGURE_ARGS+=	--with-softhsm
 CONFIGURE_ARGS+=	--with-pkcs11-softhsm=${LOCALBASE}/lib/libsofthsm.so
 RUN_DEPENDS+=	softhsm>=1.2.0:${PORTSDIR}/security/softhsm
@@ -71,7 +72,7 @@
 PKGMESSAGE=	${WRKSRC}/MIGRATION
 
 pre-install:
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
 	@${REINPLACE_CMD} -e '/REQUIRE:/ s|$$| mysql|' ${WRKDIR}/opendnssec
 .endif
 
@@ -82,7 +83,7 @@
 	${CHOWN} -R ${USERS}:${GROUPS} ${PREFIX}/var/opendnssec
 
 .include <bsd.port.pre.mk>
-.if defined(WITH_AUDITOR) && ${RUBY_VER} == 1.9
+.if ${PORT_OPTIONS:MAUDITOR} && ${RUBY_VER} == 1.9
 BROKEN=	does not work with ruby 1.9
 .endif
 .include <bsd.port.post.mk>
Comment 4 Jaap Akkerhuis 2012-10-21 18:54:55 UTC
On Oct 20, 2012, at 14:50, Edwin Groothuis <edwin@FreeBSD.ORG> wrote:

> Maintainer of dns/opendnssec,
> 
> Please note that PR ports/172903 has just been submitted.

Thanks.  However, the suggested patch doesn't work as intended.  Find below
an improved version.

Regards,

	jaap

Comment 5 Mark Linimon freebsd_committer freebsd_triage 2012-10-21 19:03:25 UTC
State Changed
From-To: feedback->open

Maintainer has replied with updated patch.
Comment 6 Erwin Lansing freebsd_committer 2012-10-21 19:16:42 UTC
Responsible Changed
From-To: freebsd-ports-bugs->erwin

My PR, I'll handle it.
Comment 7 Erwin Lansing freebsd_committer 2012-10-23 13:34:06 UTC
State Changed
From-To: open->closed

Hoi Jaap, 

I figured something like that happened to the second patch 
after looking in GNATS.  Thanks for reviewing two sets of 
patches, and for catching my mistakes in the first round. 

Committed, thanks again! 
Erwin