Bug 173137 - [lem] em(4) unable to run at gigabit with 9.1-RC2
Summary: [lem] em(4) unable to run at gigabit with 9.1-RC2
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-net (Nobody)
Keywords: IntelNetworking
Depends on:
Reported: 2012-10-27 02:20 UTC by root
Modified: 2016-03-14 19:18 UTC (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description root 2012-10-27 02:20:00 UTC
After upgrading from 9.0 to 9.1-RC2, my Intel 1000/GT Desktop (82541PI) PCI ethernet controller using the em(4) driver is unable to run at gigabit speeds.

Using autoselect, the interface defaults to 100baseTX, and setting it to 1000baseT or 1000baseTX either half- or full-duplex simply disconnects the controller from the network and changes its status to "no carrier". Changing the media to 100baseTX or autoselect again brings back the connection.

I have tried replacing the cable and connecting the machine to several different (gigabit) devices, but nothing helps. dmesg does not output anything out of the ordinary.
The other network interface in the machine, an onboard Realtek, does not have any problems and autonegotiates to gigabit just fine.

The system is an Intel D945GCLF2D dual-core Atom 330 running FreeBSD/amd64.

04:00.0 Ethernet controller: Intel Corporation 82541PI Gigabit Ethernet Controller (rev 05)

em0: <Intel(R) PRO/1000 Legacy Network Connection 1.0.4> port 0x1000-0x103f mem 0x88120000-0x8813ffff,0x88100000-0x8811ffff irq 21 at device 0.0 on pci4

sysctl dev.em:
dev.em.0.%desc: Intel(R) PRO/1000 Legacy Network Connection 1.0.4
dev.em.0.%driver: em
dev.em.0.%location: slot=0 function=0
dev.em.0.%pnpinfo: vendor=0x8086 device=0x107c subvendor=0x8086 subdevice=0x1376 class=0x020000
dev.em.0.%parent: pci4
dev.em.0.nvm: -1
dev.em.0.rx_int_delay: 0
dev.em.0.tx_int_delay: 66
dev.em.0.rx_abs_int_delay: 66
dev.em.0.tx_abs_int_delay: 66
dev.em.0.rx_processing_limit: 100
dev.em.0.flow_control: 3
dev.em.0.mbuf_alloc_fail: 0
dev.em.0.cluster_alloc_fail: 0
dev.em.0.dropped: 0
dev.em.0.tx_dma_fail: 0
dev.em.0.tx_desc_fail1: 0
dev.em.0.tx_desc_fail2: 145326
dev.em.0.rx_overruns: 0
dev.em.0.watchdog_timeouts: 0
dev.em.0.device_control: 1480327745
dev.em.0.rx_control: 32770
dev.em.0.fc_high_water: 47104
dev.em.0.fc_low_water: 45604
dev.em.0.fifo_workaround: 0
dev.em.0.fifo_reset: 0
dev.em.0.txd_head: 243
dev.em.0.txd_tail: 243
dev.em.0.rxd_head: 14
dev.em.0.rxd_tail: 12
dev.em.0.mac_stats.excess_coll: 0
dev.em.0.mac_stats.single_coll: 0
dev.em.0.mac_stats.multiple_coll: 0
dev.em.0.mac_stats.late_coll: 0
dev.em.0.mac_stats.collision_count: 0
dev.em.0.mac_stats.symbol_errors: 0
dev.em.0.mac_stats.sequence_errors: 0
dev.em.0.mac_stats.defer_count: 0
dev.em.0.mac_stats.missed_packets: 0
dev.em.0.mac_stats.recv_no_buff: 0
dev.em.0.mac_stats.recv_undersize: 0
dev.em.0.mac_stats.recv_fragmented: 0
dev.em.0.mac_stats.recv_oversize: 0
dev.em.0.mac_stats.recv_jabber: 0
dev.em.0.mac_stats.recv_errs: 0
dev.em.0.mac_stats.crc_errs: 0
dev.em.0.mac_stats.alignment_errs: 0
dev.em.0.mac_stats.coll_ext_errs: 0
dev.em.0.mac_stats.xon_recvd: 0
dev.em.0.mac_stats.xon_txd: 0
dev.em.0.mac_stats.xoff_recvd: 0
dev.em.0.mac_stats.xoff_txd: 0
dev.em.0.mac_stats.total_pkts_recvd: 27700266
dev.em.0.mac_stats.good_pkts_recvd: 27700266
dev.em.0.mac_stats.bcast_pkts_recvd: 21448
dev.em.0.mac_stats.mcast_pkts_recvd: 1334
dev.em.0.mac_stats.rx_frames_64: 5590389
dev.em.0.mac_stats.rx_frames_65_127: 12234066
dev.em.0.mac_stats.rx_frames_128_255: 882048
dev.em.0.mac_stats.rx_frames_256_511: 239892
dev.em.0.mac_stats.rx_frames_512_1023: 8548498
dev.em.0.mac_stats.rx_frames_1024_1522: 205373
dev.em.0.mac_stats.good_octets_recvd: 7051893659
dev.em.0.mac_stats.good_octets_txd: 17847873333
dev.em.0.mac_stats.total_pkts_txd: 27183553
dev.em.0.mac_stats.good_pkts_txd: 27183553
dev.em.0.mac_stats.bcast_pkts_txd: 429
dev.em.0.mac_stats.mcast_pkts_txd: 599
dev.em.0.mac_stats.tx_frames_64: 9427391
dev.em.0.mac_stats.tx_frames_65_127: 3163651
dev.em.0.mac_stats.tx_frames_128_255: 3203080
dev.em.0.mac_stats.tx_frames_256_511: 565954
dev.em.0.mac_stats.tx_frames_512_1023: 185206
dev.em.0.mac_stats.tx_frames_1024_1522: 10638271
dev.em.0.mac_stats.tso_txd: 0
dev.em.0.mac_stats.tso_ctx_fail: 0


Using the interface at 100baseTX.
How-To-Repeat: Connect the interface to a gigabit network.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-10-27 03:29:14 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Sean Bruno freebsd_committer 2016-03-03 14:59:55 UTC
This is definitely no longer happening here.

Can you retest with 10.2 or 10.3BETA if possible?
Comment 3 esh 2016-03-12 23:56:59 UTC
This problem got solved a long time ago. I think it went away with 9.1-RC3, but I can't remember for sure.
It is definitely not happening anymore, so please close this bug.

Sorry for not reporting back earlier - I completely forgot about this bug report. :-(