Bug 174212 - editors/libreoffice: ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/binaryurp/prj
Summary: editors/libreoffice: ERROR: error 65280 occurred while making /usr/ports/edit...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-05 23:00 UTC by O. Hartmann
Modified: 2014-08-26 05:53 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2012-12-05 23:00:00 UTC
Port editors/libreoffice (3.5.7) rejects building with the below shown error message.

Immediately after the commit of LLVM/CLANG 3.2-RC2 an already installed port editors/libreoffice stopped working and dropping signal 10. I was able to reproduce this behaviour on all boxes BEFORE and AFTER the commit of LLVM/CLANG 3.2-RC2. The very same time building of the port editors/libreoffice stopped working. Compilation worked before!

[...]
qadevOOo deliver
Module 'qadevOOo' delivered successfully. 0 files copied, 0 files unchanged

=============
(61/113) Building module unotest
=============
Entering /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/unotest/source/cpp/unoexceptionprotector

Entering /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/unotest/source/java/org/openoffice/test/tools

Entering /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/unotest/source/java/org/openoffice/test

Nothing to update for zip
Entering /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/unotest/source/cpp

Nothing to update for zip
unotest deliver
Module 'unotest' delivered successfully. 2 files copied, 17 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2/binaryurp/prj

 it seems that the error is inside 'binaryurp', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2
source ./Env.Host.sh
cd binaryurp
gmake clean # optional
gmake -r

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.7.2'
gmake: *** [source-env-and-recurse] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [build] Error code 1

Stop in /usr/ports/editors/libreoffice.

How-To-Repeat: Update to most recent FreeBSD10.0-CUR/amd64 with committed news LLVM/CLANG 3.2-RC and try an already installed and working(!) port editors/libreoffice. it will drop SIGNAL 10.

Try then to reinstall/compile the port editors/libreoffice and watch the build.
Comment 1 Edwin Groothuis freebsd_committer 2012-12-05 23:00:07 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Baptiste Daroussin freebsd_committer 2014-08-26 05:53:32 UTC
This has been fixed in the meantime