Bug 175201 - [PATCH] mail/spamass-rules: update to 20120817
Summary: [PATCH] mail/spamass-rules: update to 20120817
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Bernhard Froehlich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-11 08:40 UTC by michael
Modified: 2013-01-24 11:20 UTC (History)
1 user (show)

See Also:


Attachments
spamass-rules-20120817.patch (5.73 KB, patch)
2013-01-11 08:40 UTC, michael
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description michael 2013-01-11 08:40:00 UTC
- Update to 20120817
- Switch to new options framework

Port maintainer (michael@ranner.eu) is cc'd.

Generated with FreeBSD Port Tools 0.99_6 (mode: update, diff: ports)
Comment 1 Edwin Groothuis freebsd_committer 2013-01-11 08:40:09 UTC
Class Changed
From-To: maintainer-update->change-request

Fix category (submitter is not maintainer) (via the GNATS Auto Assign 
Tool)
Comment 2 Edwin Groothuis freebsd_committer 2013-01-11 08:40:10 UTC
Maintainer of mail/spamass-rules,

Please note that PR ports/175201 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/175201

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2013-01-11 08:40:11 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 michael 2013-01-11 08:42:49 UTC
Am 11.01.13 09:40, schrieb Edwin Groothuis:
> Maintainer of mail/spamass-rules,
>
> Please note that PR ports/175201 has just been submitted.
>
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the patch
> and a committer will take care of it.
>
> The full text of the PR can be found at:
>      http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/175201
>
Approved - I sent this PR.
Comment 5 Bernhard Froehlich freebsd_committer 2013-01-24 10:52:40 UTC
Responsible Changed
From-To: freebsd-ports-bugs->decke

I'll take it.
Comment 6 dfilter service freebsd_committer 2013-01-24 11:14:46 UTC
Author: decke
Date: Thu Jan 24 11:14:38 2013
New Revision: 310924
URL: http://svnweb.freebsd.org/changeset/ports/310924

Log:
  - Update to 20120817
  - Switch to new options framework
  - Convert to new Makefile header
  
  PR:		ports/175201
  Submitted by:	Michael Ranner <michael@ranner.eu> (maintainer)

Modified:
  head/mail/spamass-rules/Makefile
  head/mail/spamass-rules/distinfo

Modified: head/mail/spamass-rules/Makefile
==============================================================================
--- head/mail/spamass-rules/Makefile	Thu Jan 24 10:37:30 2013	(r310923)
+++ head/mail/spamass-rules/Makefile	Thu Jan 24 11:14:38 2013	(r310924)
@@ -1,12 +1,7 @@
-# New ports collection makefile for: spamass-rules
-# Date created:         20040725
-# Whom:                 mranner@inode.at
-#
 # $FreeBSD$
-#
 
 PORTNAME=	spamass-rules
-PORTVERSION=	20120319
+PORTVERSION=	20120817
 CATEGORIES=	mail
 MASTER_SITES=	http://www.ranner.eu/stuff/
 
@@ -15,23 +10,52 @@ COMMENT=	Custom rulesets for SpamAssassi
 
 RUN_DEPENDS=	spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin
 
-OPTIONS=	AHBL "Check AHBL Blacklist" on \
-		AIRMAX "Some custom rulesets" off \
-		BACKHAIR "Catch those ugly, unsightly HTML tags" off \
-		BOGUS_VIRUS "Catch 'collateral spam' caused by viruses" on \
-		CHICKENPOX "Catch spam like 'l.ooks f|or th.is garb+age'" off \
-		CHINESE "Catches spam written in Chinese" off \
-		EVILNUMBERS "Phone numbers, PO boxes, ... from spam " off \
-		GERMAN "Catches spam written in German" on \
-		GREEK "Catches spam written in Greek" on \
-		MALWARE "Malware Patrol - Block List" on \
-		MANGLED "Looks for obfuscated/gappy words" off \
-		MIMEVLD "Some mime validation rules" on \
-		NIXSPAM "Check NiX Spam Blacklist" on \
-		RANDOM "Detects spamware mistakes like: %RANDOM_WORD" on \
-		TRIPWIRE "Matches 3 chars that shouldn't be together" on \
-		WEEDS "Looks at alphanum, hex, lower-, uppercase chars" off \
-		WEEDS2 "More restrictive than WEEDS, dont use together" on
+NO_OPTIONS_SORT=	yes
+OPTIONS_DEFINE=	\
+	AHBL \
+	AIRMAX \
+	BACKHAIR \
+	BOGUS_VIRUS \
+	CHICKENPOX \
+	CHINESE \
+	DBRACKETS \
+	EVILNUMBERS \
+	GERMAN \
+	GREEK \
+	MALWARE \
+	MANGLED \
+	MIMEVLD \
+	MSPIKE \
+	NIXSPAM \
+	RANDOM \
+	TRIPWIRE \
+	WEEDS
+
+OPTIONS_SINGLE=		WEEDS
+OPTIONS_SINGLE_WEEDS=	WEEDS1 WEEDS2
+OPTIONS_DEFAULT=	BOGUS_VIRUS DBRACKETS GERMAN GREEK MALWARE MIMEVLD MSPIKE NIXSPAM RANDOM TRIPWIRE WEEDS WEEDS2
+
+AHBL_DESC=		Check AHBL Blacklist
+AIRMAX_DESC=	Some custom rulesets
+BACKHAIR_DESC=	Catch those ugly, unsightly HTML tags
+BOGUS_VIRUS_DESC=	Catch 'collateral spam' caused by viruses
+CHICKENPOX_DESC=	Catch spam like 'l.ooks f|or th.is garb+age'
+CHINESE_DESC=	Catches spam written in Chinese
+DBRACKETS_DESC=		Double-brackets around To header address
+EVILNUMBERS_DESC=	Phone numbers, PO boxes, ... from spam
+GERMAN_DESC=	Catches spam written in German
+GREEK_DESC=		Catches spam written in Greek
+MALWARE_DESC=	Malware Patrol - Block List
+MANGLED_DESC=	Looks for obfuscated/gappy words
+MIMEVLD_DESC=	Some mime validation rules
+MSPIKE_DESC=	Check mailspike.net blacklist
+NIXSPAM_DESC=	Check NiX Spam blacklist
+RANDOM_DESC=	Detects spamware mistakes like: %RANDOM_WORD
+TRIPWIRE_DESC=	Matches 3 chars that shouldn't be together
+WEEDS_DESC=		Looks at alphanum, hex, lower-, uppercase chars
+WEEDS1_DESC=	Less restrictive rules
+WEEDS2_DESC=	More restrictive rules
+
 SUB_FILES=	pkg-message
 NO_BUILD=	yes
 NO_WRKSUBDIR=	yes
@@ -40,78 +64,88 @@ SPAMASS_FILES=
 USE_BZIP2=	yes
 INSTALL_DIR=	${PREFIX}/${SPAMASS_CONF}
 
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
 
-.if !defined(WITHOUT_AHBL)
+.if ${PORT_OPTIONS:MAHBL}
 SPAMASS_FILES+=	20_dnsbl_ahbl.cf
 .endif
 
-.if !defined(WITHOUT_AIRMAX)
+.if ${PORT_OPTIONS:MAIRMAX}
 SPAMASS_FILES+=	airmax.cf
 .endif
 
-.if !defined(WITHOUT_BACKHAIR)
+.if ${PORT_OPTIONS:MBACKHAIR}
 SPAMASS_FILES+=	backhair.cf
 .endif
 
-.if !defined(WITHOUT_BOGUS_VIRUS)
+.if ${PORT_OPTIONS:MBOGUS_VIRUS}
 SPAMASS_FILES+=	bogus-virus-warnings.cf
 .endif
 
-.if !defined(WITHOUT_CHICKENPOX)
+.if ${PORT_OPTIONS:MCHICKENPOX}
 SPAMASS_FILES+=	chickenpox.cf
 .endif
 
-.if defined(WITH_CHINESE)
+.if ${PORT_OPTIONS:MCHINESE}
 SPAMASS_FILES+=	chinese_rules.cf
 .endif
 
-.if !defined(WITHOUT_EVILNUMBERS)
+.if ${PORT_OPTIONS:MDBRACKETS}
+SPAMASS_FILES+=	99_SMF_BRACKETS_TO.cf
+.endif
+
+.if ${PORT_OPTIONS:MEVILNUMBERS}
 SPAMASS_FILES+=	evilnumbers.cf
 .endif
 
-.if !defined(WITHOUT_GERMAN)
+.if ${PORT_OPTIONS:MGERMAN}
 SPAMASS_FILES+=	70_zmi_german.cf
 .endif
 
-.if !defined(WITHOUT_GREEK)
+.if ${PORT_OPTIONS:MGREEK}
 SPAMASS_FILES+=	gr_domain.cf
 .endif
 
-.if !defined(WITHOUT_MALWARE)
+.if ${PORT_OPTIONS:MMALWARE}
 SPAMASS_FILES+=	malwarepatrol.cf
 .endif
 
-.if !defined(WITHOUT_MANGLED)
+.if ${PORT_OPTIONS:MMANGLED}
 SPAMASS_FILES+=	mangled.cf
 .endif
 
-.if !defined(WITHOUT_MIMEVLD)
+.if ${PORT_OPTIONS:MMIMEVLD}
 SPAMASS_FILES+=	mime_validate.cf
 .endif
 
-.if !defined(WITHOUT_NIXSPAM)
+.if ${PORT_OPTIONS:MMSPIKE}
+SPAMASS_FILES+=	10_dnsbl_mspike.cf
+.endif
+
+.if ${PORT_OPTIONS:MNIXSPAM}
 SPAMASS_FILES+=	20_dnsbl_nixspam.cf
 .endif
 
-.if !defined(WITHOUT_RANDOM)
+.if ${PORT_OPTIONS:MRANDOM}
 SPAMASS_FILES+=	random.cf
 .endif
 
-.if !defined(WITHOUT_TRIPWIRE)
+.if ${PORT_OPTIONS:MTRIPWIRE}
 SPAMASS_FILES+=	99_FVGT_Tripwire.cf
 .endif
 
-.if defined(WITH_WEEDS) && defined(WITHOUT_WEEDS2)
+.if ${PORT_OPTIONS:MWEEDS}
 SPAMASS_FILES+=	weeds.cf
 .endif
 
-.if !defined(WITHOUT_WEEDS2) && !defined(WITH_WEEDS)
+.if ${PORT_OPTIONS:MWEEDS2}
 SPAMASS_FILES+=	weeds2.cf
 .endif
 
 PLIST_FILES=	${SPAMASS_FILES:S/^/${SPAMASS_CONF}\//}
 
+.include <bsd.port.pre.mk>
+
 do-build:
 	@${DO_NADA}
 

Modified: head/mail/spamass-rules/distinfo
==============================================================================
--- head/mail/spamass-rules/distinfo	Thu Jan 24 10:37:30 2013	(r310923)
+++ head/mail/spamass-rules/distinfo	Thu Jan 24 11:14:38 2013	(r310924)
@@ -1,2 +1,2 @@
-SHA256 (spamass-rules-20120319.tar.bz2) = 3a41a55634214d012f213c8110a3885ac165e0db90d4ea11a9a6fcc84bf4acfa
-SIZE (spamass-rules-20120319.tar.bz2) = 465252
+SHA256 (spamass-rules-20120817.tar.bz2) = 4734532ae0220ea5755cfb4a28e8733866b050c598b214841ceb6efd6245ab97
+SIZE (spamass-rules-20120817.tar.bz2) = 318330
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 7 Bernhard Froehlich freebsd_committer 2013-01-24 11:14:53 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!