Bug 175880 - editors/libreoffice: ERROR: error 512 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2/testtools/prj
Summary: editors/libreoffice: ERROR: error 512 occurred while making /usr/ports/editor...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-06 10:40 UTC by O. Hartmann
Modified: 2013-02-09 00:56 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2013-02-06 10:40:00 UTC
Updating or building port editors/libreoffice fails (as usual) on FreeBSD 10-CURRENT, most recent buildworld and FreeBSD 9.1-STABLE, both amd64). Enabling JAVA for JDBC/database access purposes results on both platforms in linker error not finding libjawt. This library is installed:

pkg which /usr/local/openjdk6/jre/lib/amd64/libjawt.so
/usr/local/openjdk6/jre/lib/amd64/libjawt.so was installed by package openjdk6-b27

Disabling JAVA results in the error shown below.

[...]
[ building ZIP ] xhp_simpress_en-US.zip
[ building ZIP ] xhp_simpress_en-US.zip
[ building ZIP ] swriter_en-US.zip
[ building ZIP ] simpress_en-US.zip
helpcontent2 deliver
Module 'helpcontent2' delivered successfully. 10 files copied, 1 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 512 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2/testtools/prj

 it seems that the error is inside 'testtools', please re-run build
 inside this module to isolate the error and/or test your fix:

build_error.log should contain the captured output of the failed module(s)

-----------------------------------------------------------------------
To rebuild a specific module:

gmake testtools.clean # optional
gmake testtools

when the problem is isolated and fixed, re-run 'gmake'
gmake[1]: *** [build-packimages] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2'
gmake: *** [all] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [build] Error code 1

Stop in /usr/ports/editors/libreoffice.

===>>> make failed for editors/libreoffice
===>>> Aborting update

===>>> Update for editors/libreoffice failed
===>>> Aborting update

Terminated

How-To-Repeat: Update an existing installation of port editors/libreoffice. amke sure option JAVA is NOT selected, otherwise the build will fail due to linker does not find libjawt:
find /usr/local/ -name "libjawt*" -ls
3273789       16 -r--r--r--    1 root                             wheel                                6198 Feb  5 18:34 /usr/local/openjdk6/jre/lib/amd64/libjawt.so

pkg which /usr/local/openjdk6/jre/lib/amd64/libjawt.so
/usr/local/openjdk6/jre/lib/amd64/libjawt.so was installed by package openjdk6-b27

JAVA is needed for JDBC DB access.
Comment 1 Edwin Groothuis freebsd_committer 2013-02-06 10:40:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Jung-uk Kim freebsd_committer 2013-02-09 00:55:32 UTC
State Changed
From-To: open->closed

These two build issues should be fixed now.