Bug 176205 - editors/libreoffice: libreoffice won't build in UTF-8 environment
Summary: editors/libreoffice: libreoffice won't build in UTF-8 environment
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-17 04:40 UTC by Peter Jeremy
Modified: 2013-02-18 21:49 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Jeremy 2013-02-17 04:40:00 UTC
	When building libreoffice in a UTF-8 environment, it fails due
	to invalid byte sequences in comments in Java source files.  This
	is a regression, though possibly related to openjdk6-b27_1 or
	apache-ant-1.8.4 rather than libreoffice.  Some follow-ups to
	the (unrelated) ports/175953 appear to be this problem.

	The visible error is:
=============
(42/49) Building module cli_ure
=============
Entering /tank/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2/cli_ure/inc

Entering /tank/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2/cli_ure/version

cp version.txt ../unxfbsd.pro/bin/cliureversion.mk
cli_ure deliver
Module 'cli_ure' delivered successfully. 1 files copied, 4 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /tank/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2/apache-commons/java/httpclient

 it seems that the error is inside 'apache-commons', please re-run build
 inside this module to isolate the error and/or test your fix:

build_error.log should contain the captured output of the failed module(s)


The relevant part of build_error.log is:
compile:
    [javac] /tank/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2/apache-commons/unxfbsd.pro/misc/build/commons-httpclient-3.1/build.xml:184: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 139 source files to /tank/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2/apache-commons/unxfbsd.pro/misc/build/commons-httpclient-3.1/target/classes
    [javac] /tank/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.6.5.2/apache-commons/unxfbsd.pro/misc/build/commons-httpclient-3.1/src/java/org/apache/commons/httpclient/HttpContentTooLargeException.java:6: unmappable character for encoding UTF8
    [javac]  * @author Ortwin Gl�ck
    [javac]                     ^
    [javac] 1 error

Fix: 

Not clear.  The work-around for broken source files used to be
	to set ANT_OPTS+="-Dfile.encoding=ISO-8859-1".  The libreoffice
	makefiles have this but it's patched out by the FreeBSD build
	because it doesn't work (java now takes "-Dfile.encoding=ISO-8859-1"
	to be the name of the main class and breaks).

	My work-around was LC_ALL=en_AU.ISO8859-1 make
	but, whilst that built successful, when I tried to run it,
	it displayed the splash screen and then SEGV'd.
How-To-Repeat: 	cd /usr/ports/editors/libreoffice && LC_ALL=en_AU.UTF-8 make
Comment 1 Edwin Groothuis freebsd_committer 2013-02-17 04:40:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-02-18 21:37:49 UTC
Author: jkim
Date: Mon Feb 18 21:37:41 2013
New Revision: 312531
URL: http://svnweb.freebsd.org/changeset/ports/312531

Log:
  Fix jakarta-commons-httpclient build with some locale.
  
  PR:		ports/176205

Modified:
  head/editors/libreoffice/Makefile

Modified: head/editors/libreoffice/Makefile
==============================================================================
--- head/editors/libreoffice/Makefile	Mon Feb 18 21:36:06 2013	(r312530)
+++ head/editors/libreoffice/Makefile	Mon Feb 18 21:37:41 2013	(r312531)
@@ -396,6 +396,7 @@ LDFLAGS=	-L${LOCALBASE}/lib
 
 MAKE_ENV+=	ENVCFLAGS="${CFLAGS}" ENVCXXFLAGS="${CXXFLAGS}"
 MAKE_ENV+=	ENVLINKFLAGS="${LDFLAGS}"
+MAKE_ENV+=	LANG=C LC_ALL=C
 MAKE_ENV+=	USE_GMAKE=1
 
 TMPDIR?=	/tmp
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Jung-uk Kim freebsd_committer 2013-02-18 21:47:35 UTC
State Changed
From-To: open->closed

It should be fixed now.  Note the runtime failure sounds like 
a different issue.