Bug 176845 - New port: devel/p5-MooX-Options
Summary: New port: devel/p5-MooX-Options
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Martin Wilke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-11 10:50 UTC by espen
Modified: 2013-03-29 01:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description espen 2013-03-11 10:50:00 UTC
Use Getopt::Long::Descritive to provide command line option for your =
Mo/Moo/Moose Object.
This module will add "option" which act as "has" but support additional =
feature for getopt.
You will have "new_with_options" to instanciate new object for command =
line.       =20

Fix: --Apple-Mail=_3D948BEC-A076-4854-BE05-102DE58A4FC7
Content-Disposition: attachment;
	filename=p5-MooX-Options.shar
Content-Type: application/octet-stream;
	name="p5-MooX-Options.shar"
Content-Transfer-Encoding: 7bit



--Apple-Mail=_3D948BEC-A076-4854-BE05-102DE58A4FC7----jA70wyKpW5aZEsOmDKruYDokEv0TNcdCrI4oL98mxRxmYr98
Content-Type: text/plain; name="file.shar"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.shar"

# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	p5-MooX-Options
#	p5-MooX-Options/pkg-plist
#	p5-MooX-Options/Makefile
#	p5-MooX-Options/distinfo
#	p5-MooX-Options/pkg-descr
#
echo c - p5-MooX-Options
mkdir -p p5-MooX-Options > /dev/null 2>&1
echo x - p5-MooX-Options/pkg-plist
sed 's/^X//' >p5-MooX-Options/pkg-plist << '1b1d26aa79d93e13cddba864a9cdcada'
X%%SITE_PERL%%/MooX/Options.pm
X%%SITE_PERL%%/MooX/Options/Role.pm
X@dirrmtry %%SITE_PERL%%/MooX/Options
X@dirrmtry %%SITE_PERL%%/MooX
1b1d26aa79d93e13cddba864a9cdcada
echo x - p5-MooX-Options/Makefile
sed 's/^X//' >p5-MooX-Options/Makefile << '6efef017184c37eaaf2dbee81f6063cc'
XPORTNAME=	MooX-Options
XPORTVERSION=	3.77
XCATEGORIES=	devel perl5
XMASTER_SITES=	CPAN
XPKGNAMEPREFIX=	p5-
X
XMAINTAINER=	espen@tagestad.no
XCOMMENT=	adds option keywords to your object (Mo/Moo/Moose)
X
XLICENSE=	ART10 GPLv1
XLICENSE_COMB=	dual
X
XBUILD_DEPENDS=	p5-Module-Runtime>=0.012:${PORTSDIR}/devel/p5-Module-Runtime \
X		p5-Moo>=0.091010:${PORTSDIR}/devel/p5-Moo \
X                p5-Data-Record>=0.02:${PORTSDIR}/devel/p5-Data-Record \
X                p5-Module-Load-Conditional>=0.54:${PORTSDIR}/devel/p5-Module-Load-Conditional \
X                p5-Module-Metadata>=1.000011:${PORTSDIR}/devel/p5-Module-Metadata \
X		p5-namespace-clean>=0.24:${PORTSDIR}/devel/p5-namespace-clean \
X		p5-Test-Trap>=0:${PORTSDIR}/devel/p5-Test-Trap
XRUN_DEPENDS:=	${BUILD_DEPENDS} \
X		p5-Getopt-Long-Descriptive>=0.093:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive \
X                p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common
X
XPERL_CONFIGURE=	yes
XPERL_MODBUILD=  yes
X
XMAN3=		MooX::Options.3 \
X                MooX::Options::Role.3
X
X.include <bsd.port.mk>
6efef017184c37eaaf2dbee81f6063cc
echo x - p5-MooX-Options/distinfo
sed 's/^X//' >p5-MooX-Options/distinfo << '501904abaa5f3937f98eaea8699d8440'
XSHA256 (MooX-Options-3.77.tar.gz) = 6ad22322eb72832d3510f069d9eec332cd5da5c92961e42340a12230cabbad11
XSIZE (MooX-Options-3.77.tar.gz) = 27604
501904abaa5f3937f98eaea8699d8440
echo x - p5-MooX-Options/pkg-descr
sed 's/^X//' >p5-MooX-Options/pkg-descr << '8ed4f52ba531f172310908a5b1a4d844'
XMooX::Options adds option keywords to your object (Mo/Moo/Moose)
X
XWWW: http://search.cpan.org/dist/MooX-Options/
8ed4f52ba531f172310908a5b1a4d844
exit
How-To-Repeat:         <code/input/activities to reproduce the problem (multiple =
lines)>
Comment 1 Edwin Groothuis freebsd_committer 2013-03-11 10:50:07 UTC
Responsible Changed
From-To: freebsd-ports-bugs->perl

perl@ wants this port PRs (via the GNATS Auto Assign Tool)
Comment 2 Martin Wilke freebsd_committer 2013-03-11 13:04:50 UTC
Responsible Changed
From-To: perl->miwi

I'll take it.
Comment 3 Martin Wilke freebsd_committer 2013-03-29 01:34:35 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 4 dfilter service freebsd_committer 2013-03-29 01:34:54 UTC
Author: miwi
Date: Fri Mar 29 01:34:46 2013
New Revision: 315516
URL: http://svnweb.freebsd.org/changeset/ports/315516

Log:
  MooX::Options adds option keywords to your object (Mo/Moo/Moose)
  
  WWW: http://search.cpan.org/dist/MooX-Options/
  
  PR:		ports/176845
  Submitted by:	Espen Tagestad <espen@tagestad.no>

Added:
  head/devel/p5-MooX-Options/
  head/devel/p5-MooX-Options/Makefile   (contents, props changed)
  head/devel/p5-MooX-Options/distinfo   (contents, props changed)
  head/devel/p5-MooX-Options/pkg-descr   (contents, props changed)
  head/devel/p5-MooX-Options/pkg-plist   (contents, props changed)
Modified:
  head/devel/Makefile

Modified: head/devel/Makefile
==============================================================================
--- head/devel/Makefile	Fri Mar 29 01:31:43 2013	(r315515)
+++ head/devel/Makefile	Fri Mar 29 01:34:46 2013	(r315516)
@@ -2284,6 +2284,7 @@
     SUBDIR += p5-Module-Versions
     SUBDIR += p5-Module-Versions-Report
     SUBDIR += p5-Moo
+    SUBDIR += p5-MooX-Options
     SUBDIR += p5-MooX-Types-MooseLike
     SUBDIR += p5-Moos
     SUBDIR += p5-Moose

Added: head/devel/p5-MooX-Options/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/p5-MooX-Options/Makefile	Fri Mar 29 01:34:46 2013	(r315516)
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME=	MooX-Options
+PORTVERSION=	3.77
+CATEGORIES=	devel perl5
+MASTER_SITES=	CPAN
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	espen@tagestad.no
+COMMENT=	Option keywords to your object (Mo/Moo/Moose)
+
+LICENSE=	ART10 GPLv1
+LICENSE_COMB=	dual
+
+BUILD_DEPENDS=	p5-Module-Runtime>=0.012:${PORTSDIR}/devel/p5-Module-Runtime \
+		p5-Moo>=0.091010:${PORTSDIR}/devel/p5-Moo \
+		p5-Data-Record>=0.02:${PORTSDIR}/devel/p5-Data-Record \
+		p5-Module-Load-Conditional>=0.54:${PORTSDIR}/devel/p5-Module-Load-Conditional \
+		p5-Module-Metadata>=1.000011:${PORTSDIR}/devel/p5-Module-Metadata \
+		p5-namespace-clean>=0.24:${PORTSDIR}/devel/p5-namespace-clean \
+		p5-Test-Trap>=0:${PORTSDIR}/devel/p5-Test-Trap
+RUN_DEPENDS=	p5-Module-Runtime>=0.012:${PORTSDIR}/devel/p5-Module-Runtime \
+		p5-Moo>=0.091010:${PORTSDIR}/devel/p5-Moo \
+		p5-Data-Record>=0.02:${PORTSDIR}/devel/p5-Data-Record \
+		p5-Module-Load-Conditional>=0.54:${PORTSDIR}/devel/p5-Module-Load-Conditional \
+		p5-Module-Metadata>=1.000011:${PORTSDIR}/devel/p5-Module-Metadata \
+		p5-namespace-clean>=0.24:${PORTSDIR}/devel/p5-namespace-clean \
+		p5-Test-Trap>=0:${PORTSDIR}/devel/p5-Test-Trap \
+		p5-Getopt-Long-Descriptive>=0.093:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive \
+		p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common
+
+PERL_CONFIGURE=	yes
+PERL_MODBUILD=	yes
+
+MAN3=		MooX::Options.3 \
+		MooX::Options::Role.3
+
+.include <bsd.port.mk>

Added: head/devel/p5-MooX-Options/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/p5-MooX-Options/distinfo	Fri Mar 29 01:34:46 2013	(r315516)
@@ -0,0 +1,2 @@
+SHA256 (MooX-Options-3.77.tar.gz) = 6ad22322eb72832d3510f069d9eec332cd5da5c92961e42340a12230cabbad11
+SIZE (MooX-Options-3.77.tar.gz) = 27604

Added: head/devel/p5-MooX-Options/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/p5-MooX-Options/pkg-descr	Fri Mar 29 01:34:46 2013	(r315516)
@@ -0,0 +1,3 @@
+MooX::Options adds option keywords to your object (Mo/Moo/Moose)
+
+WWW: http://search.cpan.org/dist/MooX-Options/

Added: head/devel/p5-MooX-Options/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/p5-MooX-Options/pkg-plist	Fri Mar 29 01:34:46 2013	(r315516)
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/MooX/Options.pm
+%%SITE_PERL%%/MooX/Options/Role.pm
+@dirrmtry %%SITE_PERL%%/MooX/Options
+@dirrmtry %%SITE_PERL%%/MooX
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"