Bug 180208 - wrong checksum for devel/py-asn1-modules
Summary: wrong checksum for devel/py-asn1-modules
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-02 18:30 UTC by Lance Chen
Modified: 2013-12-23 22:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lance Chen 2013-07-02 18:30:00 UTC
While installing devel/py-asn1-modules through portmaster, check for sha256 checksum shows a mismatch.

Shipped:
SHA256 (pyasn1-modules-0.0.5.tar.gz) = 47d196214aaf28f7fbae4716f57ddc9e8c81d47015e79dba83680f0f9fa19dc8

Correct:
SHA256 (pyasn1-modules-0.0.5.tar.gz) = be65f00ed28e30756f1ef39377cb382480a2368699179d646a84d79fe9349941

My portsnap source is portsnap.FreeBSD.org, and I have done portsnap fetch update. But the distinfo remained the same.

Fix: 

cd /usr/ports/devel/py-asn1-modules
make makesum
How-To-Repeat: portmaster devel/py-asn1-modules
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2013-07-03 01:09:30 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-ports-bugs

ports PR.
Comment 2 Edwin Groothuis freebsd_committer 2013-07-03 01:09:48 UTC
Responsible Changed
From-To: freebsd-ports-bugs->rm

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 3 Ruslan Makhmatkhanov freebsd_committer 2013-07-07 17:54:02 UTC
State Changed
From-To: open->feedback

Hello Lance. Sorry for delay. I can't reproduce it - it is all fine 
here. But there is the issue that tarballs at sourcefourge are different 
than pypi tarballs. I had discussion about this with upstream maintainer 
in past, but there is no solution yet. Would you please revert your 
checksum change, execute make: stopped in /home/rm in port's directory, 
make sure that you are using tarball from sourceforge. If it's ok for 
ypu, I'll just comment out the pypi mirror for a while. Thank you
Comment 4 R.Mahmatkhanov 2013-07-07 17:56:07 UTC
rm@FreeBSD.org wrote on 07.07.2013 20:54:
> Synopsis: wrong checksum for devel/py-asn1-modules
>
> State-Changed-From-To: open->feedback
> State-Changed-By: rm
> State-Changed-When: Sun Jul 7 16:54:02 UTC 2013
> State-Changed-Why:
> Hello Lance. Sorry for delay. I can't reproduce it - it is all fine
> here. But there is the issue that tarballs at sourcefourge are different
> than pypi tarballs. I had discussion about this with upstream maintainer
> in past, but there is no solution yet. Would you please revert your
> checksum change, execute make: stopped in /home/rm in port's directory,
> make sure that you are using tarball from sourceforge. If it's ok for
> ypu, I'll just comment out the pypi mirror for a while. Thank you
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=180208

Please read "execute make: stopped in /home/rm in port's directory" as
"execute `make distclean` in port's directory".

It's an shell expansion issue.

-- 
Regards,
Ruslan

Tinderboxing kills... the drives.
Comment 5 Lance Chen 2013-07-08 14:49:46 UTC
On Mon, Jul 8, 2013 at 12:56 AM, Ruslan Makhmatkhanov <cvs-src@yandex.ru> wrote:
> rm@FreeBSD.org wrote on 07.07.2013 20:54:
>
>> Synopsis: wrong checksum for devel/py-asn1-modules
>>
>> State-Changed-From-To: open->feedback
>> State-Changed-By: rm
>> State-Changed-When: Sun Jul 7 16:54:02 UTC 2013
>> State-Changed-Why:
>> Hello Lance. Sorry for delay. I can't reproduce it - it is all fine
>> here. But there is the issue that tarballs at sourcefourge are different
>> than pypi tarballs. I had discussion about this with upstream maintainer
>> in past, but there is no solution yet. Would you please revert your
>> checksum change, execute make: stopped in /home/rm in port's directory,
>> make sure that you are using tarball from sourceforge. If it's ok for
>> ypu, I'll just comment out the pypi mirror for a while. Thank you
>>
>> http://www.freebsd.org/cgi/query-pr.cgi?pr=180208
>
>
> Please read "execute make: stopped in /home/rm in port's directory" as
> "execute `make distclean` in port's directory".
>
> It's an shell expansion issue.
>
> --
> Regards,
> Ruslan
>
> Tinderboxing kills... the drives.

Hi,

I've done `make distclean && make install clean` again, but still in vain.
And I can verify that it is a pypi issue through manually download and
sha256sum the tarball from pypi.

Output: https://gist.github.com/Lance0312/5948684

Thanks a lot,
Lance
Comment 6 dfilter service freebsd_committer 2013-12-23 22:42:55 UTC
Author: rm
Date: Mon Dec 23 22:42:48 2013
New Revision: 337305
URL: http://svnweb.freebsd.org/changeset/ports/337305

Log:
  - remove pypi mirrors, because they hold different distfile [1]
  - correct license type (BSD 2 clause)
  - support staging
  - use PYDISTUTILS_AUTOPLIST
  - bump PORTREVISION
  
  PR:		180208
  Reported by:	    Lance Chen <cyen0312@gmail.com> [1]

Modified:
  head/devel/py-asn1-modules/Makefile
  head/devel/py-asn1-modules/pkg-plist

Modified: head/devel/py-asn1-modules/Makefile
==============================================================================
--- head/devel/py-asn1-modules/Makefile	Mon Dec 23 22:37:14 2013	(r337304)
+++ head/devel/py-asn1-modules/Makefile	Mon Dec 23 22:42:48 2013	(r337305)
@@ -2,43 +2,34 @@
 
 PORTNAME=	asn1-modules
 PORTVERSION=	0.0.5
+PORTREVISION=	1
 CATEGORIES=	devel python
-MASTER_SITES=	SF/pyasn1/py${PORTNAME}/${PORTVERSION} \
-		CHEESESHOP
+MASTER_SITES=	SF/pyasn1/py${PORTNAME}/${PORTVERSION}
 PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
 DISTNAME=	py${PORTNAME}-${PORTVERSION}
 
 MAINTAINER=	rm@FreeBSD.org
 COMMENT=	Collection of ASN.1 data structures for py-asn1
 
-LICENSE=	BSD
+LICENSE=	BSD2CLAUSE
 
 RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}asn1>=0.1.4:${PORTSDIR}/devel/py-asn1
 
+USES=			shebangfix
+SHEBANG_FILES=		tools/*.py
 USE_PYTHON=		yes
-USE_PYDISTUTILS=	easy_install
-PYDISTUTILS_PKGNAME=	pyasn1-modules
-
-DOCSDIR=	${PREFIX}/share/doc/py-${PORTNAME}
-
-BASEDOCS=	CHANGES README
+USE_PYDISTUTILS=	yes
+PYDISTUTILS_AUTOPLIST=	yes
 
+DOCSDIR=	${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
+PORTDOCS=	CHANGES README
 TOOLS=		cmpdump.py crldump.py crmfdump.py ocspclient.py ocspreqdump.py \
 		ocsprspdump.py ocspserver.py pkcs10dump.py pkcs1dump.py \
 		pkcs7dump.py pkcs8dump.py snmpget.py x509dump.py
 
-NO_STAGE=	yes
-.include <bsd.port.options.mk>
-
 post-install:
-.for t in ${TOOLS}
-	@${INSTALL_SCRIPT} ${WRKSRC}/tools/${t} ${PREFIX}/bin
-.endfor
-.if ${PORT_OPTIONS:MDOCS}
-	@${MKDIR} ${DOCSDIR}
-.for f in ${BASEDOCS}
-	@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
+	${INSTALL_SCRIPT} ${TOOLS:S|^|${WRKSRC}/tools/|} ${STAGEDIR}${PREFIX}/bin
+	@${MKDIR} ${STAGEDIR}${DOCSDIR}
+	${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
 
 .include <bsd.port.mk>

Modified: head/devel/py-asn1-modules/pkg-plist
==============================================================================
--- head/devel/py-asn1-modules/pkg-plist	Mon Dec 23 22:37:14 2013	(r337304)
+++ head/devel/py-asn1-modules/pkg-plist	Mon Dec 23 22:42:48 2013	(r337305)
@@ -11,7 +11,3 @@ bin/pkcs7dump.py
 bin/pkcs8dump.py
 bin/snmpget.py
 bin/x509dump.py
-%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 7 Ruslan Makhmatkhanov freebsd_committer 2013-12-23 22:44:05 UTC
State Changed
From-To: feedback->closed

I just remove pypi mirrors, so we will have consistent distfile and this 
should fix the problem.