Bug 180349 - editors/libreoffice 4.0.4_1 fails to build on freebsd-current
Summary: editors/libreoffice 4.0.4_1 fails to build on freebsd-current
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-06 18:30 UTC by Hiren Panchasara
Modified: 2013-07-23 19:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hiren Panchasara freebsd_committer 2013-07-06 18:30:00 UTC
<skip>
[build CXX] CustomTarget/writerfilter/source/doctok/qnametostr.cxx
[build CXX] CustomTarget/writerfilter/source/ooxml/qnametostr.cxx
[build LNK] Library/libwriterfilterlo.so
[build LNK] Library/libdbulo.so
/usr/bin/ld: /wrkdirs/usr/ports/editors/libreoffice/work/workdir/unxfbsd.pro/CxxObject/dbaccess/source/ui/uno/
copytablewizard.o: relocation R_X86_64_PC32 against `.LBB95_17' can not be used when making a shared object; r
ecompile with -fPIC
/usr/bin/ld: final link failed: Bad value
clang++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[2]: *** [/wrkdirs/usr/ports/editors/libreoffice/work/workdir/unxfbsd.pro/LinkTarget/Library/libdbulo.so]
 Error 1

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 512 occurred while making /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-4.0.4.2/tail_bu
ild/prj

 it seems that the error is inside 'tail_build', please re-run build
 inside this module to isolate the error and/or test your fix.

-----------------------------------------------------------------------
To rebuild a specific module:

gmake tail_build.clean # not recommended, this will re-build almost everything
gmake tail_build

when the problem is isolated and fixed, re-run 'gmake'
gmake[1]: *** [build-packimages] Error 1
gmake[1]: Leaving directory `/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-4.0.4.2'
gmake: *** [all] Error 2
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/libreoffice
===>  Cleaning for libreoffice-4.0.4_1
Comment 1 Edwin Groothuis freebsd_committer 2013-07-06 19:00:24 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Dimitry Andric freebsd_committer 2013-07-23 19:16:05 UTC
State Changed
From-To: open->closed

This was due to several imported changes from upstream llvm, to fix the 
build of qt4-webkit.  I missed one change though, which causes the 
errors you reported (problems with exception labels of the form 
.LBBxx_yy).  I corrected the problem in r253042, and LibreOffice should 
build fine after that.