Bug 180378 - devel/pcre 8.33 compilation problem on ARM
Summary: devel/pcre 8.33 compilation problem on ARM
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Brendan Fabeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-08 08:20 UTC by Łukasz
Modified: 2013-07-11 13:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Łukasz 2013-07-08 08:20:00 UTC
	it is not possible to update to pcre 8.33 on ARM (sheevaplug). pcre-8.32 works fine. There is no difference if STACK_RECURSION
	is turned on or off.
	
===>  Extracting for pcre-8.33
=> SHA256 Checksum OK for pcre-8.33.tar.bz2.
===>  Patching for pcre-8.33
===>  Configuring for pcre-8.33
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking for style of include used by make... GNU
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking dependency style of cc... gcc3
checking for ar... ar
checking the archiver (ar) interface... ar
checking for gcc... (cached) cc
checking whether we are using the GNU C compiler... (cached) yes
checking whether cc accepts -g... (cached) yes
checking for cc option to accept ISO C89... (cached) none needed
checking dependency style of cc... (cached) gcc3
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking dependency style of c++... gcc3
checking whether cc understands -c and -o together... yes
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for int64_t... yes
checking build system type... arm-portbld-freebsd8.3
checking host system type... arm-portbld-freebsd8.3
checking how to print strings... printf
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking for fgrep... (cached) /usr/bin/fgrep
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... (cached) 262144
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... no
checking how to convert arm-portbld-freebsd8.3 file names to arm-portbld-freebsd8.3 format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... dlltool
checking how to associate runtime and link libraries... printf %s\n
checking for archiver @FILE support... no
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking for dlfcn.h... (cached) yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... freebsd8.3 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking how to run the C++ preprocessor... c++ -E
checking for ld used by c++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking for c++ option to produce PIC... -fPIC -DPIC
checking if c++ PIC flag -fPIC -DPIC works... yes
checking if c++ static flag -static works... yes
checking if c++ supports -c -o file.o... yes
checking if c++ supports -c -o file.o... (cached) yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... freebsd8.3 ld.so
checking how to hardcode library paths into programs... immediate
checking whether ln -s works... yes
checking whether the -Werror option is usable... yes
checking for simple visibility declarations... yes
checking for ANSI C header files... (cached) yes
checking for limits.h... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for dirent.h... (cached) yes
checking windows.h usability... no
checking windows.h presence... no
checking for windows.h... no
checking for alias support in the linker... no
checking for alias support in the linker... no
checking string usability... yes
checking string presence... yes
checking for string... yes
checking bits/type_traits.h usability... no
checking bits/type_traits.h presence... no
checking for bits/type_traits.h... no
checking type_traits.h usability... no
checking type_traits.h presence... no
checking for type_traits.h... no
checking for strtoq... yes
checking for long long... yes
checking for unsigned long long... (cached) yes
checking for an ANSI C-conforming const... yes
checking for size_t... (cached) yes
checking for bcopy... yes
checking for memmove... (cached) yes
checking for strerror... (cached) yes
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for gzopen in -lz... yes
checking bzlib.h usability... yes
checking bzlib.h presence... yes
checking for bzlib.h... yes
checking for libbz2... yes
checking editline/readline.h usability... no
checking editline/readline.h presence... no
checking for editline/readline.h... no
checking edit/readline/readline.h usability... yes
checking edit/readline/readline.h presence... yes
checking for edit/readline/readline.h... yes
checking for readline in -ledit... yes
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... -D_THREAD_SAFE
checking for PTHREAD_PRIO_INHERIT... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating libpcre.pc
config.status: creating libpcre16.pc
config.status: creating libpcre32.pc
config.status: creating libpcreposix.pc
config.status: creating libpcrecpp.pc
config.status: creating pcre-config
config.status: creating pcre.h
config.status: creating pcre_stringpiece.h
config.status: creating pcrecpparg.h
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing script-chmod commands
config.status: executing delete-old-chartables commands

pcre-8.33 configuration summary:

    Install prefix .................. : /usr/local
    C preprocessor .................. : cpp
    C compiler ...................... : cc
    C++ preprocessor ................ : c++ -E
    C++ compiler .................... : c++
    Linker .......................... : /usr/bin/ld
    C preprocessor flags ............ :
    C compiler flags ................ : -D_THREAD_SAFE -pthread -pipe -g -fvisibility=hidden
    C++ compiler flags .............. : -pipe -g -fvisibility=hidden -fvisibility-inlines-hidden
    Linker flags .................... :
    Extra libraries ................. :

    Build 8 bit pcre library ........ : yes
    Build 16 bit pcre library ....... : yes
    Build 32 bit pcre library ....... : yes
    Build C++ library ............... : yes
    Enable JIT compiling support .... : yes
    Enable UTF-8/16/32 support ...... : yes
    Unicode properties .............. : yes
    Newline char/sequence ........... : lf
    \R matches only ANYCRLF ......... : no
    EBCDIC coding ................... : no
    EBCDIC code for NL .............. : n/a
    Rebuild char tables ............. : no
    Use stack recursion ............. : yes
    POSIX mem threshold ............. : 10
    Internal link size .............. : 2
    Match limit ..................... : 10000000
    Match limit recursion ........... : MATCH_LIMIT
    Build shared libs ............... : yes
    Build static libs ............... : yes
    Use JIT in pcregrep ............. : yes
    Buffer size for pcregrep ........ : 20480
    Link pcregrep with libz ......... : no
    Link pcregrep with libbz2 ....... : no
    Link pcretest with libedit ...... : yes
    Link pcretest with libreadline .. : no
    Valgrind support ................ : no
    Code coverage ................... : no

===>  Building for pcre-8.33
rm -f pcre_chartables.c
ln -s ./pcre_chartables.c.dist pcre_chartables.c
/usr/bin/make  all-am
  CC       libpcre_la-pcre_byte_order.lo
  CC       libpcre_la-pcre_compile.lo
  CC       libpcre_la-pcre_config.lo
  CC       libpcre_la-pcre_dfa_exec.lo
  CC       libpcre_la-pcre_exec.lo
  CC       libpcre_la-pcre_fullinfo.lo
  CC       libpcre_la-pcre_get.lo
  CC       libpcre_la-pcre_globals.lo
  CC       libpcre_la-pcre_jit_compile.lo
  CC       libpcre_la-pcre_maketables.lo
  CC       libpcre_la-pcre_newline.lo
  CC       libpcre_la-pcre_ord2utf8.lo
  CC       libpcre_la-pcre_refcount.lo
  CC       libpcre_la-pcre_string_utils.lo
  CC       libpcre_la-pcre_study.lo
  CC       libpcre_la-pcre_tables.lo
  CC       libpcre_la-pcre_ucd.lo
  CC       libpcre_la-pcre_valid_utf8.lo
  CC       libpcre_la-pcre_version.lo
  CC       libpcre_la-pcre_xclass.lo
  CC       libpcre_la-pcre_chartables.lo
  CCLD     libpcre.la
  CC       libpcre16_la-pcre16_byte_order.lo
  CC       libpcre16_la-pcre16_chartables.lo
  CC       libpcre16_la-pcre16_compile.lo
  CC       libpcre16_la-pcre16_config.lo
  CC       libpcre16_la-pcre16_dfa_exec.lo
  CC       libpcre16_la-pcre16_exec.lo
  CC       libpcre16_la-pcre16_fullinfo.lo
  CC       libpcre16_la-pcre16_get.lo
  CC       libpcre16_la-pcre16_globals.lo
  CC       libpcre16_la-pcre16_jit_compile.lo
  CC       libpcre16_la-pcre16_maketables.lo
  CC       libpcre16_la-pcre16_newline.lo
  CC       libpcre16_la-pcre16_ord2utf16.lo
  CC       libpcre16_la-pcre16_refcount.lo
  CC       libpcre16_la-pcre16_string_utils.lo
  CC       libpcre16_la-pcre16_study.lo
  CC       libpcre16_la-pcre16_tables.lo
  CC       libpcre16_la-pcre16_ucd.lo
  CC       libpcre16_la-pcre16_utf16_utils.lo
  CC       libpcre16_la-pcre16_valid_utf16.lo
  CC       libpcre16_la-pcre16_version.lo
  CC       libpcre16_la-pcre16_xclass.lo
  CC       libpcre16_la-pcre_chartables.lo
  CCLD     libpcre16.la
  CC       libpcre32_la-pcre32_byte_order.lo
  CC       libpcre32_la-pcre32_chartables.lo
  CC       libpcre32_la-pcre32_compile.lo
  CC       libpcre32_la-pcre32_config.lo
  CC       libpcre32_la-pcre32_dfa_exec.lo
  CC       libpcre32_la-pcre32_exec.lo
  CC       libpcre32_la-pcre32_fullinfo.lo
  CC       libpcre32_la-pcre32_get.lo
  CC       libpcre32_la-pcre32_globals.lo
  CC       libpcre32_la-pcre32_jit_compile.lo
  CC       libpcre32_la-pcre32_maketables.lo
  CC       libpcre32_la-pcre32_newline.lo
  CC       libpcre32_la-pcre32_ord2utf32.lo
  CC       libpcre32_la-pcre32_refcount.lo
  CC       libpcre32_la-pcre32_string_utils.lo
  CC       libpcre32_la-pcre32_study.lo
  CC       libpcre32_la-pcre32_tables.lo
  CC       libpcre32_la-pcre32_ucd.lo
  CC       libpcre32_la-pcre32_utf32_utils.lo
  CC       libpcre32_la-pcre32_valid_utf32.lo
  CC       libpcre32_la-pcre32_version.lo
  CC       libpcre32_la-pcre32_xclass.lo
  CC       libpcre32_la-pcre_chartables.lo
  CCLD     libpcre32.la
  CC       libpcreposix_la-pcreposix.lo
  CCLD     libpcreposix.la
  CXX      libpcrecpp_la-pcrecpp.lo
  CXX      libpcrecpp_la-pcre_scanner.lo
  CXX      libpcrecpp_la-pcre_stringpiece.lo
  CXXLD    libpcrecpp.la
  CC       pcretest-pcretest.o
  CC       pcretest-pcre_printint.o
  CC       pcretest-pcre16_printint.o
  CC       pcretest-pcre32_printint.o
  CCLD     pcretest
./.libs/libpcre.so: undefined reference to `__aeabi_uidivmod'
./.libs/libpcre.so: undefined reference to `__aeabi_idivmod'
*** Error code 1

Stop in /usr/ports/devel/pcre/work/pcre-8.33.
*** Error code 1

Stop in /usr/ports/devel/pcre/work/pcre-8.33.

Fix: 

downgrade to 8.32
How-To-Repeat: 	cd /usr/ports/devel/pcre && make
Comment 1 Edwin Groothuis freebsd_committer 2013-07-08 08:20:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bf

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2013-07-11 13:56:58 UTC
State Changed
From-To: open->closed

Duplicate of ports/180377.