Bug 182195 - (RELEASE - head-amd64-default) irc/scrollz: Build failed for scrollz-2.2.2_2 during configure
Summary: (RELEASE - head-amd64-default) irc/scrollz: Build failed for scrollz-2.2.2_2 ...
Status: Closed DUPLICATE of bug 191274
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Rodrigo Osorio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-17 21:20 UTC by Maarten de Vries
Modified: 2014-09-13 18:45 UTC (History)
0 users

See Also:


Attachments
file.txt (11.29 KB, text/plain)
2013-09-17 21:20 UTC, Maarten de Vries
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten de Vries 2013-09-17 21:20:00 UTC
irc/scrollz will not build on FBSD 10 because libiconv is no longer present.

This configure file should fix it.

Fix: Patch attached with submission follows:
Comment 1 William Grzybowski 2013-09-18 14:28:05 UTC
Hi,

Can you host the patch somewhere or send me privately?

Thanks

-- 
William Grzybowski
------------------------------------------
Curitiba/PR - Brasil
Comment 2 Maarten de Vries 2013-09-18 16:02:26 UTC
Hi William,

On 18/9/13 15:28 , William Grzybowski wrote:

> Can you host the patch somewhere or send me privately?

Certainly! Please download it from here:

http://www.netraam.nl/od/configure
or
http://www.netraam.nl/od/configure.tar

Thanks!

Maarten
Comment 3 Rodrigo Osorio freebsd_committer 2014-02-13 12:45:24 UTC
Responsible Changed
From-To: freebsd-ports-bugs->rodrigo

I'll take it.
Comment 4 Maarten de Vries 2014-02-14 11:26:36 UTC
Hi Rodrigo,

a new version of this port, addressing this issue amongst others, was 
actually finally released early January. However, that didn't build 
properly either, so I had to take it up with the developer. He's still 
working on it, but I expect it to be ready soon. I will then update the 
port as quickly as I can!

Regards,

Maarten

On 14/02/14 12:01, Rodrigo Osorio wrote:
> Hi,
>
> As I can see this PR goes nowhere, the patch submitted is invalid,
> and there was no activity since Sept 2013. However according with
> portsmon[1] and my tests, your port is broken for 10 and beyond.
>
> Find attached a patch to fix the config issue after FBSD 10.0,
> and stagify your port.
>
> Please test it and give me a feedback.
>
> Regards
> - rodrigo
>
>
> [1]
> http://portsmon.freebsd.org/portoverview.py?category=irc&portname=scrollz
>
Comment 5 Rodrigo Osorio freebsd_committer 2014-02-14 12:14:33 UTC
State Changed
From-To: open->feedback

Ask for maintainer approval.
Comment 6 Rodrigo Osorio freebsd_committer 2014-02-17 16:09:24 UTC
Maarten,

Meanwhile, If no action was take, I have to mark the port broken in 10.

- rodrigo

On 14/02/14 11:40 +0000, Maarten de Vries wrote:
> The following reply was made to PR ports/182195; it has been noted by GNATS.
> 
> From: Maarten de Vries <mdv@unsavoury.net>
> To: Rodrigo Osorio <rodrigo@FreeBSD.org>, bug-followup@FreeBSD.org
> Cc:  
> Subject: Re: ports/182195: (RELEASE - head-amd64-default) irc/scrollz: Build
>  failed for scrollz-2.2.2_2 during configure
> Date: Fri, 14 Feb 2014 12:26:36 +0100
> 
>  Hi Rodrigo,
>  
>  a new version of this port, addressing this issue amongst others, was 
>  actually finally released early January. However, that didn't build 
>  properly either, so I had to take it up with the developer. He's still 
>  working on it, but I expect it to be ready soon. I will then update the 
>  port as quickly as I can!
>  
>  Regards,
>  
>  Maarten
>  
Comment 7 Rodrigo Osorio freebsd_committer 2014-09-13 18:45:39 UTC
The port was fixed by pr/191274

*** This bug has been marked as a duplicate of bug 191274 ***