Bug 183271 - [em] statistic not updated on em in netmap mode
Summary: [em] statistic not updated on em in netmap mode
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: Sean Bruno
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2013-10-24 12:10 UTC by Aleksey Fedorov
Modified: 2019-01-10 22:25 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksey Fedorov 2013-10-24 12:10:00 UTC
em0 in netmap mode.
netstat show that no packets is received and transmitted while traffic is present.

# netstat -I em0 1
            input          (em0)           output
   packets  errs idrops      bytes    packets  errs      bytes colls
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0

Fix: 

not known
How-To-Repeat: Start any demo from  /usr/src/tools/tools/netmap on em interface and see counters using netstat.
Comment 1 Hiren Panchasara freebsd_committer 2013-10-25 21:37:54 UTC
Interesting. I see it working fine on -CURRENT.

I did send pkts out of ix0 by putting it in netmap mode:

-bash-4.2$ sudo ./pkt-gen -i ix0 -f tx -n 100000000 -c 8 -p 8 -d
10.73.149.69 -s 10.73.149.81

And at the same time, I could see it in netstat:

-bash-4.2$ netstat -I ix0 1
            input          (ix0)           output
   packets  errs idrops      bytes    packets  errs      bytes colls
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0
         0     0     0          0   12603624     0  806624256     0
         0     0     0          0   13450685     0  860844928     0
         0     0     0          0   13752809     0  880179648     0
         0     0     0          0   13923070     0  891076544     0
            input          (ix0)           output
   packets  errs idrops      bytes    packets  errs      bytes colls
         0     0     0          0   13658263     0  874127680     0
         0     0     0          0   13529053     0  865859776     0
         0     0     0          0   13452062     0  860931712     0
         0     0     0          0    5630434     0  360355456     0
         0     0     0          0          0     0          0     0
         0     0     0          0          0     0          0     0

I will try to findout whats difference between current and 9.2 in this regard.

cheers,
Hiren
Comment 2 Aleksey Fedorov 2013-10-25 21:53:19 UTC
Hi!

I have several ixgbe and all work fine on them in 9.1 and 9.2.

# netstat -I ix0 1
            input          (ix0)           output
   packets  errs idrops      bytes    packets  errs      bytes colls
    174164     0     0  219554276      93908     0  128263302     0
    174179     0     0  219555882      93418     0  127624014     0
    174573     0     0  220132392      94717     0  129380690     0
    173747     0     0  219101644      93755     0  128059768     0


Problem is exactly with em network card.
Comment 3 Hiren Panchasara freebsd_committer 2013-10-25 21:54:45 UTC
On Fri, Oct 25, 2013 at 1:53 PM, Aleksey Fedorov
<aleksey.v.fedorov@gmail.com> wrote:
> Problem is exactly with em network card.

ah, my bad :-)

Thanks for clarifying.

Cheers,
Hiren
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2014-05-04 06:25:38 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 5 Sean Bruno freebsd_committer 2015-06-30 16:39:40 UTC
assignment to validate on em(4) and lem(4)
Comment 6 Sean Bruno freebsd_committer 2015-10-23 18:59:36 UTC
Luigi:

Do you see this in your testing?
Comment 7 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:46:40 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 8 Vincenzo Maffione freebsd_committer 2019-01-10 22:25:58 UTC
Netmap does not increases interface statistics for performance reasons.