Bug 183726 - [exp-run] replace py-distribute with py-setuptools
[exp-run] replace py-distribute with py-setuptools
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: William Grzybowski
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 19:10 UTC by William Grzybowski
Modified: 2013-11-27 20:09 UTC (History)
0 users

See Also:


Attachments
setuptools.txt (14.77 KB, text/plain)
2013-11-06 19:10 UTC, William Grzybowski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Grzybowski freebsd_committer 2013-11-06 19:10:00 UTC
	py-setuptools is again the main project.
	I've sent an email asking for testers but got no response, so I would like to evaluate possible regressions with the switch.
	Let me know if you think it is not worth it.

	Thanks!

Fix: See attached patch, or alternatively find it here: http://people.freebsd.org/~wg/setuptools.txt
Comment 1 Mark Linimon freebsd_committer 2013-11-07 02:40:06 UTC
Responsible Changed
From-To: freebsd-ports-bugs->portmgr

Over to maintainer(s).
Comment 2 Bryan Drewery freebsd_committer 2013-11-11 18:59:44 UTC
Responsible Changed
From-To: portmgr->bdrewery

take for exp-run
Comment 3 Bryan Drewery freebsd_committer 2013-11-14 12:38:29 UTC
Logs at:
http://package19.nyi.freebsd.org/bulk/91amd64-default-pr_183726/2013-11-13_11h43m59s

Comparison shows these new failures:

Note that some are clearly unrelated (like a fetch failure), I leave it
to you to determine which are related and decide when to commit. Let me
know if you want another pass as textproc/py-sphinx failure skipped 416
ports.

> + {"origin"=>"deskutils/conduit", "pkgname"=>"conduit-0.3.17_6", "phase"=>"configure", "errortype"=>"configure_error"}
> + {"origin"=>"deskutils/gourmet", "pkgname"=>"gourmet-0.16.0", "phase"=>"configure", "errortype"=>"cluster"}
> + {"origin"=>"devel/hadoop", "pkgname"=>"apache-hadoop-1.2.1", "phase"=>"build", "errortype"=>"cluster"}
> + {"origin"=>"devel/py-TurboJinja", "pkgname"=>"py27-TurboJinja-0.9.1_2", "phase"=>"configure", "errortype"=>"cluster"}
> + {"origin"=>"devel/py-twistedCore", "pkgname"=>"py27-twistedCore-13.1.0", "phase"=>"configure", "errortype"=>"cluster"}
> + {"origin"=>"editors/gwrite", "pkgname"=>"gwrite-0.5.1_1", "phase"=>"configure", "errortype"=>"cluster"}
> + {"origin"=>"graphics/ocrfeeder", "pkgname"=>"ocrfeeder-0.7.7_2", "phase"=>"configure", "errortype"=>"configure_error"}
> + {"origin"=>"korean/hunspell", "pkgname"=>"ko-hunspell-0.5.6", "phase"=>"build", "errortype"=>"cluster"}
> + {"origin"=>"mail/py-libgmail", "pkgname"=>"py27-libgmail-0.1.11", "phase"=>"configure", "errortype"=>"cluster"}
> + {"origin"=>"net-im/turpial", "pkgname"=>"turpial-1.6.7.1_1", "phase"=>"build", "errortype"=>"cluster"}
> + {"origin"=>"net/arping", "pkgname"=>"arping-2.13", "phase"=>"fetch", "errortype"=>"fetch"}
> + {"origin"=>"science/ghemical", "pkgname"=>"ghemical-3.0.0_1", "phase"=>"build", "errortype"=>"linker_error"}
> + {"origin"=>"science/py-obspy", "pkgname"=>"py27-obspy-0.8.4_2", "phase"=>"configure", "errortype"=>"fetch"}
> + {"origin"=>"sysutils/py-filelike", "pkgname"=>"filelike-0.4.1", "phase"=>"configure", "errortype"=>"fetch"}
> + {"origin"=>"textproc/py-sphinx", "pkgname"=>"py27-sphinx-1.1.3_1", "phase"=>"install", "errortype"=>"cluster"}
> + {"origin"=>"textproc/translate-toolkit", "pkgname"=>"translate-toolkit-1.9.0_1", "phase"=>"build", "errortype"=>"cluster"}
> + {"origin"=>"www/py-amf", "pkgname"=>"py27-amf-0.6.1", "phase"=>"configure", "errortype"=>"fetch"}
> + {"origin"=>"www/py-cssmin", "pkgname"=>"py27-cssmin-0.1.4", "phase"=>"configure", "errortype"=>"fetch"}
> + {"origin"=>"www/py-djblets", "pkgname"=>"py27-djblets-0.7.9_1", "phase"=>"build", "errortype"=>"cluster"}
> + {"origin"=>"www/py-flexget", "pkgname"=>"py27-flexget-1.1.156,1", "phase"=>"run-depends", "errortype"=>"cluster"}
> + {"origin"=>"www/py-prewikka", "pkgname"=>"py27-prewikka-1.0.1p1", "phase"=>"configure", "errortype"=>"cluster"}
> + {"origin"=>"www/py-scriptaculous", "pkgname"=>"py27-scriptaculous-1.8.1.1_2", "phase"=>"configure", "errortype"=>"cluster"}
> + {"origin"=>"www/trac", "pkgname"=>"trac-1.0.1", "phase"=>"configure", "errortype"=>"fetch"}



-- 
Regards,
Bryan Drewery
Comment 4 Bryan Drewery freebsd_committer 2013-11-14 12:38:50 UTC
Responsible Changed
From-To: bdrewery->wg

back to wg
Comment 5 william88 2013-11-23 13:48:34 UTC
Hello,

I've made a new patch to deal with easy-install.pth missing in newer
setuptools install.
Would you be able to make another exp-run with this:
http://people.freebsd.org/~wg/setuptools-v2.txt

Thank you very much!

-- 
William Grzybowski
------------------------------------------
Curitiba/PR - Brasil
Comment 6 William Grzybowski freebsd_committer 2013-11-23 13:49:22 UTC
Responsible Changed
From-To: wg->bdrewery

Over to bdrewery again to check if he can do another exp-run
Comment 8 Bryan Drewery freebsd_committer 2013-11-27 17:03:18 UTC
Responsible Changed
From-To: bdrewery->wg

back to wg
Comment 9 dfilter freebsd_committer 2013-11-27 18:48:57 UTC
Author: wg
Date: Wed Nov 27 18:48:48 2013
New Revision: 335043
URL: http://svnweb.freebsd.org/changeset/ports/335043

Log:
  devel/py-setuptools: Python packages installer
  
  The fork Distribute was merged back into setuptools.
  http://pythonhosted.org/setuptools/merge.html
  
  PR:		ports/183726
  Exp-run by:	bdrewery

Added:
  head/devel/py-setuptools/
  head/devel/py-setuptools/Makefile   (contents, props changed)
  head/devel/py-setuptools/distinfo   (contents, props changed)
  head/devel/py-setuptools/files/
  head/devel/py-setuptools/files/easy-install.pth.dist   (contents, props changed)
  head/devel/py-setuptools/files/pkg-message.in   (contents, props changed)
  head/devel/py-setuptools/pkg-descr   (contents, props changed)
  head/devel/py-setuptools/pkg-plist   (contents, props changed)
Modified:
  head/MOVED
  head/Mk/bsd.python.mk
  head/UPDATING
  head/devel/Makefile

Modified: head/MOVED
==============================================================================
--- head/MOVED	Wed Nov 27 18:33:24 2013	(r335042)
+++ head/MOVED	Wed Nov 27 18:48:48 2013	(r335043)
@@ -5267,3 +5267,4 @@ www/trac-gitplugin||2013-11-25|Removed: 
 audio/mpc|audio/musicpc|2013-11-19|Renamed to avoid conflict with math/mpc
 deskutils/q4wine|emulators/q4wine|2013-11-26|Move to better category
 devel/p5-MooseX-ChainedAccessors||2013-11-27|Has expired: Marked as depreciated upstream
+devel/py-distribute|devel/py-setuptools|2013-11-27|Replaced with setuptools

Modified: head/Mk/bsd.python.mk
==============================================================================
--- head/Mk/bsd.python.mk	Wed Nov 27 18:33:24 2013	(r335042)
+++ head/Mk/bsd.python.mk	Wed Nov 27 18:48:48 2013	(r335043)
@@ -435,8 +435,8 @@ PYTHONPREFIX_SITELIBDIR=	${PYTHON_SITELI
 
 # setuptools support
 .if defined(USE_PYDISTUTILS) && ${USE_PYDISTUTILS} == "easy_install"
-BUILD_DEPENDS+=		${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-distribute
-RUN_DEPENDS+=		${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-distribute
+BUILD_DEPENDS+=		${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+=		${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
 
 PYDISTUTILS_BUILD_TARGET?=		bdist_egg
 PYDISTUTILS_INSTALL_TARGET?=	easy_install

Modified: head/UPDATING
==============================================================================
--- head/UPDATING	Wed Nov 27 18:33:24 2013	(r335042)
+++ head/UPDATING	Wed Nov 27 18:48:48 2013	(r335043)
@@ -5,6 +5,21 @@ they are unavoidable.
 You should get into the habit of checking this file for changes each time
 you update your ports collection, before attempting any port upgrades.
 
+20131127:
+  AFFECTS: users of devel/py-distribute (i.e you)
+  AUTHOR: wg@FreeBSD.org
+
+  devel/py-distribute was replaced with devel/py-setuptools. Please do
+  the following according to package manager used. py-distribute port
+  will be removed shortly.
+
+  # portmaster -o devel/py-setuptools devel/py-distribute
+    or
+  # portupgrade -fo devel/py-setuptools devel/py-distribute
+    or
+  # pkg set -o devel/py-distribute:devel/py-setuptools
+  # pkg install -f devel/py-setuptools
+
 20131125:
   AFFECTS: users of www/mod_wsgi
   AUTHOR: ohauer@FreeBSD.org

Modified: head/devel/Makefile
==============================================================================
--- head/devel/Makefile	Wed Nov 27 18:33:24 2013	(r335042)
+++ head/devel/Makefile	Wed Nov 27 18:48:48 2013	(r335043)
@@ -3754,6 +3754,7 @@
     SUBDIR += py-sdl2
     SUBDIR += py-serpent
     SUBDIR += py-setproctitle
+    SUBDIR += py-setuptools
     SUBDIR += py-setuptools-git
     SUBDIR += py-setuptools_darcs
     SUBDIR += py-setuptools_hg

Added: head/devel/py-setuptools/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/py-setuptools/Makefile	Wed Nov 27 18:48:48 2013	(r335043)
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME=	setuptools
+PORTVERSION=	1.1.7
+CATEGORIES=	devel python
+MASTER_SITES=	CHEESESHOP
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR=	python
+
+MAINTAINER=	python@FreeBSD.org
+COMMENT=	Python packages installer
+
+LICENSE=	PSFL
+
+CONFLICTS_INSTALL=	${PYTHON_PKGNAMEPREFIX}distribute-[0-9]*
+
+PLIST_SUB=	PYVER=${PYTHON_VER} VERSION=${PORTVERSION} \
+		EASYINSTALL_PTH=${PYTHON_SITELIBDIR}/easy-install.pth
+
+PYDISTUTILS_NOEGGINFO=	yes
+USE_PYTHON=	yes
+USE_PYDISTUTILS=yes
+
+SUB_LIST=	IF_DEFAULT=${IF_DEFAULT}
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION} && !exists(${LOCALBASE}/bin/easy_install)
+PLIST_SUB+=	IF_DEFAULT=""
+.else
+PLIST_SUB+=	IF_DEFAULT="@comment "
+SUB_FILES+=	pkg-message
+.endif
+
+post-install:
+	${INSTALL_DATA} ${FILESDIR}/easy-install.pth.dist ${STAGEDIR}${PYTHON_SITELIBDIR}/
+
+regression-test: build
+	@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
+.include <bsd.port.post.mk>

Added: head/devel/py-setuptools/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/py-setuptools/distinfo	Wed Nov 27 18:48:48 2013	(r335043)
@@ -0,0 +1,2 @@
+SHA256 (python/setuptools-1.1.7.tar.gz) = b35e3d7c79cfdb5b38cfc71f4b0deab4350c1176fc4bb05bfa8945504ecfb028
+SIZE (python/setuptools-1.1.7.tar.gz) = 682308

Added: head/devel/py-setuptools/files/easy-install.pth.dist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/py-setuptools/files/easy-install.pth.dist	Wed Nov 27 18:48:48 2013	(r335043)
@@ -0,0 +1,2 @@
+import sys; sys.__plen = len(sys.path)
+import sys; new=sys.path[sys.__plen:]; del sys.path[sys.__plen:]; p=getattr(sys,'__egginsert',0); sys.path[p:p]=new; sys.__egginsert = p+len(new)

Added: head/devel/py-setuptools/files/pkg-message.in
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/py-setuptools/files/pkg-message.in	Wed Nov 27 18:48:48 2013	(r335043)
@@ -0,0 +1,7 @@
+*********************************************************************
+
+    The script %%PREFIX%%/bin/easy_install was already installed
+    on your system, so the only script %%PREFIX%%/bin/easy_install-%%PYVER%%
+    has been added.
+
+*********************************************************************

Added: head/devel/py-setuptools/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/py-setuptools/pkg-descr	Wed Nov 27 18:48:48 2013	(r335043)
@@ -0,0 +1,10 @@
+Setuptools is a fully-featured, actively-maintained, and stable library
+designed to facilitate packaging Python projects, where packaging includes:
+ - Python package and module definitions
+ - Distribution package metadata
+ - Test hooks
+ - Project installation
+ - Platform-specific details
+ - Python 3 support
+
+WWW: https://pypi.python.org/pypi/setuptools

Added: head/devel/py-setuptools/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/py-setuptools/pkg-plist	Wed Nov 27 18:48:48 2013	(r335043)
@@ -0,0 +1,216 @@
+%%IF_DEFAULT%%bin/easy_install
+bin/easy_install-%%PYVER%%
+@unexec if cmp -s %%EASYINSTALL_PTH%% %%EASYINSTALL_PTH%%.dist; then rm -f %%EASYINSTALL_PTH%%; fi
+%%PYTHON_SITELIBDIR%%/easy-install.pth.dist
+@exec if [ ! -f "%%EASYINSTALL_PTH%%" ]; then cp -p %%EASYINSTALL_PTH%%.dist %%EASYINSTALL_PTH%%; fi
+%%PYTHON_SITELIBDIR%%/_markerlib/__init__.py
+%%PYTHON_SITELIBDIR%%/_markerlib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/_markerlib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/_markerlib/markers.py
+%%PYTHON_SITELIBDIR%%/_markerlib/markers.pyc
+%%PYTHON_SITELIBDIR%%/_markerlib/markers.pyo
+%%PYTHON_SITELIBDIR%%/easy_install.py
+%%PYTHON_SITELIBDIR%%/easy_install.pyc
+%%PYTHON_SITELIBDIR%%/easy_install.pyo
+%%PYTHON_SITELIBDIR%%/pkg_resources.py
+%%PYTHON_SITELIBDIR%%/pkg_resources.pyc
+%%PYTHON_SITELIBDIR%%/pkg_resources.pyo
+%%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info/PKG-INFO
+%%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info/entry_points.txt
+%%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info/entry_points.txt.orig
+%%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info/requires.txt
+%%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info/top_level.txt
+%%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info/zip-safe
+%%PYTHON_SITELIBDIR%%/setuptools/__init__.py
+%%PYTHON_SITELIBDIR%%/setuptools/__init__.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/__init__.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/__init__.py
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/__init__.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/__init__.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/__init__.py
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha.py
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha256.py
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha256.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha256.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha512.py
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha512.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib/_sha512.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/archive_util.py
+%%PYTHON_SITELIBDIR%%/setuptools/archive_util.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/archive_util.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/__init__.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/__init__.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/__init__.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/alias.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/alias.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/alias.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_egg.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_egg.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_egg.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_rpm.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_rpm.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_rpm.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_wininst.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_wininst.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/bdist_wininst.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/build_ext.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/build_ext.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/build_ext.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/build_py.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/build_py.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/build_py.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/develop.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/develop.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/develop.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/easy_install.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/easy_install.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/easy_install.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/egg_info.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/egg_info.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/egg_info.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/install.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/install.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/install.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_egg_info.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_egg_info.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_egg_info.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_lib.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_lib.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_lib.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_scripts.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_scripts.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/install_scripts.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/register.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/register.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/register.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/rotate.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/rotate.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/rotate.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/saveopts.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/saveopts.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/saveopts.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/sdist.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/sdist.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/sdist.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/setopt.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/setopt.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/setopt.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/test.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/test.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/test.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/upload.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/upload.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/upload.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/command/upload_docs.py
+%%PYTHON_SITELIBDIR%%/setuptools/command/upload_docs.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/command/upload_docs.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/compat.py
+%%PYTHON_SITELIBDIR%%/setuptools/compat.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/compat.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/depends.py
+%%PYTHON_SITELIBDIR%%/setuptools/depends.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/depends.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/dist.py
+%%PYTHON_SITELIBDIR%%/setuptools/dist.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/dist.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/extension.py
+%%PYTHON_SITELIBDIR%%/setuptools/extension.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/extension.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/package_index.py
+%%PYTHON_SITELIBDIR%%/setuptools/package_index.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/package_index.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/py24compat.py
+%%PYTHON_SITELIBDIR%%/setuptools/py24compat.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/py24compat.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/py26compat.py
+%%PYTHON_SITELIBDIR%%/setuptools/py26compat.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/py26compat.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/py27compat.py
+%%PYTHON_SITELIBDIR%%/setuptools/py27compat.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/py27compat.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/sandbox.py
+%%PYTHON_SITELIBDIR%%/setuptools/sandbox.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/sandbox.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/script template (dev).py
+%%PYTHON_SITELIBDIR%%/setuptools/script template (dev).pyc
+%%PYTHON_SITELIBDIR%%/setuptools/script template (dev).pyo
+%%PYTHON_SITELIBDIR%%/setuptools/script template.py
+%%PYTHON_SITELIBDIR%%/setuptools/script template.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/script template.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/site-patch.py
+%%PYTHON_SITELIBDIR%%/setuptools/site-patch.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/site-patch.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/ssl_support.py
+%%PYTHON_SITELIBDIR%%/setuptools/ssl_support.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/ssl_support.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/doctest.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/doctest.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/doctest.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/py26compat.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/py26compat.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/py26compat.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/script-with-bom.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/script-with-bom.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/script-with-bom.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/server.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/server.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/server.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_bdist_egg.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_bdist_egg.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_bdist_egg.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_build_ext.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_build_ext.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_build_ext.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_develop.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_develop.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_develop.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_dist_info.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_dist_info.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_dist_info.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_easy_install.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_easy_install.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_easy_install.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_egg_info.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_egg_info.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_egg_info.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_markerlib.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_markerlib.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_markerlib.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_packageindex.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_packageindex.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_packageindex.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_resources.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_resources.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_resources.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_sandbox.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_sandbox.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_sandbox.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_sdist.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_sdist.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_sdist.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_test.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_test.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_test.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_upload_docs.py
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_upload_docs.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/tests/test_upload_docs.pyo
+%%PYTHON_SITELIBDIR%%/setuptools/version.py
+%%PYTHON_SITELIBDIR%%/setuptools/version.pyc
+%%PYTHON_SITELIBDIR%%/setuptools/version.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/setuptools/tests
+@dirrmtry %%PYTHON_SITELIBDIR%%/setuptools/command
+@dirrmtry %%PYTHON_SITELIBDIR%%/setuptools/_backport/hashlib
+@dirrmtry %%PYTHON_SITELIBDIR%%/setuptools/_backport
+@dirrmtry %%PYTHON_SITELIBDIR%%/setuptools-%%VERSION%%-py%%PYVER%%.egg-info
+@dirrmtry %%PYTHON_SITELIBDIR%%/setuptools
+@dirrmtry %%PYTHON_SITELIBDIR%%/_markerlib
+@dirrmtry %%PYTHON_SITELIBDIR%%
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 10 William Grzybowski freebsd_committer 2013-11-27 20:09:29 UTC
State Changed
From-To: open->closed

Committed. Thanks!