Bug 184956 - Update audio/opus ports
Summary: Update audio/opus ports
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Christian Weisgerber
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-18 08:00 UTC by Eric Camachat
Modified: 2013-12-18 16:10 UTC (History)
0 users

See Also:


Attachments
file.diff (2.78 KB, patch)
2013-12-18 08:00 UTC, Eric Camachat
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Camachat 2013-12-18 08:00:01 UTC
Update audio/opus ports to version 1.1.
Tested by totem via gstreamer-plugins-opus.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2013-12-18 08:01:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->naddy

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-12-18 16:04:59 UTC
Author: naddy
Date: Wed Dec 18 16:04:49 2013
New Revision: 336843
URL: http://svnweb.freebsd.org/changeset/ports/336843

Log:
  Update opus to 1.1, which includes:
  * new analysis code and tuning that significantly improves encoding
    quality, especially for variable-bitrate (VBR),
  * automatic detection of speech or music to decide which encoding
    mode to use,
  * surround with good quality at 128 kbps for 5.1 and usable down
    to 48 kbps,
  * and speed improvements on all architectures.
  
  Chase shared library bump.
  
  PR:		184956

Added:
  head/audio/opus/files/
  head/audio/opus/files/patch-configure   (contents, props changed)
Modified:
  head/audio/gstreamer-plugins-opus/Makefile
  head/audio/gstreamer1-plugins-opus/Makefile
  head/audio/mumble/Makefile
  head/audio/opus/Makefile
  head/audio/opus/distinfo
  head/audio/opus/pkg-plist
  head/multimedia/vlc/Makefile

Modified: head/audio/gstreamer-plugins-opus/Makefile
==============================================================================
--- head/audio/gstreamer-plugins-opus/Makefile	Wed Dec 18 15:49:52 2013	(r336842)
+++ head/audio/gstreamer-plugins-opus/Makefile	Wed Dec 18 16:04:49 2013	(r336843)
@@ -1,6 +1,6 @@
 # $FreeBSD$
 
-PORTREVISION=	1
+PORTREVISION=	2
 CATEGORIES=	audio
 
 COMMENT=	Gstreamer Opus audio encoder/decoder plugin

Modified: head/audio/gstreamer1-plugins-opus/Makefile
==============================================================================
--- head/audio/gstreamer1-plugins-opus/Makefile	Wed Dec 18 15:49:52 2013	(r336842)
+++ head/audio/gstreamer1-plugins-opus/Makefile	Wed Dec 18 16:04:49 2013	(r336843)
@@ -1,6 +1,6 @@
 # $FreeBSD$
 
-PORTREVISION=	0
+PORTREVISION=	1
 CATEGORIES=	audio
 
 COMMENT=	Gstreamer Opus audio encoder/decoder plugin

Modified: head/audio/mumble/Makefile
==============================================================================
--- head/audio/mumble/Makefile	Wed Dec 18 15:49:52 2013	(r336842)
+++ head/audio/mumble/Makefile	Wed Dec 18 16:04:49 2013	(r336843)
@@ -3,7 +3,7 @@
 
 PORTNAME=	mumble
 PORTVERSION=	1.2.4
-PORTREVISION=	4
+PORTREVISION=	5
 CATEGORIES=	audio
 MASTER_SITES=	SF/${PORTNAME}/Mumble/${PORTVERSION}
 

Modified: head/audio/opus/Makefile
==============================================================================
--- head/audio/opus/Makefile	Wed Dec 18 15:49:52 2013	(r336842)
+++ head/audio/opus/Makefile	Wed Dec 18 16:04:49 2013	(r336843)
@@ -1,7 +1,7 @@
 # $FreeBSD$
 
 PORTNAME=	opus
-PORTVERSION=	1.0.3
+PORTVERSION=	1.1
 CATEGORIES=	audio
 MASTER_SITES=	http://downloads.xiph.org/releases/opus/ \
 		https://ftp.mozilla.org/pub/mozilla.org/opus/
@@ -9,7 +9,7 @@ MASTER_SITES=	http://downloads.xiph.org/
 MAINTAINER=	naddy@FreeBSD.org
 COMMENT=	IETF audio codec
 
-USES=		pathfix
+USES=		gmake pathfix
 USE_AUTOTOOLS=	libtool
 USE_LDCONFIG=	yes
 
@@ -19,7 +19,7 @@ CONFIGURE_ARGS=	--enable-custom-modes \
 		--disable-doc   # requires doxygen
 
 regression-test: build
-	@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+	@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
 
 .include <bsd.port.options.mk>
 

Modified: head/audio/opus/distinfo
==============================================================================
--- head/audio/opus/distinfo	Wed Dec 18 15:49:52 2013	(r336842)
+++ head/audio/opus/distinfo	Wed Dec 18 16:04:49 2013	(r336843)
@@ -1,2 +1,2 @@
-SHA256 (opus-1.0.3.tar.gz) = 191a089c92dbc403de6980463dd3604b65beb12d283c607e246c8076363cb49c
-SIZE (opus-1.0.3.tar.gz) = 781049
+SHA256 (opus-1.1.tar.gz) = b9727015a58affcf3db527322bf8c4d2fcf39f5f6b8f15dbceca20206cbe1d95
+SIZE (opus-1.1.tar.gz) = 850208

Added: head/audio/opus/files/patch-configure
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/audio/opus/files/patch-configure	Wed Dec 18 16:04:49 2013	(r336843)
@@ -0,0 +1,20 @@
+--- configure.orig	2013-12-17 16:51:41.000000000 +0100
++++ configure	2013-12-17 16:52:02.000000000 +0100
+@@ -12807,7 +12807,7 @@ else
+   CPU_ARM_FALSE=
+ fi
+ 
+- if test x"${inline_optimization:0:3}" = x"ARM"; then
++ if expr x"${inline_optimization}" : x"ARM" >/dev/null; then
+   OPUS_ARM_INLINE_ASM_TRUE=
+   OPUS_ARM_INLINE_ASM_FALSE='#'
+ else
+@@ -12815,7 +12815,7 @@ else
+   OPUS_ARM_INLINE_ASM_FALSE=
+ fi
+ 
+- if test x"${asm_optimization:0:3}" = x"ARM"; then
++ if expr x"${asm_optimization}" : x"ARM" >/dev/null; then
+   OPUS_ARM_EXTERNAL_ASM_TRUE=
+   OPUS_ARM_EXTERNAL_ASM_FALSE='#'
+ else

Modified: head/audio/opus/pkg-plist
==============================================================================
--- head/audio/opus/pkg-plist	Wed Dec 18 15:49:52 2013	(r336842)
+++ head/audio/opus/pkg-plist	Wed Dec 18 16:04:49 2013	(r336843)
@@ -6,7 +6,7 @@ include/opus/opus_types.h
 lib/libopus.a
 lib/libopus.la
 lib/libopus.so
-lib/libopus.so.4
+lib/libopus.so.5
 libdata/pkgconfig/opus.pc
 share/aclocal/opus.m4
 @dirrm include/opus

Modified: head/multimedia/vlc/Makefile
==============================================================================
--- head/multimedia/vlc/Makefile	Wed Dec 18 15:49:52 2013	(r336842)
+++ head/multimedia/vlc/Makefile	Wed Dec 18 16:04:49 2013	(r336843)
@@ -3,7 +3,7 @@
 
 PORTNAME=	vlc
 DISTVERSION=	2.1.1
-PORTREVISION=	1
+PORTREVISION=	2
 PORTEPOCH=	4
 CATEGORIES=	multimedia audio ipv6 net www
 MASTER_SITES=	http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Christian Weisgerber freebsd_committer 2013-12-18 16:06:05 UTC
State Changed
From-To: open->closed

Thanks, I was already working on this and committed a somewhat different 
diff.  (How did this ever work for you without gmake??)