Bug 185684 - [PATCH] devel/swig20: update to 2.0.11, backport C++11 SWIG rixes
[PATCH] devel/swig20: update to 2.0.11, backport C++11 SWIG rixes
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Kubilay Kocak
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-12 14:00 UTC by koobs.freebsd
Modified: 2014-01-14 09:28 UTC (History)
1 user (show)

See Also:


Attachments
swig-2.0.11.patch (34.80 KB, patch)
2014-01-12 14:00 UTC, koobs.freebsd
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description koobs.freebsd 2014-01-12 14:00:00 UTC
devel/swig20: update to 2.0.11, backport C++11 fixes

- Update to 2.0.11
- Update pkg-plist
- Enable STAGE support
- Modernise LIB_DEPENDS
- Backport C++11 SWIG fixes from upstream for games/py-fife [1][2]
- pkg-descr: Tab to space in WWW:

[1] Commit: https://github.com/swig/swig/commit/92128eef445f75f674894e3f5d4e1fc2a1818957
[2] Issue: https://github.com/swig/swig/issues/73

portlint: WARN - Makefile: only one MASTER_SITE configured.
redports: OK - https://redports.org/buildarchive/20140112070401-18077/
testport: OK - poudriere, all versions/archs

Port maintainer (jwbacon@tds.net) is cc'd.

Generated with FreeBSD Port Tools 0.99_11 (mode: update, diff: ports)
Comment 1 Edwin Groothuis freebsd_committer 2014-01-12 14:00:10 UTC
Maintainer of devel/swig20,

Please note that PR ports/185684 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/185684

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2014-01-12 14:00:11 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 jwbacon 2014-01-12 21:15:08 UTC
Approved, thanks.

On 1/12/14 8:00 AM, Edwin Groothuis wrote:
> Maintainer of devel/swig20,
>
> Please note that PR ports/185684 has just been submitted.
>
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the patch
> and a committer will take care of it.
>
> The full text of the PR can be found at:
>      http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/185684
>
Comment 4 Kubilay Kocak freebsd_committer 2014-01-13 07:56:05 UTC
Responsible Changed
From-To: freebsd-ports-bugs->koobs

I'll take it.
Comment 5 koobs.freebsd 2014-01-13 09:48:19 UTC
Jason,

I'd like to make 2 additional changes before I commit this:

- Add a regression-test target so users/developers may run the test suite:

regression-test: build
	cd ${WRKSRC} && ${MAKE} check

Add USES=gmake as per:

http://www.swig.org/Doc2.0/Preface.html:

"You must use GNU make to build and install SWIG."

This note was removed from the README into the HTML documentation in:

https://github.com/swig/swig/commit/4bf045ce2c72f3cf3a20caa9dc42b26c9e6b6458#diff-c47c7c7383225ab55ff591cb59c41e6b

The test suite fails part way when invoked with our make:

make: don't know how to make check-tcl-version. Stop
Comment 6 jwbacon 2014-01-13 15:57:39 UTC
OK by me...

Regards,

     JB

On 01/13/14 03:48, Kubilay Kocak wrote:
> Jason,
>
> I'd like to make 2 additional changes before I commit this:
>
> - Add a regression-test target so users/developers may run the test suite:
>
> regression-test: build
> 	cd ${WRKSRC} && ${MAKE} check
>
> Add USES=gmake as per:
>
> http://www.swig.org/Doc2.0/Preface.html:
>
> "You must use GNU make to build and install SWIG."
>
> This note was removed from the README into the HTML documentation in:
>
> https://github.com/swig/swig/commit/4bf045ce2c72f3cf3a20caa9dc42b26c9e6b6458#diff-c47c7c7383225ab55ff591cb59c41e6b
>
> The test suite fails part way when invoked with our make:
>
> make: don't know how to make check-tcl-version. Stop
Comment 7 dfilter freebsd_committer 2014-01-14 09:01:54 UTC
Author: koobs
Date: Tue Jan 14 09:01:38 2014
New Revision: 339666
URL: http://svnweb.freebsd.org/changeset/ports/339666

Log:
  devel/swig20: update to 2.0.11, Backport C++11 fixes, Use GNU Make
  
  - Update to 2.0.11
  - Update pkg-plist
  - Enable STAGE support
  - Backport C++11 SWIG fixes from upstream for games/py-fife [1][2]
  - Use GNU Make as recommended by upstream [3]
  - Modernise LIB_DEPENDS
  - Add regression-test: target to make running the test suite easier
  - pkg-descr: Tab to space in WWW:
  
  [1] Commit: https://github.com/swig/swig/commit/92128eef445f75f674894e3f5d4e1fc2a1818957
  [2] Issue: https://github.com/swig/swig/issues/73
  [3] http://www.swig.org/Doc2.0/Preface.html
  
  PR:		ports/185684
  Submitted by:	koobs
  Approved by:	Jason Bacon <jwbacon@tds.net> (maintainer)
  MFH:		2014Q1

Added:
  head/devel/swig20/files/
  head/devel/swig20/files/patch-Lib__std__std_container.i   (contents, props changed)
  head/devel/swig20/files/patch-Lib__std__std_map.i   (contents, props changed)
  head/devel/swig20/files/patch-Lib__std__std_set.i   (contents, props changed)
Modified:
  head/devel/swig20/Makefile
  head/devel/swig20/distinfo
  head/devel/swig20/pkg-descr   (contents, props changed)
  head/devel/swig20/pkg-plist

Modified: head/devel/swig20/Makefile
==============================================================================
--- head/devel/swig20/Makefile	Tue Jan 14 08:53:50 2014	(r339665)
+++ head/devel/swig20/Makefile	Tue Jan 14 09:01:38 2014	(r339666)
@@ -2,7 +2,7 @@
 # $FreeBSD$
 
 PORTNAME=	swig
-PORTVERSION=	2.0.9
+PORTVERSION=	2.0.11
 CATEGORIES=	devel
 MASTER_SITES=	SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
 
@@ -11,26 +11,22 @@ COMMENT=	Generate wrappers for calling C
 
 LICENSE=	GPLv3
 
-LIB_DEPENDS=	pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS=	libpcre.so:${PORTSDIR}/devel/pcre
 
+USES=		gmake
 USE_AUTOTOOLS=	autoconf:env libtool
 
-MAN1=		ccache-swig${VER}.1
-
 VER=		${PORTVERSION:R}
-PLIST_SUB+=	PORTVERSION=${PORTVERSION}
+PLIST_SUB+=	PORTVERSION=${PORTVERSION} VER="${VER}"
 
-WRKSRC=		${WRKDIR}/${DISTNAME}
 CFLAGS+=	-fPIC -DPIC
-ALL_TARGET=	swig
-PLIST_SUB+=	VER="${VER}"
+ALL_TARGET=	# none
 
 WANT_LUA=	yes
 WANT_LUA_VER=	5.0+
 
 CONFIGURE_ARGS+=--program-suffix=${VER}
 
-NO_STAGE=	yes
 .include <bsd.port.pre.mk>
 
 .if ${HAVE_LUA:Mlua-5.*} != ""
@@ -59,18 +55,21 @@ post-configure:
 
 post-install:
 .if ${PORT_OPTIONS:MEXAMPLES}
-	${MKDIR} ${EXAMPLESDIR}/${PORTVERSION}
+	${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${PORTVERSION}
 	cd ${WRKSRC}/Examples && ${FIND} . -type d \
-		-exec ${INSTALL} -d ${EXAMPLESDIR}/${PORTVERSION}/{} \;
+		-exec ${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}/${PORTVERSION}/{} \;
 	cd ${WRKSRC}/Examples && ${FIND} . -type f \
-		-exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/${PORTVERSION}/{} \;
+		-exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/${PORTVERSION}/{} \;
 .endif
 .if ${PORT_OPTIONS:MDOCS}
-	${MKDIR} ${DOCSDIR}/${PORTVERSION}
+	${MKDIR} ${STAGEDIR}${DOCSDIR}/${PORTVERSION}
 	cd ${WRKSRC}/Doc && ${FIND} . -type d \
-		-exec ${INSTALL} -d ${DOCSDIR}/${PORTVERSION}/{} \;
+		-exec ${INSTALL} -d ${STAGEDIR}${DOCSDIR}/${PORTVERSION}/{} \;
 	cd ${WRKSRC}/Doc && ${FIND} . -type f \
-		-exec ${INSTALL_DATA} {} ${DOCSDIR}/${PORTVERSION}/{} \;
+		-exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/${PORTVERSION}/{} \;
 .endif
 
+regression-test: build
+	cd ${WRKSRC} && ${GMAKE} check
+
 .include <bsd.port.post.mk>

Modified: head/devel/swig20/distinfo
==============================================================================
--- head/devel/swig20/distinfo	Tue Jan 14 08:53:50 2014	(r339665)
+++ head/devel/swig20/distinfo	Tue Jan 14 09:01:38 2014	(r339666)
@@ -1,2 +1,2 @@
-SHA256 (swig-2.0.9.tar.gz) = 586954000d297fafd7e91d1ad31089cc7e249f658889d11a44605d3662569539
-SIZE (swig-2.0.9.tar.gz) = 5307341
+SHA256 (swig-2.0.11.tar.gz) = 63780bf29f53937ad399a1f68bccb3730c90f65746868c4cdfc25cafcd0a424e
+SIZE (swig-2.0.11.tar.gz) = 5310295

Added: head/devel/swig20/files/patch-Lib__std__std_container.i
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/swig20/files/patch-Lib__std__std_container.i	Tue Jan 14 09:01:38 2014	(r339666)
@@ -0,0 +1,53 @@
+--- ./Lib/std/std_container.i.orig	2014-01-12 12:49:23.125903702 +1100
++++ ./Lib/std/std_container.i	2014-01-12 17:22:07.027709014 +1100
+@@ -46,8 +46,14 @@
+   void resize(size_type new_size);
+   
+   #ifdef SWIG_EXPORT_ITERATOR_METHODS
+-  iterator erase(iterator pos);
+-  iterator erase(iterator first, iterator last);
++// Backport C++11 support
++// Issue ID: https://github.com/swig/swig/issues/73
++// Commit: https://github.com/swig/swig/commit/92128eef445f75f674894e3f5d4e1fc2a1818957
++%extend {
++  // %extend wrapper used for differing definitions of these methods introduced in C++11
++  iterator erase(iterator pos) { return $self->erase(pos); }
++  iterator erase(iterator first, iterator last) { return $self->erase(first, last); }
++}
+   #endif
+   
+ %enddef
+@@ -68,8 +74,14 @@
+   void resize(size_type new_size, const value_type& x);
+   
+   #ifdef SWIG_EXPORT_ITERATOR_METHODS
+-  iterator insert(iterator pos, const value_type& x);
+-  void insert(iterator pos, size_type n, const value_type& x);
++// Backport C++11 support
++// Issue ID: https://github.com/swig/swig/issues/73
++// Commit: https://github.com/swig/swig/commit/92128eef445f75f674894e3f5d4e1fc2a1818957
++%extend {
++  // %extend wrapper used for differing definitions of these methods introduced in C++11
++  iterator insert(iterator pos, const value_type& x) { return $self->insert(pos, x); }
++  void insert(iterator pos, size_type n, const value_type& x) { $self->insert(pos, n, x); }
++}
+   #endif
+   
+ %enddef
+@@ -89,8 +101,14 @@
+   void resize(size_type new_size, value_type x);
+   
+   #ifdef SWIG_EXPORT_ITERATOR_METHODS
+-  iterator insert(iterator pos, value_type x);
+-  void insert(iterator pos, size_type n, value_type x);
++// Backport C++11 support
++// Issue ID: https://github.com/swig/swig/issues/73
++// Commit: https://github.com/swig/swig/commit/92128eef445f75f674894e3f5d4e1fc2a1818957
++%extend {
++  // %extend wrapper used for differing definitions of these methods introduced in C++11
++  iterator insert(iterator pos, value_type x) { return $self->insert(pos, x); }
++  void insert(iterator pos, size_type n, value_type x) { $self->insert(pos, n, x); }
++}
+   #endif
+   
+ %enddef

Added: head/devel/swig20/files/patch-Lib__std__std_map.i
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/swig20/files/patch-Lib__std__std_map.i	Tue Jan 14 09:01:38 2014	(r339666)
@@ -0,0 +1,20 @@
+--- ./Lib/std/std_map.i.orig	2014-01-12 17:22:34.464286699 +1100
++++ ./Lib/std/std_map.i	2014-01-12 17:25:54.847499215 +1100
+@@ -12,9 +12,14 @@
+   size_type count(const key_type& x) const;
+ 
+ #ifdef SWIG_EXPORT_ITERATOR_METHODS
+-//  iterator insert(iterator position, const value_type& x);
+-  void erase(iterator position);
+-  void erase(iterator first, iterator last);
++// Backport C++11 support
++// Issue ID: https://github.com/swig/swig/issues/73
++// Commit: https://github.com/swig/swig/commit/92128eef445f75f674894e3f5d4e1fc2a1818957
++%extend {
++  // %extend wrapper used for differing definitions of these methods introduced in C++11
++  void erase(iterator position) { $self->erase(position); }
++  void erase(iterator first, iterator last) { $self->erase(first, last); }
++}
+ 
+   iterator find(const key_type& x);
+   iterator lower_bound(const key_type& x);

Added: head/devel/swig20/files/patch-Lib__std__std_set.i
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/swig20/files/patch-Lib__std__std_set.i	Tue Jan 14 09:01:38 2014	(r339666)
@@ -0,0 +1,19 @@
+--- ./Lib/std/std_set.i.orig	2014-01-12 17:24:56.140822773 +1100
++++ ./Lib/std/std_set.i	2014-01-12 17:25:47.509154979 +1100
+@@ -29,8 +29,14 @@
+   reverse_iterator rbegin();
+   reverse_iterator rend();
+ 
+-  void erase(iterator pos);
+-  void erase(iterator first, iterator last);
++// Backport C++11 support
++// Issue ID: https://github.com/swig/swig/issues/73
++// Commit: https://github.com/swig/swig/commit/92128eef445f75f674894e3f5d4e1fc2a1818957
++%extend {
++  // %extend wrapper used for differing definitions of these methods introduced in C++11
++  void erase(iterator pos) { $self->erase(pos); }
++  void erase(iterator first, iterator last) { $self->erase(first, last); }
++}
+ 
+   iterator find(const key_type& x);
+   iterator lower_bound(const key_type& x);

Modified: head/devel/swig20/pkg-descr
==============================================================================
--- head/devel/swig20/pkg-descr	Tue Jan 14 08:53:50 2014	(r339665)
+++ head/devel/swig20/pkg-descr	Tue Jan 14 09:01:38 2014	(r339666)
@@ -6,4 +6,4 @@ Using SWIG, it is possible to greatly si
 and to put interesting interfaces on existing applications with
 little effort.    
 
-WWW:	http://www.swig.org/
+WWW: http://www.swig.org/

Modified: head/devel/swig20/pkg-plist
==============================================================================
--- head/devel/swig20/pkg-plist	Tue Jan 14 08:53:50 2014	(r339665)
+++ head/devel/swig20/pkg-plist	Tue Jan 14 09:01:38 2014	(r339666)
@@ -1,5 +1,6 @@
-bin/ccache-swig2.0
-bin/swig2.0
+bin/ccache-swig%%VER%%
+bin/swig%%VER%%
+man/man1/ccache-swig2.0.1.gz
 %%PORTDOCS%%%%DOCSDIR%%/%%PORTVERSION%%/Devel/cmdopt.html
 %%PORTDOCS%%%%DOCSDIR%%/%%PORTVERSION%%/Devel/engineering.html
 %%PORTDOCS%%%%DOCSDIR%%/%%PORTVERSION%%/Devel/file.html
@@ -122,11 +123,11 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/class/example.cxx
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/class/example.h
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/class/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/class/test-lowlevel-class.scm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/class/test-tinyclos-class.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/class/runme-lowlevel.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/class/runme-tinyclos.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/constants/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/constants/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/constants/test-constants.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/constants/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/egg/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/egg/README
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/egg/mod1.i
@@ -139,18 +140,18 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/multimap/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/multimap/example.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/multimap/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/multimap/test-multimap.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/multimap/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/overload/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/overload/README
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/overload/example.cxx
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/overload/example.h
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/overload/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/overload/test-overload.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/overload/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/simple/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/simple/README
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/simple/example.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/simple/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/simple/test-simple.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/chicken/simple/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/contract/simple_c/example.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/contract/simple_c/example.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/contract/simple_c/runme1.py
@@ -351,20 +352,22 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/go/variables/example.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/go/variables/index.html
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/go/variables/runme.go
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/Makefile.in
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/README
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/check.list
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/class/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/class/example.cxx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/class/example.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/class/example.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/class/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/constants/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/constants/constants.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/constants/example.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/constants/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/main.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/example.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/matrix.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/matrix.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/matrix.scm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/package.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/vector.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/vector.h
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix/vector.i
@@ -378,14 +381,14 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/multivalue/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/port/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/port/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/port/port.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/port/port.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/port/port.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/port/example.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/port/example.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/port/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/simple/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/simple/README
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/simple/example.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/simple/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/simple/example.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/simple/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/std_vector/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/std_vector/example.h
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/guile/std_vector/example.i
@@ -575,16 +578,16 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/multimap/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/multimap/example.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/multimap/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/multimap/example.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/multimap/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/simple/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/simple/README
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/simple/example.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/simple/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/simple/example.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/simple/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/std_vector/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/std_vector/example.h
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/std_vector/example.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/std_vector/example.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/mzscheme/std_vector/runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/ocaml/argout_ref/Makefile
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/ocaml/argout_ref/example.c
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/ocaml/argout_ref/example.i
@@ -1341,6 +1344,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/arrays_scope.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/autodoc.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/bloody_hell.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/bom_utf8.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/bools.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/callback.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/cast_operator.i
@@ -1356,6 +1360,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/README
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/casts_runme.ss
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/char_constant_runme.ss
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/chicken_ext_test_external.cxx
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/chicken_ext_test_runme.ss
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/class_ignore_runme.ss
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/clientdata_prop_runme_proxy.ss
@@ -1365,7 +1370,6 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/cpp_enum_runme.ss
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/cpp_namespace_runme.ss
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/dynamic_cast_runme.ss
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/ext_test_external.cxx
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/global_vars_runme.ss
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/global_vars_runme_proxy.ss
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/chicken/import_nomodule_runme.ss
@@ -1463,6 +1467,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/csharp/director_nspace_runme.cs
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/csharp/director_primitives_runme.cs
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/csharp/director_protected_runme.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/csharp/director_smartptr_runme.cs
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/csharp/director_string_runme.cs
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/csharp/enum_forward_runme.cs
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/csharp/enum_thorough_runme.cs
@@ -1635,6 +1640,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_namespace_clash.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_nested.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_nspace.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_nspace_director_name_collision.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_overload.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_overload2.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_primitives.i
@@ -1642,6 +1648,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_protected.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_protected_overloaded.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_redefined.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_smartptr.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_stl.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_string.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/director_thread.i
@@ -1653,6 +1660,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/dynamic_cast.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/empty.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/enum_forward.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/enum_macro.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/enum_plus.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/enum_rename.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/enum_scope_template.i
@@ -1743,6 +1751,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/errors/pp_unterm_string.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/errors/pp_variable_args.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/errors/swig_apply_nargs.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/errors/swig_extend.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/errors/swig_identifier.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/errors/swig_insert_bad.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/errors/swig_typemap_copy.i
@@ -1937,6 +1946,8 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/cpp_enum_runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/cpp_namespace_runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/dynamic_cast_runme.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/guile_ext_test_external.cxx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/guile_ext_test_runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/import_nomodule_runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/imports_runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/inherit_missing_runme.scm
@@ -1958,11 +1969,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/typedef_inherit_runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/typename_runme.scm
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile/unions_runme.scm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guilescm/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guilescm/Makefile.in
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guilescm/ext_test_external.cxx
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guilescm/guilescm_ext_test_runme.scm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guilescm_ext_test.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile_ext_test.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/iadd.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/ignore_parameter.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/ignore_template_constructor.i
@@ -2020,12 +2027,14 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/director_nspace_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/director_primitives_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/director_protected_runme.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/director_smartptr_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/director_string_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/director_thread_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/director_unroll_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/director_wombat_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/dynamic_cast_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/enum_forward_runme.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/enum_macro_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/enum_thorough_proper_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/enum_thorough_runme.java
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java/enum_thorough_simple_runme.java
@@ -2127,6 +2136,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java_lib_arrays.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java_lib_arrays_dimensionless.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java_lib_various.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java_nspacewithoutpackage.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java_pgcpp.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java_pragmas.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java_prepost.i
@@ -2139,6 +2149,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/langobj.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/lextype.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_attribute.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_attribute_template.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_boost_intrusive_ptr.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_boost_shared_ptr.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_boost_shared_ptr_bits.i
@@ -2160,6 +2171,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_std_containers_int.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_std_deque.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_std_except.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_std_except_as_class.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_std_functors.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_std_list.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/li_std_map.i
@@ -2473,6 +2485,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/overload_extend.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/overload_extendc.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/overload_method.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/overload_numeric.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/overload_rename.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/overload_return_type.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/overload_simple.i
@@ -2730,6 +2743,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/kwargs_feature_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/langobj_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_attribute_runme.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_attribute_template_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_boost_shared_ptr_bits_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_boost_shared_ptr_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_boost_shared_ptr_template_runme.py
@@ -2743,6 +2757,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_implicit_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_std_carray_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_std_containers_int_runme.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_std_except_as_class_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_std_map_member_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_std_map_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/li_std_pair_extra_runme.py
@@ -2771,6 +2786,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/overload_copy_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/overload_extend_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/overload_extendc_runme.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/overload_numeric_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/overload_rename_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/overload_simple_runme.py
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/python/overload_subtype_runme.py
@@ -2884,6 +2900,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r/r_copy_struct_runme.R
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r/r_double_delete_runme.R
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r/r_legacy_runme.R
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r/r_sexp_runme.R
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r/rename_simple_runme.R
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r/simple_array_runme.R
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r/unions_runme.R
@@ -2892,6 +2909,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r_double_delete.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r_legacy.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r_overload_array.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/r_sexp.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/redefined.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/redefined_not.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/refcount.h
@@ -3169,6 +3187,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_default.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_default2.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_default_arg.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_default_arg_virtual_destructor.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_default_class_parms.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_default_class_parms_typedef.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_default_inherit.i
@@ -3239,13 +3258,14 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_using_directive_and_declaration_forward.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_virtual.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/template_whitespace.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/subdir1/hello.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/subdir1/imports.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/subdir1/subinc1.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/subdir2/hello.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/subdir2/imports.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/subdir2/subinc2.i
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/test.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/subdir1/hello.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/subdir1/imports.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/subdir1/subinc1.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/subdir2/hello.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/subdir2/imports.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/subdir2/subinc2.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/test.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/threads.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/threads_exception.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/throw_exception.i
@@ -3259,6 +3279,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/typedef_scope.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/typedef_sizet.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/typedef_struct.i
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/typemap_array_qualifiers.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/typemap_arrays.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/typemap_delete.i
 %%PORTEXAMPLES%%%%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/typemap_directorout.i
@@ -3429,10 +3450,7 @@ bin/swig2.0
 %%DATADIR%%/%%PORTVERSION%%/go/typemaps.i
 %%DATADIR%%/%%PORTVERSION%%/guile/common.scm
 %%DATADIR%%/%%PORTVERSION%%/guile/cplusplus.i
-%%DATADIR%%/%%PORTVERSION%%/guile/ghinterface.i
 %%DATADIR%%/%%PORTVERSION%%/guile/guile.i
-%%DATADIR%%/%%PORTVERSION%%/guile/guile_gh.swg
-%%DATADIR%%/%%PORTVERSION%%/guile/guile_gh_run.swg
 %%DATADIR%%/%%PORTVERSION%%/guile/guile_scm.swg
 %%DATADIR%%/%%PORTVERSION%%/guile/guile_scm_run.swg
 %%DATADIR%%/%%PORTVERSION%%/guile/guilemain.i
@@ -3710,6 +3728,7 @@ bin/swig2.0
 %%DATADIR%%/%%PORTVERSION%%/python/stl.i
 %%DATADIR%%/%%PORTVERSION%%/python/typemaps.i
 %%DATADIR%%/%%PORTVERSION%%/python/wchar.i
+%%DATADIR%%/%%PORTVERSION%%/r/boost_shared_ptr.i
 %%DATADIR%%/%%PORTVERSION%%/r/cdata.i
 %%DATADIR%%/%%PORTVERSION%%/r/exception.i
 %%DATADIR%%/%%PORTVERSION%%/r/r.swg
@@ -3952,8 +3971,9 @@ bin/swig2.0
 @dirrm %%DATADIR%%
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/xml
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/uffi
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/subdir2
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/subdir1
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/subdir2
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest/subdir1
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir/inctest
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/testdir
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/tcl
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/schemerunme
@@ -3968,7 +3988,6 @@ bin/swig2.0
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/mzscheme
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/lua
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/java
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guilescm
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/guile
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/go
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/test-suite/errors
@@ -4177,6 +4196,7 @@ bin/swig2.0
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/guile/multimap
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/guile/matrix
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/guile/constants
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/guile/class
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/guile
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/go/variables
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/go/template
@@ -4244,7 +4264,6 @@ bin/swig2.0
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/android/simple/res/values
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/android/simple/res/layout
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/android/simple/res
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/android/simple/libs
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/android/simple/jni
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/android/simple
 %%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/%%PORTVERSION%%/android/extend/src/org/swig/extendexample
@@ -4272,4 +4291,3 @@ bin/swig2.0
 %%PORTDOCS%%@dirrm %%DOCSDIR%%/%%PORTVERSION%%/Devel
 %%PORTDOCS%%@dirrm %%DOCSDIR%%/%%PORTVERSION%%
 %%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%@exec mkdir -p %D/%%EXAMPLESDIR%%/%%PORTVERSION%%/android/simple/libs
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 8 Kubilay Kocak freebsd_committer 2014-01-14 09:28:19 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!