Bug 187736 - devel/otrs: need additional perl5 package SSLGlue for web appliance OTRS
Summary: devel/otrs: need additional perl5 package SSLGlue for web appliance OTRS
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-19 14:50 UTC by Ryder Dain
Modified: 2014-03-30 19:10 UTC (History)
0 users

See Also:


Attachments
otrs.txt (4.58 KB, text/plain; charset=US-ASCII)
2014-03-28 11:41 UTC, m.tsatsenko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryder Dain 2014-03-19 14:50:01 UTC
The package for OTRS fails to run when it's set up to use IMAPS, if the Net::SSLGlue package isn't available.

As a workaround, we installed the relevant portion of the package from CPAN, but it would have been more appropriate to install a package like "p5-Net-SSLGlue", which isn't currently available in ports or for the new pkg repo.

Fix: 

Using CPAN, install Net::SSLGlue, or fetch
http://cpansearch.perl.org/src/SULLR/Net-SSLGlue-1.052/lib/Net/SSLGlue/SMTP.pm
and install to /usr/local/lib/perl5/5.16/Net/SSLglue/ directly.
How-To-Repeat: Install an OTRS system and attempt to configure a PostMaster Mail account using IMAPS for email fetching.
Comment 1 Mark Linimon 2014-03-21 05:48:09 UTC
to which port does this PR apply?
Comment 2 Ryder Dain 2014-03-21 08:43:08 UTC
otrs-3.3.5 /// devel/otrs

apologies for leaving this out of the synopsis.

On 21 Mar 2014, at 06:48, Mark Linimon <linimon@lonesome.com> wrote:

> to which port does this PR apply?
Comment 3 Edwin Groothuis freebsd_committer 2014-03-21 20:00:36 UTC
Maintainer of devel/otrs,

Please note that PR ports/187736 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/187736

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 4 Edwin Groothuis freebsd_committer 2014-03-21 20:00:37 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 5 Po-Chuan Hsieh freebsd_committer 2014-03-24 12:39:45 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sunpoet

I'll take it.
Comment 6 m.tsatsenko 2014-03-25 06:09:52 UTC
To submitter: I can not reproduce the problem. I just created an IMAPS
account without any problem and I don't have SSLGlue installed.
Could you please send me entire error message indicating that SSLGlue
is required?

To sunpoet: please do not take any action for now. It seems the
problem needs some investigation.

-- 
Mikhail
Comment 7 Michael Gmelin 2014-03-25 12:47:42 UTC
I've seen this as well, SSLGlue is required for sending email using
SMTPS and strictly speaking only Net::SSLGlue::SMTP is required
(http://search.cpan.org/~sullr/Net-SSLGlue-1.052/lib/Net/SSLGlue/SMTP.pm)

Placing it in /usr/local/lib/perl5/5.16/Net/SSLGlue/SMTP.pm fixes the
issue.

It's included by /usr/local/otrs/Kernel/System/Email/SMTPS.pm as well
as /usr/local/otrs/Kernel/System/Email/SMTPTLS.pm (use
Net::SSLGlue::SMTP).

The error message is the usual:

Can't locate Net/SSLGlue/SMTP.pm in @INC (...)

Grepping through OTRS shows that other Net::SSLGlue::POP3 is also
required for POP3S and POP3 STARTTLS. Also, OTRS checks for
Net::SSLGlue when checking its configuration - so either this should
brought in as well, or the check should be modified to only check for
POP3 and SMTP.

# grep -R SSLGlue /usr/local/otrs/Kernel  
/usr/local/otrs/Kernel/System/Environment.pm:            Net::SSLGlue
/usr/local/otrs/Kernel/System/Email/SMTPTLS.pm:use Net::SSLGlue::SMTP;
/usr/local/otrs/Kernel/System/Email/SMTPS.pm:use Net::SSLGlue::SMTP;
/usr/local/otrs/Kernel/System/MailAccount/POP3TLS.pm:use
 Net::SSLGlue::POP3;
/usr/local/otrs/Kernel/System/MailAccount/POP3S.pm:use
Net::SSLGlue::POP3;

Note that this was not required in OTRS 3.1, back then OTRS used
Net::SMTP::SSL, in 3.3 they switched to using Net::SSLGlue::SMTP, I
assume it's the same for POP3. This also means that users upgrading to
3.3.5 through ports/pkg will get stuck.

As an additional note: OTRS config check also shows that there are a
couple of other modules as missing, not sure what they're required for,
but OTRS says they're *not* optional and I've been told that OTRS
didn't behave well without them:

p5-Algorithm-Diff-1.1902
p5-CSS-Minifier-0.01
p5-Class-Inspector-1.28
p5-JavaScript-Minifier-1.11
p5-Module-Refresh-0.17
p5-SOAP-Lite-0.716
p5-Text-Diff-1.41

Based on the output of otrs.CheckModules.pl:
(Linux::Distribution can be ignored)

Bundled modules:

  o Algorithm::Diff..................Not installed! (required - Please
  install this module - )
  o Apache2::Reload..................ok (v0.12)
  o Apache::DBI......................ok (v1.12)
  o Authen::SASL.....................ok (v2.16)
  o CGI..............................ok (v3.59)
  o CSS::Minifier....................Not installed! (required - Please
  install this module - )
  o Class::Inspector.................Not installed! (required - Please
  install this module - )
  o Crypt::PasswdMD5.................ok (v1.3)
  o Date::Pcalc......................ok (v6.1)
  o Email::Valid.....................ok (v1.192)
  o Encode::Locale...................ok (v1.03)
  o IO::Interactive..................ok (v0.0.6)
  o JSON.............................ok (v2.90)
  o JSON::PP.........................ok (v2.27200)
  o JavaScript::Minifier.............Not installed! (required - Please
  install this module - )
  o LWP..............................ok (v6.05)
  o Linux::Distribution..............Not installed! (required - Please
  install this module - )
  o Locale::Codes....................ok (v3.21)
  o MIME::Tools......................ok (v5.505)
  o Mail::Address....................ok (v2.13)
  o Mail::Internet...................ok (v2.13)
  o Module::Refresh..................Not installed! (required - Please
  install this module - )
  o Mozilla::CA......................ok (v20130114)
  o Net::HTTP........................ok (v6.06)
  o Net::IMAP::Simple................ok (v1.2204)
  o Net::SSLGlue.....................Not installed! (required - Please
  install this module - )
  o Proc::Daemon.....................ok (v0.14)
  o SOAP::Lite.......................Not installed! (required - Please
  install this module - )
  o Sys::Hostname::Long..............ok (v1.4)
  o Text::CSV........................ok (v1.32)
  o Text::Diff.......................Not installed! (required - Please
  install this module - )
  o URI..............................ok (v1.60)
  o YAML.............................ok (v0.87)
  o parent...........................ok (v0.225)

-- 
Michael Gmelin
Comment 8 Po-Chuan Hsieh freebsd_committer 2014-03-25 19:24:21 UTC
FYI, I've added security/p5-Net-SSLGlue to the ports tree.

Regards,
sunpoet
Comment 9 m.tsatsenko 2014-03-28 11:41:31 UTC
Please see the patch attached.
Changes:
- Add missing dependencies (inc SSLGlue)
- Drop unused dependencies
- fix some installation issues
- bump portrevison due to package change

-- 
Mikhail
Comment 10 dfilter service freebsd_committer 2014-03-30 19:01:46 UTC
Author: sunpoet
Date: Sun Mar 30 18:01:41 2014
New Revision: 349660
URL: http://svnweb.freebsd.org/changeset/ports/349660
QAT: https://qat.redports.org/buildarchive/r349660/

Log:
  - Fix *_DEPENDS:
    - Add missing dependencies, including security/p5-Net-SSLGlue
    - Drop unused dependencies
  - Fix installation issues
  - Bump PORTREVISION for dependency and package change
  
  PR:		ports/187736
  Submitted by:	Ryder Dain <ryder.dain@gmail.com>
  Approved by:	Mikhail Tsatsenko <m.tsatsenko@gmail.com> (maintainer)

Modified:
  head/devel/otrs/Makefile
  head/devel/otrs/pkg-plist

Modified: head/devel/otrs/Makefile
==============================================================================
--- head/devel/otrs/Makefile	Sun Mar 30 18:01:37 2014	(r349659)
+++ head/devel/otrs/Makefile	Sun Mar 30 18:01:41 2014	(r349660)
@@ -3,6 +3,7 @@
 
 PORTNAME=	otrs
 PORTVERSION=	3.3.5
+PORTREVISION=	1
 CATEGORIES=	devel
 MASTER_SITES=	http://ftp.otrs.org/pub/otrs/ \
 		ftp://ftp.samurai.com/pub/otrs/ \
@@ -34,7 +35,13 @@ BUILD_DEPENDS=	p5-DBI>=0:${PORTSDIR}/dat
 		p5-Date-Pcalc>=0:${PORTSDIR}/devel/p5-Date-Pcalc \
 		p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
 		p5-XML-FeedPP>=0:${PORTSDIR}/textproc/p5-XML-FeedPP \
-		p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML
+		p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML \
+		p5-JavaScript-Minifier>=0:${PORTSDIR}/textproc/p5-JavaScript-Minifier \
+		p5-CSS-Minifier>=0:${PORTSDIR}/textproc/p5-CSS-Minifier \
+		p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite \
+		p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+		p5-Mozilla-CA>=0:${PORTSDIR}/www/p5-Mozilla-CA
+
 RUN_DEPENDS:=	${BUILD_DEPENDS}
 
 USES=		shebangfix perl5
@@ -61,7 +68,7 @@ GROUPS=		${USERS} www
 SUB_FILES=	pkg-install pkg-message
 PKGMESSAGE=	${WRKDIR}/pkg-message
 
-ROOT_DIRS_LIST=	Kernel bin scripts
+ROOT_DIRS_LIST=	Kernel bin scripts doc
 BIN_DIRS_LIST=	"" cgi-bin fcgi-bin
 PM_DIRS_LIST=	Kernel Kernel/Config Kernel/Config/Files Kernel/Language \
 		Modules Kernel/Output/HTML Kernel/Output/HTML/Lite \
@@ -72,6 +79,7 @@ DOCS_DIRS_LIST=	"" manual/en
 DOCS_FILES_LIST=	C[A-Z]* INSTALL.md RE* UPGRADING.md
 
 SCRIPTS_DIRS_LIST=	"" database/update test tools
+CRON_SCRIPTS=	${OTRSDIR}/var/cron/
 CLEAN_FILES=	scripts/suse* scripts/redhat* \
 		var/httpd/htdocs/js/thirdparty/ckeditor-4.0/_source \
 		var/httpd/htdocs/skins/Agent/*/img/source
@@ -103,18 +111,17 @@ RUN_DEPENDS+=	p5-GD>=0:${PORTSDIR}/graph
 .endif
 
 .if ${PORT_OPTIONS:MSMTP}
-RUN_DEPENDS+=	p5-Net-SMTP-SSL>=0:${PORTSDIR}/mail/p5-Net-SMTP-SSL \
-		p5-Net-SMTP-TLS>=0:${PORTSDIR}/mail/p5-Net-SMTP-TLS \
-		p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
+RUN_DEPENDS+=	p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL \
+		p5-Net-SSLGlue>=0:${PORTSDIR}/security/p5-Net-SSLGlue
 .endif
 
 .if ${PORT_OPTIONS:MPOP3}
-RUN_DEPENDS+=	p5-Mail-POP3Client>=0:${PORTSDIR}/mail/p5-Mail-POP3Client \
-		p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
+RUN_DEPENDS+=	p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+		p5-Net-SSLGlue>=0:${PORTSDIR}/security/p5-Net-SSLGlue
 .endif
 
 .if ${PORT_OPTIONS:MIMAP}
-RUN_DEPENDS+=	p5-Net-IMAP-Simple-SSL>=0:${PORTSDIR}/mail/p5-Net-IMAP-Simple-SSL
+RUN_DEPENDS+=	p5-Mail-IMAPClient>=0:${PORTSDIR}/mail/p5-Mail-IMAPClient
 .endif
 
 .if ${PORT_OPTIONS:MLDAP}
@@ -171,6 +178,7 @@ do-install:
 		${SCRIPTS_DIRS_LIST:S!^!${OTRSDIR}/scripts/!}
 	@${INSTALL_DATA} ${WRKSRC}/.*.dist ${OTRSDIR}/
 	@${INSTALL_DATA} ${WRKSRC}/RELEASE ${OTRSDIR}/
+	@${INSTALL_DATA} ${WRKSRC}/ARCHIVE ${OTRSDIR}/
 .for D in ${BIN_DIRS_LIST}
 	@${INSTALL_SCRIPT} ${WRKSRC}/bin/${D}/*.* ${OTRSDIR}/bin/${D}/
 .endfor
@@ -197,6 +205,7 @@ do-install:
 	@${INSTALL_DATA} ${WRKSRC}/doc/${D}/*.* ${DOCSDIR}/${D}/
 .endfor
 .endif
+	@${FIND} ${CRON_SCRIPTS} -type f -name *.dist | ${SED} -e "p;s/\.dist//" | ${XARGS} -n2 ${MV}
 	@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
 
 post-install:

Modified: head/devel/otrs/pkg-plist
==============================================================================
--- head/devel/otrs/pkg-plist	Sun Mar 30 18:01:37 2014	(r349659)
+++ head/devel/otrs/pkg-plist	Sun Mar 30 18:01:41 2014	(r349660)
@@ -764,6 +764,7 @@ otrs/Kernel/System/Web/UploadCache/FS.pm
 otrs/Kernel/System/WebUserAgent.pm
 otrs/Kernel/System/XML.pm
 otrs/Kernel/System/YAML.pm
+otrs/ARCHIVE
 otrs/RELEASE
 otrs/bin/Cron.sh
 otrs/bin/cgi-bin/app.psgi
@@ -951,18 +952,18 @@ otrs/scripts/tools/md5sum.pl
 otrs/scripts/tools/sync-ldap2db.pl
 otrs/scripts/tools/xml2html.pl
 otrs/scripts/webform.pl
-otrs/var/cron/aaa_base.dist
-otrs/var/cron/cache.dist
-otrs/var/cron/fetchmail.dist
-otrs/var/cron/generate_dashboard_stats.dist
-otrs/var/cron/generic_agent-database.dist
-otrs/var/cron/generic_agent.dist
-otrs/var/cron/pending_jobs.dist
-otrs/var/cron/postmaster.dist
-otrs/var/cron/postmaster_mailbox.dist
-otrs/var/cron/rebuild_ticket_index.dist
-otrs/var/cron/session.dist
-otrs/var/cron/unlock.dist
+otrs/var/cron/aaa_base
+otrs/var/cron/cache
+otrs/var/cron/fetchmail
+otrs/var/cron/generate_dashboard_stats
+otrs/var/cron/generic_agent-database
+otrs/var/cron/generic_agent
+otrs/var/cron/pending_jobs
+otrs/var/cron/postmaster
+otrs/var/cron/postmaster_mailbox
+otrs/var/cron/rebuild_ticket_index
+otrs/var/cron/session
+otrs/var/cron/unlock
 otrs/var/fonts/DejaVuSans-Bold.ttf
 otrs/var/fonts/DejaVuSans-BoldOblique.ttf
 otrs/var/fonts/DejaVuSans-Oblique.ttf
@@ -2472,6 +2473,7 @@ otrs/var/stats/Stats.TicketOverview.en.x
 @dirrm otrs/bin/fcgi-bin
 @dirrm otrs/bin/cgi-bin
 @dirrm otrs/bin
+@dirrm otrs/doc
 @dirrm otrs/Kernel/System/Web/UploadCache
 @dirrm otrs/Kernel/System/Web
 @dirrm otrs/Kernel/System/VirtualFS
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 11 Po-Chuan Hsieh freebsd_committer 2014-03-30 19:02:42 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!