Bug 187810 - cc(1): compiler does not work on FreeBSD 10
Summary: cc(1): compiler does not work on FreeBSD 10
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.0-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-21 09:40 UTC by jonas.bulow
Modified: 2015-05-08 19:45 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonas.bulow 2014-03-21 09:40:00 UTC
Compiler/linker depends on missing file:

 % cat fil.c
#include <stdio.h>

int
main(int argc, char *argv[])
{
        printf("hello world\n");
        return 0;
}
jonasbu@jonasbu-netlab:~/t % cc -o plopp fil.c
/usr/bin/ld: cannot find /usr/lib/libc_nonshared.a
cc: error: linker command failed with exit code 1 (use -v to see invocation)

How-To-Repeat: See above.
Comment 1 Jilles Tjoelker freebsd_committer 2015-05-05 21:49:14 UTC
How did you install FreeBSD? It seems extremely unlikely that a normal installation of a release would be broken like this.
Comment 2 jonas.bulow 2015-05-08 05:34:58 UTC
The problem was likely caused by installing clang from ports. This defect can be closed now.
Comment 3 Jilles Tjoelker freebsd_committer 2015-05-08 19:45:41 UTC
Thanks for the information.