Bug 188298 - whois(1) says "% Error: 55000000013 Invalid charset for response"
Summary: whois(1) says "% Error: 55000000013 Invalid charset for response"
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.0-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-05 20:30 UTC by gerald
Modified: 2018-05-21 12:50 UTC (History)
4 users (show)

See Also:


Attachments
whois-iconv.patch (3.44 KB, patch)
2014-04-20 23:36 UTC, diego
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description gerald 2014-04-05 20:30:00 UTC
	FreeBSD whois is not able to handle umlauts in whois records;
	the version used by SUSE and other Linux distributions works just fine.

How-To-Repeat: 	whois goodbye-dots.de
	% Error: 55000000013 Invalid charset for response
Comment 1 diego 2014-04-20 23:36:44 UTC
Currently whois(1) hardcodes US-ASCII charset for German domains when sending the request. That triggers the error on the remote side, and not on whois(1) itself.

Attached to this message there's a patch that uses libiconv for handling UTF-8 data and remove US-ASCII from the request. It seems to be working good on all my tests, be it a German domain or not. The patch can be applied to FreeBSD-CURRENT.

--
Diego Giagio
diego@giagio.com
diego@FreeBSD.org

 		 	   		  =
Comment 2 martin.dieringer 2015-08-22 08:34:22 UTC
Still not working for .de
Comment 3 Tobias Kortkamp freebsd_committer 2015-11-04 03:45:50 UTC
I get the same error on 10.2-RELEASE, but it works for me on 11.0-CURRENT r289044. base r287030 seems to have fixed this.
Comment 4 Christian Kujau 2015-11-07 20:49:44 UTC
FWIW, MacOS seems to have fixed this as well, and they switched to using UTF-8 recently:

----------------------------------------------
$ strings /usr/bin/whois | grep -A1 de.w
de.whois-servers.net
-T dn -C UTF-8 %s

$ whois denic.de | grep ß
Address: Kaiserstraße 75-77
Address: Kaiserstraße 75-77
----------------------------------------------

Until this is fixed, the following workaround could be used for .de domains:

$ whois -h whois.denic.de -- "-T dn,ace denic.de"
Comment 5 Yuri Pankov 2018-05-20 15:46:48 UTC
Looks like this is already fixed in base r294613.
Comment 6 Oleksandr Tymoshenko freebsd_committer freebsd_triage 2018-05-21 06:21:24 UTC
Tested by running "whois denic.de | grep Kaiser" and "whois goodbye-dots.de" on 11.1-RELEASE-p4 and 12.0-CURRENT r333606, worked in both cases. Closing as FIXED
Comment 7 Gerald Pfeifer freebsd_committer 2018-05-21 12:50:25 UTC
(In reply to Oleksandr Tymoshenko from comment #6)
> Tested by running "whois denic.de | grep Kaiser" and "whois goodbye-dots.de"
> on 11.1-RELEASE-p4 and 12.0-CURRENT r333606, worked in both cases.

Yes, but note that the original issue (whois goodbye-dots.de) does not
replicate any longer, even on an affected system, since the data has been
changed. ;-)

I can confirm, comparing ref10-i386 with ref11-*, for example, that indeed
this has been fixed for "whois denic.de".