Bug 188684 - [MAINTAINER] www/MT,russian/MT: update to 5.2.10,1
[MAINTAINER] www/MT,russian/MT: update to 5.2.10,1
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: John Marino
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-16 09:40 UTC by takefu
Modified: 2014-08-03 19:31 UTC (History)
2 users (show)

See Also:


Attachments
MT-5.2.10.patch (1.72 KB, patch)
2014-04-16 09:40 UTC, takefu
no flags Details | Diff
file.diff (191 bytes, patch)
2014-04-16 09:40 UTC, takefu
no flags Details | Diff
file.diff (10.45 KB, patch)
2014-04-16 09:40 UTC, takefu
no flags Details | Diff
MT.patch (1.74 KB, patch)
2014-07-28 04:11 UTC, takefu
no flags Details | Diff
ru-MT.patch (11.01 KB, patch)
2014-07-28 04:12 UTC, takefu
no flags Details | Diff
MT.patch (7.08 KB, patch)
2014-07-30 07:50 UTC, takefu
no flags Details | Diff
ru-MT.patch (16.00 KB, patch)
2014-07-30 07:50 UTC, takefu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description takefu 2014-04-16 09:40:00 UTC
www/MT,russian/MT
- Update to 5.2.10
- add license

Generated with FreeBSD Port Tools 1.01 (mode: update, diff: ports)

Fix: CATEGORIES=	russian www
 MASTER_SITES=	http://movable-type.ru/downloads/
-DISTNAME=	MTOS-${PORTVERSION}-${PKGNAMEPREFIX:S,-,,}
+DISTNAME=	MTOS-5.2.9-${PKGNAMEPREFIX:S,-,,}

 COMMENT=	Russian localization of the MovableType publishing system

+PATCHDIR=	${.CURDIR}/files
 MASTERDIR=	${.CURDIR}/../../www/MT
 MT_LANG=	${PKGNAMEPREFIX:S,-,,U}
 CONFLICTS=	MT-[2-5].* de-MT-[2-5].* fr-MT-[2-5].* ja-MT-[2-5].*
Comment 1 John Marino freebsd_committer 2014-07-27 09:18:22 UTC
I think this submission has issues.

1) The patch of 191 bytes is empty.
2) The patch of 10.45 kb creates files at russian/MT/files but:

> cd /usr/ports/russian/MT
> make -V FILESDIR
> /usr/ports/russian/MT/../../www/MT/files

So the patches created there would never be used.


Can you review the submission?  If you find a mistake, can you "obsolete" all the patches and replace it with one patch that changes both www/MT and russian/MT together?  

Thanks,
John
Comment 2 John Marino freebsd_committer 2014-07-27 09:20:01 UTC
oh, I think I see what happened.  Part of the russian/MT/Makefile patch got set to the comment section.

What sent that, the send-PR tool?

Maybe you shouldn't use that tool anymore and stick with the web interface.  I call you in this case, that tool did you no favors.
Comment 3 takefu 2014-07-28 04:11:28 UTC
Created attachment 145058 [details]
MT.patch
Comment 4 takefu 2014-07-28 04:12:07 UTC
Created attachment 145059 [details]
ru-MT.patch
Comment 5 John Marino freebsd_committer 2014-07-28 15:45:24 UTC
I see this is an old PR so maybe the send-pr tool wasn't the culprit, but rather a bad conversion from GNATS to bugzilla.
Comment 6 John Marino freebsd_committer 2014-07-28 16:20:09 UTC
I am getting an error in poudriere but it's likely a false error:

===========================================================================
====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: @unexec rmdir "/var/db/mysql" >/dev/null 2>&1 || :
===> Checking for directories owned by MTREEs
===> Checking for directories handled by dependencies
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1


I'm seeing a similar error in hal, so it might be a bug in check-plist
Comment 7 John Marino freebsd_committer 2014-07-28 18:47:12 UTC
It's not a bug, this is a real problem.

The cause of the problem is that DB_DIR is configurable.

If DB_DIR is 8 folder levels deep, the pkg-plist will only try to remove the 8th level.  The remaining 7 levels will be left over.

I think the only way to support variable DB_DIR is with pkg_install and pkg_deinstall scripts that try to remove everything that gets created.  It's not a simple fix for me.

Can you take this back and submit a version that passes in poudriere?
Comment 8 takefu 2014-07-30 07:50:01 UTC
Created attachment 145144 [details]
MT.patch
Comment 9 takefu 2014-07-30 07:50:35 UTC
Created attachment 145145 [details]
ru-MT.patch
Comment 10 John Marino freebsd_committer 2014-07-30 07:56:06 UTC
let's hope the third time is the charm!
Comment 11 commit-hook freebsd_committer 2014-08-03 19:29:32 UTC
A commit references this bug:

Author: marino
Date: Sun Aug  3 19:29:19 UTC 2014
New revision: 363930
URL: http://svnweb.freebsd.org/changeset/ports/363930

Log:
  www/MT, russian/MT: Upgrade version 5.2.9 => 5.2.10

  PR:		188684
  Submitted by:	maintainer: takefu (airport.fm)

Changes:
  head/russian/MT/Makefile
  head/russian/MT/files/
  head/russian/MT/files/patch-default_templates__comment_response.mtml
  head/russian/MT/files/patch-lib__MT.pm
  head/russian/MT/files/patch-mt-check.cgi
  head/russian/MT/files/patch-mt-static__css__main.css
  head/russian/MT/files/patch-mt-static__css__simple.css
  head/russian/MT/files/patch-mt-static__js__editor.js
  head/russian/MT/files/patch-mt-static__js__mt_core_compact.js
  head/russian/MT/files/patch-php__mt.php
  head/russian/MT/files/patch-themes__classic_blog__templates__comment_response.mtml
  head/russian/MT/files/patch-themes__classic_blog__theme.yaml
  head/russian/MT/files/patch-themes__classic_website__templates__comment_response.mtml
  head/russian/MT/files/patch-themes__classic_website__theme.yaml
  head/russian/MT/files/patch-themes__pico__templates__comment_response.mtml
  head/russian/MT/files/patch-themes__pico__theme.yaml
  head/russian/MT/files/patch-themes__rainier__templates__comment_response.mtml
  head/russian/MT/files/patch-themes__rainier__theme.yaml
  head/www/MT/Makefile
  head/www/MT/distinfo
  head/www/MT/files/MT.conf.in
  head/www/MT/files/pkg-install.in
  head/www/MT/pkg-plist
Comment 12 John Marino freebsd_committer 2014-08-03 19:31:29 UTC
Thanks!