Bug 188895 - OPTIONS_UNSET X11 doesn't seem to work
Summary: OPTIONS_UNSET X11 doesn't seem to work
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-22 18:40 UTC by Vick Khera
Modified: 2014-10-05 22:08 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vick Khera 2014-04-22 18:40:00 UTC
	

I was running portupgrade today, and one of the updating ports was ImageMagick-nox11.

I saw warnings from ports that I was setting WITHOUT_X11=YES, and should instead
do OPTIONS_UNSET=X11.  I dutifully updated the make.conf file:

 OPTIONS_UNSET=GUI X11

and removed WITHOUT_X11 as well.

I restarted portmaster to have it pick up those new settings and it tried to
install ghostscript9 instead of using the installed ghostscript9-nox11. It
also tried to pull in a fair number of additional libraries that come with X11
support (possibly for some other ports I have).

Fix: 

keep using WITHOUT_X11 setting.
How-To-Repeat: 	

as above
Comment 1 John Marino freebsd_committer 2014-07-22 19:39:48 UTC
assigning to portmgr for the lack of a better option
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2014-07-22 23:12:37 UTC
graphics/ImageMagick uses the deprecated WITHOUT_X11 option rather than ${PORT_OPTIONS:MX11} and needs to be converted.

CC'ing maintainer (kwm) for re-assignment and appropriate summary edit
Comment 3 commit-hook freebsd_committer 2014-07-23 12:11:01 UTC
A commit references this bug:

Author: kwm
Date: Wed Jul 23 12:10:15 UTC 2014
New revision: 362664
URL: http://svnweb.freebsd.org/changeset/ports/362664

Log:
  Convert from WITHOUT_X11 to Options X11.

  PR:		188895
  Submitted by:	Vick Khera <vivek@khera.org>

Changes:
  head/graphics/ImageMagick/Makefile
  head/graphics/ImageMagick-nox11/Makefile
Comment 4 Markus Mann 2014-07-23 19:47:54 UTC
Today i built ImageMagick-nox11 (Makefile revision 362664) and it still doesn't resprect OPTIONS_UNSET=GUI X11

'make all-depends-list' lists x11/libXext (and deps) as dependency, regardless which of the options are set/unset. Unfortunately i cannot provide a patch :-(
Comment 5 Markus Mann 2014-07-28 10:33:03 UTC
For me this is fixed now. I think the Portrevision should be raised, to be sure everyone gets the fix.
Comment 6 Vick Khera 2014-07-28 15:50:33 UTC
works for me too.