Bug 190569 - science/openbabel pthread.h:294:42: error: typedef redefinition with different types ('struct pthread_rwlock_st *' vs 'struct pthread_rwlock *'
Summary: science/openbabel pthread.h:294:42: error: typedef redefinition with differen...
Status: Closed DUPLICATE of bug 191744
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Max Brazhnikov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-03 13:16 UTC by mikhail.rokhin
Modified: 2014-07-11 18:24 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.rokhin 2014-06-03 13:16:13 UTC
In file included from /usr/ports/science/openbabel/work/openbabel-2.3.2/include/openbabel/math/vector3.h:24:
In file included from /usr/include/c++/v1/ostream:131:
In file included from /usr/include/c++/v1/ios:216:
In file included from /usr/include/c++/v1/__locale:18:
In file included from /usr/include/c++/v1/mutex:176:
In file included from /usr/include/c++/v1/__mutex_base:17:
/usr/local/include/python2.7/pthread.h:294:42: error: typedef redefinition with different types ('struct pthread_rwlock_st *' vs 'struct pthread_rwlock *')
typedef struct  pthread_rwlock_st       *pthread_rwlock_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:75:33: note: previous definition is here
typedef struct  pthread_rwlock          *pthread_rwlock_t;
                                         ^
Comment 1 Jung-uk Kim freebsd_committer 2014-07-11 18:24:08 UTC

*** This bug has been marked as a duplicate of bug 191744 ***