Bug 190712 - [patch] sysutils/devcpu-data: Update to latest microcodes
[patch] sysutils/devcpu-data: Update to latest microcodes
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Many People
Assigned To: William Grzybowski
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-06 13:12 UTC by Lawrence Chen
Modified: 2014-06-15 21:30 UTC (History)
3 users (show)

See Also:


Attachments
patch (4.23 KB, patch)
2014-06-06 13:12 UTC, Lawrence Chen
no flags Details | Diff
Added PORTVERSION bump in addition to submitted patch (4.64 KB, patch)
2014-06-15 19:01 UTC, John Clark
clarkjc: maintainer‑approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lawrence Chen 2014-06-06 13:12:02 UTC
Created attachment 143454 [details]
patch

I've been working on my own update to this port for sometime, where
	the stumbling block has been trying to locate a tool to decode
	AMD microcode files.

	So, I'm happy to see that this port got updated and includes a tool
	that handles both Intel and AMD microcode files.

	However, I was disappointed that the microcode files don't appear to
	be any newer than before.  Namely I had been trying to update the port
	to microcode-20130906.  I actually don't currently have any amd
	processors, but wanted to incorporate the latest (amd-ucode-latest.tar.bz2)
	for completeness.  On Debian, the files are the same as source for
	amd64-microcode-2.20131007.1+really20130710.1, and the files have a
	datestamp of 20130907.  While all the files on amd64.org have a date
	stamp of 20130927 and the files are dated 20130925.

	The amd-ucode-2012-09-10.tar file extracts to reveal that its a
	duplicate of amd-ucode-2012-01-17.

	In checking Intel site, found that latest microcode file is 20140430.

	Wonder what the newer revision for my CPU brings?

Fix:
Update port to use 'microcode-20140430.tgz' and
	'amd-ucode-latest.tar.bz2'.
Comment 1 Mark Linimon freebsd_committer 2014-06-13 03:15:22 UTC
Notify maintainer.
Comment 2 John Clark 2014-06-15 19:01:30 UTC
Created attachment 143815 [details]
Added PORTVERSION bump in addition to submitted patch
Comment 3 John Clark 2014-06-15 19:02:39 UTC
Tested and approved with minor changes.  Please commit.

Thank you, Lawrence Chen!
Comment 4 commit-hook freebsd_committer 2014-06-15 21:30:17 UTC
A commit references this bug:

Author: wg
Date: Sun Jun 15 21:29:39 UTC 2014
New revision: 357929
URL: http://svnweb.freebsd.org/changeset/ports/357929

Log:
  sysutils/devcpu-data: update to 1.1

  PR:		190712
  Submitted by:	Lawrence Chen
  Approved by:	maintainer

Changes:
  head/sysutils/devcpu-data/Makefile
  head/sysutils/devcpu-data/distinfo
  head/sysutils/devcpu-data/files/Makefile
  head/sysutils/devcpu-data/pkg-plist