Bug 191715 - [ staging ] net-mgmt/nagvis
Summary: [ staging ] net-mgmt/nagvis
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-07 17:54 UTC by Dan Lukes
Modified: 2014-07-27 13:52 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Lukes 2014-07-07 17:54:15 UTC
net-mgmt/nagvis require staging or will be removed

Fix:
Patch is attached. 

Note the check-plist complain abount missing entries in pkg-plist:

@dirrmtry %%WWWDIR%%/etc/automaps
@dirrmtry %%WWWDIR%%/share/var
@dirrmtry %%WWWDIR%%/var/tmpl/cache
@dirrmtry %%WWWDIR%%/var/tmpl/compile
@dirrmtry %%WWWDIR%%/var/tmpl
@dirrmtry %%WWWDIR%%/var

The directories in question are not created during package installation, but 
may (or may not) be created during program run.  They should be deleted 
(if empty) on uninstall ...

--- net-mgmt/nagvis/Makefile.orig	2014-07-07 19:41:08.000000000 +0200
+++ net-mgmt/nagvis/Makefile	2014-07-07 19:45:03.000000000 +0200
@@ -24,7 +24,6 @@
 USE_PHP=	gd gettext mbstring session json pdo pdo_sqlite
 WANT_PHP_WEB=	yes
 
-NO_STAGE=	yes
 .include <bsd.port.options.mk>
 
 WWW_OWNER?=	${WWWOWN}
@@ -36,6 +35,8 @@
 		DIRMODE=${DIRMODE} FILEMODE=${FILEMODE}
 SUB_FILES+=	pkg-install pkg-deinstall
 
+PLIST_SUB+=	WWWDIR="${WWWDIR}"
+
 .if ${PORT_OPTIONS:MNDO2DB}
 USE_PHP+=	mysql
 RUN_DEPENDS+=	ndo2db-3x:${PORTSDIR}/net-mgmt/ndoutils
@@ -60,7 +61,7 @@
 		${WRKSRC}/etc/nagvis.ini.php-sample
 
 do-install:
-	@( cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${WWWDIR}/ )
+	@( cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WWWDIR}/ )
 
 post-install:
 	@${SH} ${PKGINSTALL} ${DISTNAME} POST-INSTALL
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-07-08 01:35:00 UTC
Notify maintainer.
Comment 2 John Marino freebsd_committer 2014-07-26 07:35:24 UTC
maintainer approval not required for staging.

Dan, it's very helpful to resubmit patch as an attachment.
Comment 3 John Marino freebsd_committer 2014-07-27 13:41:55 UTC
(In reply to Dan Lukes from comment #0)
> net-mgmt/nagvis require staging or will be removed
> 
> Fix:
> Patch is attached. 
> 
> Note the check-plist complain abount missing entries in pkg-plist:
> 
> @dirrmtry %%WWWDIR%%/etc/automaps
> @dirrmtry %%WWWDIR%%/share/var
> @dirrmtry %%WWWDIR%%/var/tmpl/cache
> @dirrmtry %%WWWDIR%%/var/tmpl/compile
> @dirrmtry %%WWWDIR%%/var/tmpl
> @dirrmtry %%WWWDIR%%/var

this is caused by a quirk in how stage works.
Creating empty directories in stage makes these errors go away.
Comment 4 commit-hook freebsd_committer 2014-07-27 13:52:01 UTC
A commit references this bug:

Author: marino
Date: Sun Jul 27 13:51:51 UTC 2014
New revision: 363066
URL: http://svnweb.freebsd.org/changeset/ports/363066

Log:
  stage net-mgmt/nagvis

  PR:		191715
  Submitted by:	Dan Lukes
  Tweaks by:	marino

Changes:
  head/net-mgmt/nagvis/Makefile
Comment 5 John Marino freebsd_committer 2014-07-27 13:52:46 UTC
thanks!