Bug 191767 - arm: graphics/dri install failure
Summary: arm: graphics/dri install failure
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sean Bruno
URL:
Keywords:
: 176703 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-09 13:29 UTC by Anton Shterenlikht
Modified: 2015-03-11 20:52 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Shterenlikht 2014-07-09 13:29:44 UTC
===>   Registering installation for dri-9.1.7_4,2 as automatic
pkg-static: lstat(/usr/ports/graphics/dri/work/stage/usr/local/lib/libdricore9.1.7.la): No such file or directory
pkg-static: lstat(/usr/ports/graphics/dri/work/stage/usr/local/lib/libdricore9.1.7.so): No such file or directory
pkg-static: lstat(/usr/ports/graphics/dri/work/stage/usr/local/lib/libdricore9.1.7.so.1): No such file or directory
pkg-static: lstat(/usr/ports/graphics/dri/work/stage/usr/local/lib/libdricore9.1.7.so.1.0.0): No such file or directory
pkg-static: lstat(/usr/ports/graphics/dri/work/stage/usr/local/lib/dri/): No such file or directory
*** Error code 74

# uname -a
FreeBSD raspberry-pi 10.0-STABLE FreeBSD 10.0-STABLE #0 r268038: Tue Jul  1 04:29:43 UTC 2014     root@grind.freebsd.org:/usr/obj/arm.armv6/usr/src/sys/RPI-B  arm

# svn info /usr/ports/graphics/dri
Path: /usr/ports/graphics/dri
Working Copy Root Path: /usr/ports
URL: https://svn0.eu.freebsd.org/ports/head/graphics/dri
Relative URL: ^/head/graphics/dri
Repository Root: https://svn0.eu.freebsd.org/ports
Repository UUID: 35697150-7ecd-e111-bb59-0022644237b5
Revision: 361360
Node Kind: directory
Schedule: normal
Last Changed Author: kwm
Last Changed Rev: 355979
Last Changed Date: 2014-05-31 14:15:47 +0000 (Sat, 31 May 2014)

Probably should be tacked together with:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=183304
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=176703
Comment 1 Koop Mast freebsd_committer 2014-07-11 20:44:06 UTC
Can you attach dri config.log? thanks.
Comment 2 Anton Shterenlikht 2014-07-12 14:32:41 UTC
http://eis.bris.ac.uk/~mexas/log/config.log

Thanks
Comment 3 Mikael Urankar freebsd_committer 2014-07-12 15:14:38 UTC
You probably need WITH_NEW_XORG=yes
Comment 4 carbaecker 2014-08-31 22:47:48 UTC
Same problem here...

Caused by missing driver-definition for ARCH=armv6

Use same definition as already present for sparc64 and it should work.
Comment 5 Sean Bruno freebsd_committer 2014-08-31 23:15:14 UTC
Working on a patch for this under a phabricator review:

https://reviews.freebsd.org/D704
Comment 6 commit-hook freebsd_committer 2014-09-02 22:54:37 UTC
A commit references this bug:

Author: sbruno
Date: Tue Sep  2 22:54:11 UTC 2014
New revision: 367121
URL: http://svnweb.freebsd.org/changeset/ports/367121

Log:
  Enable SWRAST for armv6 architectures to allow building of dricore libs

  PR:		191767
  Reviewed by:	kwm

Changes:
  head/graphics/dri/Makefile
Comment 7 Jean-Sébastien Pédron freebsd_committer 2015-03-11 20:52:08 UTC
*** Bug 176703 has been marked as a duplicate of this bug. ***