Bug 191829 - [stage] textproc/groonga: Update to version 4.0.4
Summary: [stage] textproc/groonga: Update to version 4.0.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-11 18:49 UTC by tkato432
Modified: 2014-08-01 13:40 UTC (History)
0 users

See Also:


Attachments
textproc_groonga.diff (65.07 KB, patch)
2014-07-11 18:49 UTC, tkato432
no flags Details | Diff
textproc_groonga.diff (65.08 KB, patch)
2014-07-25 18:32 UTC, tkato432
no flags Details | Diff
textproc_groonga.diff (65.24 KB, patch)
2014-08-01 12:30 UTC, tkato432
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description tkato432 2014-07-11 18:49:50 UTC
Created attachment 144600 [details]
textproc_groonga.diff
Comment 1 John Marino freebsd_committer 2014-07-12 15:07:13 UTC
provides staging.
Miwi wants ports fury PRs automatically
Comment 2 tkato432 2014-07-25 18:32:22 UTC
Created attachment 144978 [details]
textproc_groonga.diff
Comment 3 John Marino freebsd_committer 2014-07-29 08:39:42 UTC
Return to pool
Comment 4 John Marino freebsd_committer 2014-07-31 15:37:34 UTC
I accidentally built this on i386 jail on amd64 (FreeBSD 10) and it failed.  I have not tried redports yet.

Have you tested this on i386?

Another issue:
It spews out a ton of warnings at least on FreeBSD10.  I've been trying to figure out how to turn off.  The warns seem to repeat over and over giving the appearance   the compiler is stuck in a look but then it finally moves on.

If you have any ideas (e.g. disable -Wall) i would be interested.
Comment 5 John Marino freebsd_committer 2014-07-31 17:17:22 UTC
I can reproduce this on redports: https://redports.org/buildarchive/20140731164931-48565/

6x pass, 2x fail
Fails on 10/i386 and 11/i386

The numerous warnings seem to a clang thing.  There is some code in configure that checks specifically for gcc and clang but it wouldn't work for ports.
Comment 6 John Marino freebsd_committer 2014-07-31 17:18:46 UTC
I think it's also curious that the build takes far longer on F10 and F11 than F8 and F9 (2 to 3 times longer)
Comment 7 tkato432 2014-08-01 12:30:24 UTC
Created attachment 145211 [details]
textproc_groonga.diff

I usually verify ports on 8.4/i386 and HEAD/amd64 only since common
troubles may happen on either of these combinations. An error only seen
on i386 with clang would be quite exceptional.

As far as I can see, disabling optimization is the only condition to
finish building this port flawlessly on 10.0/i386 with stock compiler.
Since expr.c consumes enormous amount of memory when compiling with
optimization, perhaps it reveals some shortcomings of clang on 32-bit
platforms if available free memory is insufficient. gcc appears to be
somewhat better at this point.
Comment 8 John Marino freebsd_committer 2014-08-01 12:39:20 UTC
okay, so you're recommending gcc=any for i386 in any cases.  Sounds reasonable to me.
Comment 9 commit-hook freebsd_committer 2014-08-01 13:38:37 UTC
A commit references this bug:

Author: marino
Date: Fri Aug  1 13:38:31 UTC 2014
New revision: 363708
URL: http://svnweb.freebsd.org/changeset/ports/363708

Log:
  textproc/groonga: Upgrade version 3.0.0 => 4.0.4 and stage

  Note that gcc is required for i386 - clang/i386 will coredump on
  FreeBSD 10 and 11.

  PR:		191829
  Submitted by:	Ports Fury

Changes:
  head/textproc/groonga/Makefile
  head/textproc/groonga/distinfo
  head/textproc/groonga/files/
  head/textproc/groonga/pkg-install
  head/textproc/groonga/pkg-plist
Comment 10 John Marino freebsd_committer 2014-08-01 13:40:21 UTC
done!