Bug 192009 - databases/memcached fails to build
Summary: databases/memcached fails to build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-21 13:58 UTC by Jaap Akkerhuis
Modified: 2014-07-24 14:28 UTC (History)
2 users (show)

See Also:


Attachments
proposed patch (1.29 KB, patch)
2014-07-21 13:58 UTC, Jaap Akkerhuis
no flags Details | Diff
typescript containing build log (5.61 KB, text/plain)
2014-07-21 21:21 UTC, Jaap Akkerhuis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaap Akkerhuis 2014-07-21 13:58:30 UTC
Created attachment 144846 [details]
proposed patch

The buildprocess complains about:

Making all in doc
make[4]: make[4]: don't know how to make protocol-binary.txt. Stop

It seems to need "USES= gmake"

While at it, I also made portlint (nearly) happy, see attached diff
Comment 1 Steve Wills freebsd_committer 2014-07-21 16:35:08 UTC
I'm unable to reproduce any issue with either option enabled. Can you perhaps show the log file for the build where you are having issues?
Comment 2 Jaap Akkerhuis 2014-07-21 21:21:07 UTC
Created attachment 144862 [details]
typescript containing build log

See my comment mentioning this attachment
Comment 3 Jaap Akkerhuis 2014-07-21 21:24:14 UTC
(In reply to Steve Wills from comment #1)
> I'm unable to reproduce any issue with either option enabled. Can you
> perhaps show the log file for the build where you are having issues?

See the attachment "typescript"

I also tried to build the otiginal under redports with disastrous results, see as example: https://redports.org/~jaap/20140721194500-62439-226258/.txz.log
Comment 4 Steve Wills freebsd_committer 2014-07-21 21:33:38 UTC
Ok, from the log, this seems to be happening because textproc/xml2rfc and textproc/libxslt are installed, perhaps this is changing which docs are built or how they are built. I will look into it. Thanks!
Comment 5 commit-hook freebsd_committer 2014-07-22 19:31:10 UTC
A commit references this bug:

Author: swills
Date: Tue Jul 22 19:30:32 UTC 2014
New revision: 362570
URL: http://svnweb.freebsd.org/changeset/ports/362570

Log:
  databases/memcached: fix build when xml2rfc is installed

  The docs for require xml2rfc and aren't built in the case where it's not
  installed. However when they are installed, they fail due to make issues. This
  patches the doc Makefile to avoid the gmake specific extensions as well as
  ensuring that network access is not needed to build the docs. It also ensure
  that xml2rfc is always there in the case where the DOCS option is enabled so
  that the docs are always built the same.

  While here, I decided to include some of the cleanup from the PR including the
  LICENSE change ane enabling the SASL and DOCS options by default since they
  don't add much in the way of dependencies. Also switched to static plist.

  PR:		192009
  Reported by:	jaap@NLnetLabs.nl

Changes:
  head/databases/memcached/Makefile
  head/databases/memcached/files/patch-doc-local
  head/databases/memcached/files/patch-doc__Makefile.in
  head/databases/memcached/pkg-plist
Comment 6 Steve Wills freebsd_committer 2014-07-22 19:45:33 UTC
Took most of the changes from this patch along with a few others to clean some things up, see commit message. I think portlint lead you astray on the distdir thing, the heuristics there aren't perfect and I think the distdir thing was incorrect. Please let me know if you have any further issues, but I believe this should resolve it. Thanks!
Comment 7 Jaap Akkerhuis 2014-07-22 20:51:29 UTC
(In reply to Steve Wills from comment #6)
> Took most of the changes from this patch along with a few others to clean
> some things up, see commit message. I think portlint lead you astray on the
> distdir thing, the heuristics there aren't perfect and I think the distdir
> thing was incorrect. Please let me know if you have any further issues, but
> I believe this should resolve it. Thanks!

This indeed fixes building the port. However, if you want to build this in a tinderbox (I have my own,but resorts.org also shows it) it wants to build all ports in /usr/ports/lang and dies after a while. I do think this is trigger by the TEST_DEPENDS line, expecially since portlints says:

    WARN: Makefile: no port directory /usr/ports/lang/${PERL_PORT} found, even though it is listed in TEST_DEPENDS.

Anyway, for just using it with as a port it works fine. Thanks!

        jaap
Comment 8 Steve Wills freebsd_committer 2014-07-23 20:00:00 UTC
(In reply to jaap from comment #7)
> (In reply to Steve Wills from comment #6)
> > Took most of the changes from this patch along with a few others to clean
> > some things up, see commit message. I think portlint lead you astray on the
> > distdir thing, the heuristics there aren't perfect and I think the distdir
> > thing was incorrect. Please let me know if you have any further issues, but
> > I believe this should resolve it. Thanks!
> 
> This indeed fixes building the port. However, if you want to build this in a
> tinderbox (I have my own,but resorts.org also shows it) it wants to build
> all ports in /usr/ports/lang and dies after a while. I do think this is
> trigger by the TEST_DEPENDS line, expecially since portlints says:
> 
>     WARN: Makefile: no port directory /usr/ports/lang/${PERL_PORT} found,
> even though it is listed in TEST_DEPENDS.
> 
> Anyway, for just using it with as a port it works fine. Thanks!
> 
>         jaap

Went ahead and removed the TEST_DEPENDS for now, we can add it back later.
Comment 9 Jaap Akkerhuis 2014-07-24 14:28:38 UTC
(In reply to Steve Wills from comment #8)
> (In reply to jaap from comment #7)
> > (In reply to Steve Wills from comment #6)
> > > Took most of the changes from this patch along with a few others to clean
> > > some things up, see commit message. I think portlint lead you astray on the
> > > distdir thing, the heuristics there aren't perfect and I think the distdir
> > > thing was incorrect. Please let me know if you have any further issues, but
> > > I believe this should resolve it. Thanks!
> > 
> > This indeed fixes building the port. However, if you want to build this in a
> > tinderbox (I have my own,but resorts.org also shows it) it wants to build
> > all ports in /usr/ports/lang and dies after a while. I do think this is
> > trigger by the TEST_DEPENDS line, expecially since portlints says:
> > 
> >     WARN: Makefile: no port directory /usr/ports/lang/${PERL_PORT} found,
> > even though it is listed in TEST_DEPENDS.
> > 
> > Anyway, for just using it with as a port it works fine. Thanks!
> > 
> >         jaap
> 
> Went ahead and removed the TEST_DEPENDS for now, we can add it back later.

Yes, taking out the TEST_DEPENDS takes enabling building in tinderboxes and on redports.org. Thanks again.