Bug 192125 - missing resource file in sysutils/xmbmon
missing resource file in sysutils/xmbmon
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Many People
Assigned To: John Marino
:
: 192051 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-26 05:30 UTC by turutani
Modified: 2014-08-12 10:38 UTC (History)
3 users (show)

See Also:


Attachments
patch for xmbmon (847 bytes, patch)
2014-07-26 10:19 UTC, turutani
no flags Details | Diff
xmbmon-205_14 patch (1.34 KB, patch)
2014-08-11 11:50 UTC, Muhammad Moinur Rahman
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description turutani 2014-07-26 05:30:54 UTC
sysutils/xmbmon misses resource file.
	https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=186332 might be caused
	by this, as I guess.

Fix:
here is a patch:

diff -urN xmbmon.orig/Makefile xmbmon/Makefile
--- xmbmon.orig/Makefile	2014-07-26 14:20:40.000000000 +0900
+++ xmbmon/Makefile	2014-07-26 14:25:27.000000000 +0900
@@ -32,7 +32,8 @@
 CLI_DESC=	CLI support only
 
 ASUS_PATCHFILES=	${PORTNAME}${PORTVERSION}_A7N8X-VM.patch
-X11_PLIST_FILES=	lib/X11/app-defaults/${PORTNAME} \
+X11_PLIST_FILES=	bin/xmbmon \
+			lib/X11/app-defaults/XMBmon \
 			man/man1/${PORTNAME}.1x.gz
 CLI_PLIST_FILES=	bin/mbmon \
 			man/man1/mbmon.1.gz
@@ -59,7 +60,9 @@
 do-install:
 .if ${PORT_OPTIONS:MX11}
 	${INSTALL_PROGRAM} ${WRKSRC}/xmbmon \
-		${STAGEDIR}${PREFIX}/lib/X11/app-defaults
+		${STAGEDIR}${PREFIX}/bin
+	${INSTALL_DATA} ${WRKSRC}/xmbmon.resources \
+		${STAGEDIR}${PREFIX}/lib/X11/app-defaults/XMBmon
 	${INSTALL_MAN} ${WRKSRC}/xmbmon.1x ${STAGEDIR}${MANPREFIX}/man/man1
 .endif
 .if ${PORT_OPTIONS:MCLI}
Comment 1 John Marino freebsd_committer 2014-07-26 06:50:07 UTC
This is a great example of why gratuitous and unnecessary use of ${PORTNAME} can bite you.  maybe this solves the grep x11 resource debate too....

tututani, it would help a committer immensely if you  re-add the patch as an attachment.  Committers can and do download patches and copy/paste from browser can be problematic and error-prone.  The request for patches as attachments goes for future PRs as well.

Remember, committers are free to choose another PR that's easier to process and may end up skipping yours for this simple reason, so I present this as advice.

Thanks,
John

(notifying maintainer)
Comment 2 turutani 2014-07-26 10:19:47 UTC
Created attachment 144996 [details]
patch for xmbmon

re-send a patch.
Comment 3 John Marino freebsd_committer 2014-08-11 08:53:43 UTC
ping for muhammad (I know he's back now) :)
Comment 4 Muhammad Moinur Rahman 2014-08-11 08:56:19 UTC
poudriere logs or resports log ?
Comment 5 John Marino freebsd_committer 2014-08-11 09:01:30 UTC
It's probably normal for the maintainer to apply the patch and run it through redports and/or poudriere themselves, although it would be a bonus if the submitter did it first.

I wouldn't expect that is common though.
Comment 6 Muhammad Moinur Rahman 2014-08-11 09:04:30 UTC
He He .. OK .. Let me merge 192125 and 192051 altogether and run it through my poudriere. Then I will create a single patch and submit it.

(In reply to John Marino from comment #5)
> It's probably normal for the maintainer to apply the patch and run it
> through redports and/or poudriere themselves, although it would be a bonus
> if the submitter did it first.
> 
> I wouldn't expect that is common though.
Comment 7 John Marino freebsd_committer 2014-08-11 09:09:36 UTC
*** Bug 192051 has been marked as a duplicate of this bug. ***
Comment 8 John Marino freebsd_committer 2014-08-11 09:10:25 UTC
Okay, I closed bug 192051 
Just add the combined patch here.
Comment 9 Muhammad Moinur Rahman 2014-08-11 11:50:08 UTC
Created attachment 145660 [details]
xmbmon-205_14 patch
Comment 10 Muhammad Moinur Rahman 2014-08-11 11:51:47 UTC
poudriere logs:
http://pdr.s.ubze.ro/bulk/latest-per-pkg/xmbmon/205_14/
Comment 11 John Marino freebsd_committer 2014-08-11 11:54:52 UTC
looks good; moving to patch-ready
Comment 12 commit-hook freebsd_committer 2014-08-12 10:35:10 UTC
A commit references this bug:

Author: marino
Date: Tue Aug 12 10:35:04 UTC 2014
New revision: 364691
URL: http://svnweb.freebsd.org/changeset/ports/364691

Log:
  sysutils/xmbmon: Fix missing resource file and eliminate rc.d in setuid

  Note this was really two (combined) PRs but dfilter is still busted and
  if I list two, never will post on bugzilla.

  PR:		192125
  Submitted by:	turutani(scphys.kyoto-u.ac.jp) & takefu (airport.fm)
  Approved by: 	maintainer (Muhammad Rahman)

Changes:
  head/sysutils/xmbmon/Makefile
Comment 13 John Marino freebsd_committer 2014-08-12 10:38:43 UTC
Done, thanks!