Bug 192258 - [patch] upgrade editors/openoffice-4 to version 4.1.0
Summary: [patch] upgrade editors/openoffice-4 to version 4.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-29 23:27 UTC by Don Lewis
Modified: 2014-08-05 16:58 UTC (History)
1 user (show)

See Also:


Attachments
patch to upgrade editors/openoffice to version 4.1.0 (24.79 KB, patch)
2014-07-29 23:27 UTC, Don Lewis
no flags Details | Diff
updated patch to upgrade editors/openoffice-4 to version 4.1.0 (35.55 KB, patch)
2014-08-04 16:49 UTC, Don Lewis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Don Lewis freebsd_committer 2014-07-29 23:27:23 UTC
Created attachment 145135 [details]
patch to upgrade editors/openoffice to version 4.1.0

The attached patch is not quite ready to commit, but it should be fairly close.

It has been build tested on 11.0-CURRENT i386 and 8.4-STABLE i386.  The port has been installed on 8.4-STABLE i386 and very lightly tested.  Only the default build options have tested.

The Makefile came from openoffice-devel, with some tweaks for the non-devel version of the port.  In particular, the configure options are identical to what is currently in openoffice-devel.  I haven't tried any tweaks to those.  The patch files, patch-* are from openoffice-devel with a few tweaks to get a clean build.

Portlint complains a lot, but that is not a new problem.  I fixed one of
the old warnings.

One unresolved issue at this point are these duplicate directory warnings during the install phase:

===>   Registering installation for apache-openoffice-4.1.0
pkg-static: duplicate directory listing: /usr/local/share/licenses/apache-openoffice-4.1.0/, ignoring
pkg-static: duplicate directory listing: /usr/local/share/licenses/, ignoring
pkg-static: (apache-openoffice-4.1.0) /usr/ports/editors/openoffice-4/work/stage//usr/local/openoffice-4.1.0/openoffice4/program/libofficebean.so - shared library libjawt.so not found
Installing apache-openoffice-4.1.0... done


If you want to test this patch, you will need to first download ApacheOpenOffice.ext_sources.4.1.0.r1589052.tar.bz2 to /usr/ports/distfiles/openoffice.  Before the port is officially upgraded, this file will need to
be uploaded to a better location and MASTER_SITES changed to point to its
location.  In the 4.0.1 version of the port, this location is ${MASTER_SITE_LOCAL:S@%SUBDIR%@maho/openoffice@}.
Comment 1 Baptiste Daroussin freebsd_committer 2014-07-30 05:44:20 UTC
Please do commit!
Comment 2 John Marino freebsd_committer 2014-07-30 07:30:49 UTC
Over to maintainer
Comment 3 Don Lewis freebsd_committer 2014-08-04 16:49:02 UTC
Created attachment 145365 [details]
updated patch to upgrade editors/openoffice-4 to version 4.1.0
Comment 4 Don Lewis freebsd_committer 2014-08-04 16:51:08 UTC
This updated patch is definitely a commit candidate.

* I uploaded the ext_sources tarball to local_distfiles, so make fetch now works

* portlint -a is now clean

* check-plist is now clean

* There is now only one stage Q/A warning:
  Warning: you may not need USES=desktop-file-utils
  The reason for this is that the .desktop files are installed under
  openoffice-4.1.0/openoffice4/share/xdg/ instead of share/applications

By default, this port downloads a bunch of additional distfiles to ext_sources during the build phase, in addition to the distfiles that were unpacked from the ext_sources tarball and came from the aoo svn repository.  While working on this port, I started running into build failures caused by download failures.  I addition, I noticed that it looked like unnecessary distfiles were being downloaded for components that would not be build because -with-system-whatever
was specified as a configure option.  To fix both problems, to take care of both
problems, I added the --disable-fetch-external configure option and added the following distfiles to the ext_sources tarball: boost, jpeg, mdds, and rhino.

I also sorted the CONFIGURE_ARGS and *_DEPEND.
Comment 5 Pedro F. Giffuni freebsd_committer 2014-08-05 06:02:48 UTC
Thank you for working on this.

While here, I think you can (and should) use graphics/silgraphite as a dependency and get rid of the corresponding ext_sources file.

Unfortunately, we cannot use the system boost due to a bug (which I PR'd but no one has followed up).

Also, FWIW, this version was somewhat buggy so there will be a new 4.1.1 release soon.
Comment 6 Don Lewis freebsd_committer 2014-08-05 06:25:11 UTC
(In reply to Pedro F. Giffuni from comment #5)
> Thank you for working on this.
> 
> While here, I think you can (and should) use graphics/silgraphite as a
> dependency and get rid of the corresponding ext_sources file.

I already enabled --with-system-graphite.  That distfile isn't in this
version of ext_sources.  There may be other stuff in there that can be nuked
as well, but I didn't look.  I basically just fetched the stuff that was in the ext_sources svn repo and added the missing distfiles noted above.

> Unfortunately, we cannot use the system boost due to a bug (which I PR'd but
> no one has followed up).

I spent way too much time battling boost and finally gave up.  I didn't know
there was a PR.

I am currently working on a patch so that --with-system-jpeg will hopefully
work.

Because of the downloaded distfile issue during build, I also looked at rhino and mdds.  There's no knob for rhino, and they are using a much older version of mdds, which seems to be incompatible with what we have in ports.

> Also, FWIW, this version was somewhat buggy so there will be a new 4.1.1
> release soon.

I'll keep an eye out.  Hopefully that upgrade will go more smoothly.
Comment 7 commit-hook freebsd_committer 2014-08-05 16:35:07 UTC
A commit references this bug:

Author: truckman
Date: Tue Aug  5 16:34:49 UTC 2014
New revision: 364119
URL: http://svnweb.freebsd.org/changeset/ports/364119

Log:
  Upgrade Apache OpenOffice to version 4.1.0.

  Fix all portlint -a and check-plist errors and warnings.

  Fix all but one stage-qa warnings.

  Disable --with-system-boost because it broke the build.

  Enable the --with-system-graphite, --with-system-hyphen, and
  --with-system-nss configure options.

  Add all distfiles that were previously downloaded during
  built to the ext_sources distfile.  Add the --disable-fetch-external
  configure flag to disable downloads during build.

  PR:		192258
  Approved by:	office@ (bapt)

Changes:
  head/editors/openoffice-4/Makefile
  head/editors/openoffice-4/distinfo
  head/editors/openoffice-4/files/extra-patch-libexttextcat-lingucomponent
  head/editors/openoffice-4/files/patch-configmgr
  head/editors/openoffice-4/files/patch-i123018
  head/editors/openoffice-4/files/patch-moz-freetype_header_relocation
  head/editors/openoffice-4/files/patch-nss
  head/editors/openoffice-4/files/patch-nss-gcc46
  head/editors/openoffice-4/files/patch-sal
  head/editors/openoffice-4/files/patch-vcl_source_glyphs_graphite_adaptors.cxx
  head/editors/openoffice-4/files/patch-webdav
  head/editors/openoffice-4/pkg-plist
Comment 8 Don Lewis freebsd_committer 2014-08-05 16:58:31 UTC
Patch committed.