Bug 192353 - databases/virtuoso: staged, and port maintainership changed
Summary: databases/virtuoso: staged, and port maintainership changed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-03 13:36 UTC by Michelle Sullivan
Modified: 2014-08-05 12:45 UTC (History)
2 users (show)

See Also:


Attachments
Patch to stage virtuoso and include readline for 11.x (15.82 KB, patch)
2014-08-03 13:36 UTC, Michelle Sullivan
no flags Details | Diff
145298: Patch to stage virtuoso and include readline for 11.x (14.75 KB, patch)
2014-08-04 01:05 UTC, Michelle Sullivan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michelle Sullivan 2014-08-03 13:36:03 UTC
Created attachment 145298 [details]
Patch to stage virtuoso and include readline for 11.x

Staged

Does not build on redports.org (can't complete testing - but works in poudriere locally)

Take maintainership (though for how long I don't know ;-) )

(not tested on 11.x as I don't have a 11.x - however should be correct as someone else wrote that)

====>> Deleting existing package: virtuoso-testing-6.1.6_4.tbz
====>> Sanity checking the repository
====>> Deleting stale symlinks
====>> Deleting empty directories
====>> Cleaning the build queue
====>> Building 1 packages using 1 builders
====>> Starting/Cloning builders
====>> Hit CTRL+t at any time to see build progress and stats
====>> [01] Starting build of databases/virtuoso-testing
====>> [01] Status for build databases/virtuoso-testing: check-sanity
====>> [01] Status for build databases/virtuoso-testing: pkg-depends
====>> [01] Status for build databases/virtuoso-testing: fetch-depends
====>> [01] Status for build databases/virtuoso-testing: fetch
====>> [01] Status for build databases/virtuoso-testing: checksum
====>> [01] Status for build databases/virtuoso-testing: distfiles
====>> [01] Status for build databases/virtuoso-testing: extract-depends
====>> [01] Status for build databases/virtuoso-testing: extract
====>> [01] Status for build databases/virtuoso-testing: patch-depends
====>> [01] Status for build databases/virtuoso-testing: patch
====>> [01] Status for build databases/virtuoso-testing: build-depends
====>> [01] Status for build databases/virtuoso-testing: lib-depends
====>> [01] Status for build databases/virtuoso-testing: configure
====>> [01] Status for build databases/virtuoso-testing: build
====>> [01] Status for build databases/virtuoso-testing: run-depends
====>> [01] Status for build databases/virtuoso-testing: stage
====>> [01] Status for build databases/virtuoso-testing: package
====>> [01] Status for build databases/virtuoso-testing: install-mtree
====>> [01] Status for build databases/virtuoso-testing: install
====>> [01] Finished build of databases/virtuoso-testing: Success
====>> Stopping 1 builders
Comment 1 John Marino freebsd_committer 2014-08-03 13:40:57 UTC
I prefer local poudriere actually.
Was this tested with "poudriere testport"?  or "poudriere bulk" with the -t option ?
Comment 2 Michelle Sullivan 2014-08-03 13:59:28 UTC
bulk
Comment 3 John Marino freebsd_committer 2014-08-03 14:01:23 UTC
would you mind running it one more time with bulk -t?

If it builds cleanly, then just say "passes with bulk -t too", and then I'll move it to patch ready
Comment 4 Michelle Sullivan 2014-08-03 14:05:44 UTC
that was 8.4-amd64 btw ... have added -t when 8.4 is finished it will move onto 9.0 and I will post the results.. (8.4 is started already so won't pick up the -t)

Michelle
Comment 5 John Marino freebsd_committer 2014-08-03 14:07:24 UTC
sounds good.  I'll wait.  :)
Comment 6 Michelle Sullivan 2014-08-04 01:05:29 UTC
Created attachment 145326 [details]
145298: Patch to stage virtuoso and include readline for 11.x

Started by upstream project "FreeBSD 8.4 amd64 Ports Builder Master controller..." build number 236
originally caused by:
 Started by user michelle
Building remotely on 84amd64 in workspace /home/jenkins/workspace/freebsd-8.4-amd64-builder
[freebsd-8.4-amd64-builder] $ /bin/sh -xe /var/tmp/hudson2350654501947540835.sh
+ fetch -o /tmp/slave_build.sh http://flashback.sorbs.net/packages/build_scripts/slave_build.sh
/tmp/slave_build.sh                                   1330  B   15 MBps
+ sh -xe /tmp/slave_build.sh
+ hostname
+ cut -f1 '-d '
+ POUDRIERE_JAIL=84amd64
+ uname -r
+ cut -f1 -d-
+ RELEASE=8.4
+ rm -f '/tmp/poudriere*' '/tmp/*gz'
+ mktemp /tmp/poudriere.XXXXXX
+ tmpfile=/tmp/poudriere.9Ppchj
+ mktemp /tmp/poudriere.XXXXX
+ tmpcfile=/tmp/poudriere.E8MKP
+ fetch -o /tmp/poudriere.9Ppchj http://flashback.sorbs.net/packages/pkg-8.4.lst
/tmp/poudriere.9Ppchj                                 8148  B   38 kBps
+ fetch -o /tmp/poudriere.E8MKP http://flashback.sorbs.net/packages/clean.lst
/tmp/poudriere.E8MKP                                    19  B  269 kBps
+ mktemp /tmp/poudriere.patch.XXXXXX
+ tmppfile=/tmp/poudriere.patch.a50jRk
+ fetch -o /tmp/poudriere.patch.a50jRk http://flashback.sorbs.net/packages/local-patches/patch-build-servers.sh
/tmp/poudriere.patch.a50jRk                           1922  B   12 MBps
+ chmod +x /tmp/poudriere.patch.a50jRk
+ /tmp/poudriere.patch.a50jRk
/tmp/poudriere.patch.nYz74a                           1300  B   16 MBps
/tmp/poudriere.patch.nYz74a                             16 kB   40 kBps
x virtuoso-testing/
x virtuoso-testing/files/
x virtuoso-testing/distinfo
x virtuoso-testing/Makefile
x virtuoso-testing/pkg-install
x virtuoso-testing/pkg-plist
x virtuoso-testing/pkg-descr
x virtuoso-testing/files/patch-binsrc-tests-Makefile.in
x virtuoso-testing/files/patch-binsrc-tests-biftest-thook.sh
x virtuoso-testing/files/patch-configure
x virtuoso-testing/files/virtuoso.in
/tmp/poudriere.patch.nYz74a                             15 kB   39 kBps
x virtuoso/
x virtuoso/Makefile
x virtuoso/distinfo
x virtuoso/files/
x virtuoso/pkg-descr
x virtuoso/pkg-plist
x virtuoso/files/patch-binsrc-tests-Makefile.in
x virtuoso/files/patch-binsrc-tests-biftest-thook.sh
x virtuoso/files/patch-configure
x virtuoso/files/virtuoso.in
x virtuoso/files/pkg-message.in
+ rm -f /tmp/poudriere.patch.a50jRk
+ poudriere jails -k -j 84amd64
====>> Jail 84amd64-default not running, but cleaning up anyway
====>> Umounting file systems
+ poudriere jails -k -j 84amd64ng
====>> Jail 84amd64ng-default not running, but cleaning up anyway
====>> Umounting file systems
+ poudriere bulk -f /tmp/poudriere.E8MKP -C -t -v -j 84amd64
====>> Creating the reference jail... done
====>> Mounting system devices for 84amd64-default
====>> Mounting ports/packages/distfiles
====>> Mounting ccache from: /var/cache/ccache
====>> Mounting packages from: /build/poudriere_data/packages/84amd64-default
====>> Mounting /var/db/ports from: /usr/local/etc/poudriere.d/84amd64-options
====>> Logs: /build/poudriere_data/logs/bulk/84amd64-default/2014-08-04_02h41m44s
====>> WWW: http://typhoon.isux.com/poudriere//bulk/84amd64-default/2014-08-04_02h41m44s
====>> Appending to make.conf: /usr/local/etc/poudriere.d/84amd64-make.conf
/etc/resolv.conf -> /build/poudriere_data/build/84amd64-default/ref/etc/resolv.conf
====>> Starting jail 84amd64-default
====>> Loading MOVED
====>> Calculating ports order and dependencies
.
.
.
====>> Sanity checking the repository
====>> Deleting stale symlinks
====>> Deleting empty directories
====>> Cleaning the build queue
====>> Building 1 packages using 1 builders
====>> Starting/Cloning builders
====>> Hit CTRL+t at any time to see build progress and stats
====>> [01] Starting build of databases/virtuoso
====>> [01] Status for build databases/virtuoso: check-sanity
====>> [01] Status for build databases/virtuoso: pkg-depends
====>> [01] Status for build databases/virtuoso: fetch-depends
====>> [01] Status for build databases/virtuoso: fetch
====>> [01] Status for build databases/virtuoso: checksum
====>> [01] Status for build databases/virtuoso: distfiles
====>> [01] Status for build databases/virtuoso: extract-depends
====>> [01] Status for build databases/virtuoso: extract
====>> [01] Status for build databases/virtuoso: patch-depends
====>> [01] Status for build databases/virtuoso: patch
====>> [01] Status for build databases/virtuoso: build-depends
====>> [01] Status for build databases/virtuoso: lib-depends
====>> [01] Status for build databases/virtuoso: configure
====>> [01] Status for build databases/virtuoso: build
====>> [01] Status for build databases/virtuoso: run-depends
====>> [01] Status for build databases/virtuoso: stage
====>> [01] Status for build databases/virtuoso: package
====>> [01] Status for build databases/virtuoso: install-mtree
====>> [01] Status for build databases/virtuoso: install
====>> [01] Status for build databases/virtuoso: deinstall
====>> [01] Finished build of databases/virtuoso: Success
====>> Stopping 1 builders

(note the -C -t)

New patch attached as I managed to remove the pkg-install
Comment 7 John Marino freebsd_committer 2014-08-04 05:55:20 UTC
nice, thanks!
Comment 8 John Marino freebsd_committer 2014-08-05 07:42:17 UTC
FYI, the patch didn't apply until I backed out the last commit (by peter) and even then it applied with fuzz.

But marching on ...
Comment 9 John Marino freebsd_committer 2014-08-05 09:19:33 UTC
Is this untestable by redports?

Just to be sure, I set it to 4 builders.  1 failed the other 3 won't finish (90+ minutes so far):

https://redports.org/buildarchive/20140805074600-30464/
Comment 10 Michelle Sullivan 2014-08-05 11:48:59 UTC
No it won't test on redports - it tries to test the server when building the tools.  Startup of the server fails (or the network is disabled so it can't connect to the test server)... net result is the logs show its in the test phase and continuously times out whilst trying to connect to the test server.

My poudriere has no such restrictions and it compiles as above.

Full logs of it here: http://flashback.sorbs.net/logs/92amd64.isux.com/archive/logs/2014-08-04_16h16m13s/logs/virtuoso-6.1.6_4.log
Comment 11 John Marino freebsd_committer 2014-08-05 11:55:00 UTC
okay.  I'll commit it as it is.
Comment 12 Michelle Sullivan 2014-08-05 11:58:34 UTC
What was the backed out patch and fuzz you saw?

If you want the complete 'my port' to compare.. http://flashback.sorbs.net/packages/virtuoso.tar.gz
Comment 14 John Marino freebsd_committer 2014-08-05 12:13:27 UTC
It looks like your diff says NO_STAGE line didn't exist (line 51).  You must have removed it, and generated diff based on that.  I'll need that compare file after all just to be sure that's the last of it.
Comment 15 commit-hook freebsd_committer 2014-08-05 12:22:54 UTC
A commit references this bug:

Author: marino
Date: Tue Aug  5 12:22:18 UTC 2014
New revision: 364092
URL: http://svnweb.freebsd.org/changeset/ports/364092

Log:
  Stage databases/virtuoso and assign maintainership to michelle

  This can't be tested in Redports due to the attempt to start the service
  during the build, but it does pass local poudriere builds of the submitter.

  PR:		192353
  Submitted by:	Michelle Sullivan

Changes:
  head/databases/virtuoso/Makefile
  head/databases/virtuoso/files/pkg-message.in
  head/databases/virtuoso/pkg-install
  head/databases/virtuoso/pkg-plist
Comment 16 Michelle Sullivan 2014-08-05 12:42:47 UTC
Ahh yes, my mistake - I removed the NO_STAGE before I copied it to see how much work would be involved.  Guess I forgot to restore it before the cp -rpv virtuoso virtuoso.orig

Sorry

Michelle
Comment 17 John Marino freebsd_committer 2014-08-05 12:45:16 UTC
Okay, thanks!