Bug 192605 - graphics/qgis: Add support for SQlite/SpatiaLite with DB Manager
Summary: graphics/qgis: Add support for SQlite/SpatiaLite with DB Manager
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: easy, needs-qa, patch
: 192624 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-12 04:48 UTC by lbartoletti
Modified: 2014-11-09 14:50 UTC (History)
3 users (show)

See Also:


Attachments
Add py-spatialite (495 bytes, patch)
2014-09-02 19:03 UTC, Rainer Hurling
rhurlin: maintainer-approval+
Details | Diff
QGIS 2.4.0, several fixes and improvements (1.42 KB, patch)
2014-09-09 08:33 UTC, Rainer Hurling
rhurlin: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lbartoletti 2014-08-12 04:48:50 UTC
Hello,

Can you add spatialite python bindings into RUN_DEPENDS ?

With databases/pyspatialite you can use SQlite/SpatiaLite with DB Manager.

QGis recognize automatically when pyspatialite is installed. Maybe (i can't test now) you can patch like this :

RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/osgeo/gdal.pyc:${PORTSDIR}/graphics/py-gdal \
${PYTHON_SITELIBDIR}/pyspatialite/dbapi2.pyc:${PORTSDIR}/databases/pyspatialite

Regards
Comment 1 John Marino freebsd_committer 2014-08-12 06:20:51 UTC
Add maintainer to CC.
Comment 2 Rainer Hurling 2014-09-02 19:03:05 UTC
Created attachment 146692 [details]
Add py-spatialite

Thanks for the suggestion of using py-spatialite. Sorry of the delay, I was in vacation and after it had some trouble with the login of Bugzilla.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2014-09-08 06:57:15 UTC
A couple of things to improve:

* Fix typoe (UN_DEPENDS)
* Update Python dependencies to form: ${PYTHON_PKGNAMEPREFIX}name>[compatible-version]

If possible please also include the following QA results to promote quick 
resolution:

 * Attach successful poudriere testport, or redports.org build logs
 * Attach portlint -AC output (after addressing any outstanding issues)
Comment 4 Rainer Hurling 2014-09-09 08:33:59 UTC
Created attachment 147099 [details]
QGIS 2.4.0, several fixes and improvements

###  This patch includes
###  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=192624

Enhancements are:
- Add python and pgsql to USES=
- Correct grass dependency version: 6.4.3 to 6.4.4 (bug 192624)
- Ensure presence of GRASS, if option enabled
- Use ${PYTHON_PKGNAMEPREFIX}name>[compatible-version] scheme
- Broken on FreeBSD < 9.0, if option GRASS enabled (utempter.h problem)
- Correct typo for 'RUN_DEPENDS' in previous patch, sorry.

-------------------------------------------------------

#portlint -AC
WARN: /usr/ports/graphics/qgis/pkg-plist: [495]: enumerating info files
in the plist is deprecated in favor of adding info files into the
Makefile using the INFO macro.
0 fatal errors and 1 warnings found.

This warning is wrong, because it relates to qgis.g.info, a QGIS pendant
for the GRASS command 'g.info'. It is not an info file.

-------------------------------------------------------

Tested with RedPorts. Mostly all seems fine, if build with standard options:
[1] https://redports.org/buildarchive/20140909053138-45136

RedPorts errors for 10.x builds are irritating ("Cannot
open /usr/ports/Mk/bsd.port.mk"). This only happens some times, and some times not, see e.g. [3].

If GRASS and MAPSERVER options are enabled, 8.x is broken and other versions build as intended:
[2] https://redports.org/buildarchive/20140909050031-83898
[3] https://redports.org/buildarchive/20140909050813-54492

All in all, I think the port works mostly correct now and probably there is something
wrong in RedPorts (10.x, QATty) at the moment?
Comment 5 John Marino freebsd_committer 2014-09-09 08:40:12 UTC
*** Bug 192624 has been marked as a duplicate of this bug. ***
Comment 6 Lars Engels freebsd_committer 2014-11-09 14:50:56 UTC
Fixed with current release according to maintainer.