Bug 192736 - devel/googletest: improve bsd support
Summary: devel/googletest: improve bsd support
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: John Marino
URL:
Keywords:
Depends on: 187562
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-17 09:26 UTC by Jan Beich
Modified: 2014-11-25 17:38 UTC (History)
1 user (show)

See Also:


Attachments
v0 (6.81 KB, patch)
2014-08-17 09:26 UTC, Jan Beich
no flags Details | Diff
poudriere testport log (10.0R amd64) (228.62 KB, text/plain)
2014-08-17 09:27 UTC, Jan Beich
no flags Details
poudriere testport log (9.3R i386) (146.31 KB, text/plain)
2014-08-17 09:31 UTC, Jan Beich
no flags Details
work in progress for update (10.15 KB, patch)
2014-11-24 20:59 UTC, John Marino
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-08-17 09:26:08 UTC
Created attachment 145907 [details]
v0

- enable pthreads by default
- enable death tests
- enable socket streaming
- implement GetThreadCount for death tests
- disable streaming tests that fail with old gcc on 9.x

Not upstreamed because of privacy-hostile walled garden there.
Comment 1 Jan Beich freebsd_committer 2014-08-17 09:27:10 UTC
Created attachment 145908 [details]
poudriere testport log (10.0R amd64)
Comment 2 Jan Beich freebsd_committer 2014-08-17 09:31:08 UTC
Created attachment 145910 [details]
poudriere testport log (9.3R i386)
Comment 3 Jan Beich freebsd_committer 2014-10-31 01:09:27 UTC
The patch is for googletest-1.7.0.
Comment 4 John Marino freebsd_committer 2014-11-24 19:24:17 UTC
I'll reset the maintainer while I'm at it.
Comment 5 John Marino freebsd_committer 2014-11-24 20:59:45 UTC
Created attachment 149790 [details]
work in progress for update

This needs *a lot* more work.
It was basically a request to update the port without all the normal patches.  I did try, but the requirements of 1.7 are much different than 1.5

not only is it now a zip file the regression test will not work (it requires cmake) and worse: It refuses to honor "make install", saying this is "dangerous" and to read "README".  I tried but it wasn't immediately clear, so i'm kicking it back.

I am attaching the state of the port as I left it.  Please apply the patch to a current try and fix "regression-test" and "do-install" targets to continue, thanks.
Comment 6 Jan Beich freebsd_committer 2014-11-25 00:38:11 UTC
Please, don't pollute this bug with updates. See attachment 148808 [details] for how I fixed/improved regression-test and bug 187562 comment 17 for issues with cmake approach.
Comment 7 John Marino freebsd_committer 2014-11-25 07:06:30 UTC
The problem is that I had no idea there was another PR --- the description doesn't mention it at all.  the only clue is the "depends on" line which I didn't see.


This PR doesn't stand by itself in a vacuum, and that caused great confusion.  It also wasted a good chunk of my time. :(
Comment 8 Jan Beich freebsd_committer 2014-11-25 08:41:01 UTC
(In reply to John Marino from comment #7)
> The problem is that I had no idea there was another PR --- the description
> doesn't mention it at all.  the only clue is the "depends on" line which I
> didn't see.

Er, different experience in using Bugzilla? I tend to (ab)use blocking bugs like in Mozilla land. But with ports granular changes are often affected with rebase churn, at least in Mk/*, Makefile and pkg-plist.

> This PR doesn't stand by itself in a vacuum, and that caused great
> confusion.

It requires a separate more involved review, in no rush to land after bug 187562 and easier to bisect. Also, can be applied as is upstream and/or in PkgSrc.

regression-test works fine *without* the patch.

> It also wasted a good chunk of my time. :(

Bug 195059 should help other people to not waste time as well.
Comment 9 John Marino freebsd_committer 2014-11-25 08:48:05 UTC
(In reply to Jan Beich from comment #8)
> (In reply to John Marino from comment #7)
> > The problem is that I had no idea there was another PR --- the description
> > doesn't mention it at all.  the only clue is the "depends on" line which I
> > didn't see.
> 
> Er, different experience in using Bugzilla? I tend to (ab)use blocking bugs
> like in Mozilla land. But with ports granular changes are often affected
> with rebase churn, at least in Mk/*, Makefile and pkg-plist.


It's just one little line, it's easy to miss.  blocking / depends PRs aren't the majority.

> 
> regression-test works fine *without* the patch.

the README says cmake is required though.

> 
> > It also wasted a good chunk of my time. :(
> 
> Bug 195059 should help other people to not waste time as well.

To clarify:
Because it wasn't immediately obvious that this PR was a follow-on to another PR, I tried to use it by itself -- that is, I was modifying makefile, distinfo etc to use a complex patch.  By going the extra mile instead of just immediately asking, "what's going on here", I wasted a bunch of my time.

Actually this isn't the first time.  I'm just saying, had the description specifically mentioned the other PR in addition to listing in on the depends line there wouldn't have been any confusion on my part.

I was just too eager to help resolve this cslung backlog
Comment 10 Jan Beich freebsd_committer 2014-11-25 09:07:07 UTC
(In reply to John Marino from comment #9)
> Because it wasn't immediately obvious that this PR was a follow-on to
> another PR, I tried to use it by itself

The patch is, not the bug. I've just made no attempt to provide a patch rebased against 1.5.0. Being lazy to cope with rebase churn I've just edited "Depends on" field later.
Comment 11 John Marino freebsd_committer 2014-11-25 14:02:43 UTC
We'll take care of this in bug 187562.
Comment 12 commit-hook freebsd_committer 2014-11-25 17:38:54 UTC
A commit references this bug:

Author: marino
Date: Tue Nov 25 17:38:12 UTC 2014
New revision: 373421
URL: https://svnweb.freebsd.org/changeset/ports/373421

Log:
  devel/googlemock, devel/googletest: Upgrade version 1.5 => 1.7

  As part of the upgrade process:
    - copy shebangfix and regression-test from googletest to googlemock
    - convert regression-test to TEST option for better integration with
      poudriere and visibility for users
    - make sure configure detects python2 to follow shebangfix
    - add LICENSE=BSD3CLAUSE (idea from comment 0)
    - strip libs per stage-qa
    - enable pthreads by default in devel/googletest
    - enable death tests in devel/googletest
    - enable socket streaming in devel/googletest
    - implement GetThreadCount for death tests in devel/googletest
    - disable streaming tests that fail with old gcc on 9.x in googletest
    - depend on googletest in googlemock as -lgmock fails otherwise [1]
    - pass maintainership to the persistent submitter [2]

  PR:		187562
  PR:		192736 [2]
  PR:		192042 [1]
  Approved by:	maintainer timeout (~8 months)
  Submitted by:	rakuco [1]
  Submitted by:	Jan Beich <jbeich@vfemail.net> [2]

Changes:
  head/devel/googlemock/Makefile
  head/devel/googlemock/distinfo
  head/devel/googlemock/pkg-plist
  head/devel/googletest/Makefile
  head/devel/googletest/distinfo
  head/devel/googletest/files/patch-bsd-defines
  head/devel/googletest/files/patch-include_gtest_internal_gtest-port.h
  head/devel/googletest/pkg-plist