Bug 192757 - [build] libexec/telnetd: fails make checkdpadd
Summary: [build] libexec/telnetd: fails make checkdpadd
Status: Closed DUPLICATE of bug 192730
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-17 18:25 UTC by Enji Cooper
Modified: 2014-08-19 18:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2014-08-17 18:25:00 UTC
LDFLAGS should probably point to ${.OBJDIR}/../../lib/libtelnet (or the program should be converted over to use a private library?).

===> libexec/telnetd (checkdpadd)
/usr/src/libexec/telnetd
DPADD -> -lutil -ltermcapw -ltelnet -lmp -lcrypto -lcrypt -lpam
LDADD -> -lutil -ltermcapw /usr/obj/usr/src/libexec/telnetd/../../lib/libtelnet/libtelnet.a -lmp -lcrypto -lcrypt -lpam
Comment 1 Enji Cooper freebsd_committer 2014-08-19 18:36:10 UTC
The underlying issue here, with rcs, gnu/*/binutils, *bin*/clang, is the same underlying issue as bug 192730. Duping appropriately.

*** This bug has been marked as a duplicate of bug 192730 ***