Bug 193422 - [NEW PORT] games/openra: Command & Conquer: Red Alert engine written in Mono
Summary: [NEW PORT] games/openra: Command & Conquer: Red Alert engine written in Mono
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords: patch
Depends on: 193426
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-07 11:11 UTC by Jan Beich
Modified: 2014-10-31 13:17 UTC (History)
1 user (show)

See Also:


Attachments
shar (3.00 KB, text/plain)
2014-09-07 11:11 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (10.0R amd64) (25.79 KB, text/plain)
2014-09-07 11:13 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (9.3R i386) (25.75 KB, text/plain)
2014-09-07 11:53 UTC, Jan Beich
no flags Details
TEST=on build log (29.97 KB, text/plain)
2014-09-07 13:18 UTC, Jan Beich
no flags Details
shar, v2 (5.52 KB, text/plain)
2014-09-20 18:34 UTC, Jan Beich
no flags Details
TEST=on build log (31.01 KB, text/plain)
2014-09-20 18:36 UTC, Jan Beich
no flags Details
DOCS=off build log (26.46 KB, text/plain)
2014-09-20 18:44 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (10.0R amd64) (26.83 KB, text/plain)
2014-09-20 18:50 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (9.3R i386) (26.83 KB, text/plain)
2014-09-20 19:30 UTC, Jan Beich
no flags Details
shar, v3 (5.89 KB, text/plain)
2014-09-28 20:23 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (9.3R i386) (30.02 KB, text/plain)
2014-09-28 20:24 UTC, Jan Beich
no flags Details
shar, v4 (7.26 KB, text/plain)
2014-10-30 04:04 UTC, Jan Beich
no flags Details
TEST=on build log (33.71 KB, text/plain)
2014-10-30 04:05 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (8.4R amd64) (29.84 KB, text/plain)
2014-10-30 04:09 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (9.3R i386) (29.66 KB, text/plain)
2014-10-30 04:11 UTC, Jan Beich
no flags Details
shar, v4 (6.18 KB, text/plain)
2014-10-30 04:15 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (10.0R amd64) (30.29 KB, text/plain)
2014-10-30 04:54 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-09-07 11:11:28 UTC
Created attachment 146993 [details]
shar

OpenRA is a Libre/Free Real Time Strategy project that recreates the
classic Command & Conquer titles.

We include recreations of C&C (Tiberian Dawn), C&C: Red Alert, and
Dune 2000. These are not intended to be perfect copies, but instead
combine the classic gameplay of the originals with modern improvements
such as unit veterancy and the fog of war.

WWW: http://www.openra.net
Comment 1 Jan Beich freebsd_committer 2014-09-07 11:13:14 UTC
Created attachment 146994 [details]
|poudriere testport -P| log (10.0R amd64)
Comment 2 Jan Beich freebsd_committer 2014-09-07 11:14:38 UTC
$ portlint -AC
looks fine.
Comment 3 Jan Beich freebsd_committer 2014-09-07 11:20:29 UTC
TEST option has a caveat:

====>> Checking for filesystem violations... done
====>> Error: Filesystem touched during build:
extra: root/.openra

https://github.com/mono/mono/pull/371
Comment 4 Jan Beich freebsd_committer 2014-09-07 11:23:51 UTC
Please, remove OpenRA entry from
https://wiki.freebsd.org/WantedPorts
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2014-09-07 11:28:22 UTC
Thanks for your submission Jan

If the TEST option is for you (the maintainer), then you may use an alternate target, such as regression-test:

If the test option is for the user, then:

- Ensure the description is correct and meaningful specifically for this port
- That everything else as per a standard build, works normally

Creating files outside of the stage directory will need to be addressed prior to this port being committed.

Please update your patch accordingly
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2014-09-07 11:29:59 UTC
Wiki entry for OpenRA updated
Comment 7 Jan Beich freebsd_committer 2014-09-07 11:35:02 UTC
I wish regression-test would die. It's not run at all in poudriere, not visibile to user and too often doesn't properly pass make environment or pulls dependencies.

TEST is disabled by default. Fixing cleanup would require patching lang/mono to properly respect HOME.
Comment 8 Jan Beich freebsd_committer 2014-09-07 11:53:01 UTC
Created attachment 146998 [details]
|poudriere testport -P| log (9.3R i386)

pkg(8) and bsd.port.mk cannot agree on what is ARCH-agnostic package ABI.

===>   Registering installation for openra-20140722
pkg-static: DEVELOPER_MODE: Notice: arch "freebsd:10:*" -- no architecture specific files found:
**** could this package use a wildcard architecture?
Comment 9 Jan Beich freebsd_committer 2014-09-07 13:18:00 UTC
Created attachment 147008 [details]
TEST=on build log

after applying bug 193426
Comment 10 Kubilay Kocak freebsd_committer freebsd_triage 2014-09-07 14:40:59 UTC
Very nice :)
Comment 11 Jan Beich freebsd_committer 2014-09-20 18:34:47 UTC
Created attachment 147505 [details]
shar, v2

- improve description based on debian package
- add DOCS option
- fix build with lang/mono 3.6.x
Comment 12 Jan Beich freebsd_committer 2014-09-20 18:36:35 UTC
Created attachment 147506 [details]
TEST=on build log
Comment 13 Jan Beich freebsd_committer 2014-09-20 18:44:34 UTC
Created attachment 147507 [details]
DOCS=off build log
Comment 14 Jan Beich freebsd_committer 2014-09-20 18:50:51 UTC
Created attachment 147508 [details]
|poudriere testport -P| log (10.0R amd64)
Comment 15 Jan Beich freebsd_committer 2014-09-20 19:30:34 UTC
Created attachment 147511 [details]
|poudriere testport -P| log (9.3R i386)
Comment 16 Jan Beich freebsd_committer 2014-09-28 20:23:31 UTC
Created attachment 147768 [details]
shar, v3

kill @dirrmtry (per CHANGES from 20140922) and add ZENITY option for crash dialog
Comment 17 Jan Beich freebsd_committer 2014-09-28 20:24:39 UTC
Created attachment 147769 [details]
|poudriere testport -P| log (9.3R i386)
Comment 18 Jan Beich freebsd_committer 2014-09-28 21:51:09 UTC
No need to wait for bug 193426 if an option is non-default.
Comment 19 John Marino freebsd_committer 2014-10-27 15:50:56 UTC
I'm not quite sure how Jan moved this to "patch-ready" himself, but I'll take it especially since it's DFLY friendly. :)
Comment 20 Jan Beich freebsd_committer 2014-10-30 04:04:03 UTC
Created attachment 148785 [details]
shar, v4

- update to release-20141029
- improve crash dialog fallback
- workaround mono bug since 3.10.0
Comment 21 Jan Beich freebsd_committer 2014-10-30 04:05:02 UTC
Created attachment 148786 [details]
TEST=on build log
Comment 22 Jan Beich freebsd_committer 2014-10-30 04:09:50 UTC
Created attachment 148787 [details]
|poudriere testport -P| log (8.4R amd64)
Comment 23 Jan Beich freebsd_committer 2014-10-30 04:11:11 UTC
Created attachment 148788 [details]
|poudriere testport -P| log (9.3R i386)
Comment 24 Jan Beich freebsd_committer 2014-10-30 04:15:59 UTC
Created attachment 148789 [details]
shar, v4

Forgot to cleanup *~ backup files.
Comment 25 Jan Beich freebsd_committer 2014-10-30 04:54:03 UTC
Created attachment 148790 [details]
|poudriere testport -P| log (10.0R amd64)
Comment 26 commit-hook freebsd_committer 2014-10-31 12:55:08 UTC
A commit references this bug:

Author: marino
Date: Fri Oct 31 12:54:20 UTC 2014
New revision: 371809
URL: https://svnweb.freebsd.org/changeset/ports/371809

Log:
  Add new port games/openra

  PR:		193422
  Submitted by:	Jan Beich

  A reimplementation of the Command & Conquer: Red Alert game engine
  using .NET/Mono, OpenGL, OpenAL and SDL. It includes reimagninations
  of Command & Conquer: Red Alert, Command & Conquer: Tiberian Dawn as
  well as Dune 2000. These combine the classic gameplay of the originals
  with modern improvements such as unit veterancy and the fog of war.

Changes:
  head/games/Makefile
  head/games/openra/
  head/games/openra/Makefile
  head/games/openra/distinfo
  head/games/openra/files/
  head/games/openra/files/patch-Makefile
  head/games/openra/files/patch-xamarin-bug23319
  head/games/openra/pkg-descr
  head/games/openra/pkg-plist
Comment 27 John Marino freebsd_committer 2014-10-31 13:17:03 UTC
Nice work, thanks!