Bug 193558 - rm -rf should not fail if multiple processes deleting same directory
Summary: rm -rf should not fail if multiple processes deleting same directory
Status: Closed DUPLICATE of bug 192490
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.0-PRERELEASE
Hardware: i386 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-11 12:19 UTC by Radim Kolar
Modified: 2014-10-02 06:20 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Radim Kolar 2014-09-11 12:19:54 UTC
if you delete work directory used for building port with multiple rm with -rf flags, all instances of rm after some time fails with:

(hsn@sanatana:pts/0):~/myports/spark% rm -rf work
rm: fts_read: No such file or directory

as i see it, rm -f should never hard fail during delete process, just ignore error (directory deleted by other process) and move on.
Comment 1 Jilles Tjoelker freebsd_committer 2014-09-12 14:44:13 UTC
I think SVN r268376 (in head only) should fix this.
Comment 2 Enji Cooper freebsd_committer 2014-10-02 06:20:52 UTC

*** This bug has been marked as a duplicate of bug 192490 ***